Remove extra kernel

Questions about applications and software
Forum rules
Before you post please read this

Remove extra kernel

Postby Spix73 on Mon Jan 06, 2014 6:16 pm

Hi everyone, I'm new to the forum.
I use Mint 15 Cinnamon 32bit on an Asus eeepc 900. The 'inxi -Fxz' command reads:
Code: Select all
System:    Host: ee-spix Kernel: 3.8.0-19-generic i686 (32 bit, gcc: 4.7.3) Desktop: Gnome Distro: Linux Mint 15 Olivia
Machine:   System: ASUSTeK product: 900 version: 0601
           Mobo: ASUSTeK model: 900 version: x.xx Bios: American Megatrends version: 0601 date: 05/26/2008
CPU:       Single core Intel Celeron M (-UP-) cache: 512 KB flags: (nx sse sse2) bmips: 1800.2 clocked at 900.103 MHz
Graphics:  Card: Intel Mobile 915GM/GMS/910GML Express Graphics Controller bus-ID: 00:02.0
           X.Org: 1.13.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1024x600@59.5hz
           GLX Renderer: Mesa DRI Intel 915GM x86/MMX/SSE2 GLX Version: 1.4 Mesa 9.1.7 Direct Rendering: Yes
Audio:     Card: Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture ver: k3.8.0-19-generic
Network:   Card-1: Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express) driver: ath5k bus-ID: 01:00.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Qualcomm Atheros Attansic L2 Fast Ethernet driver: atl2 ver: 2.2.3 bus-ID: 03:00.0
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 20.2GB (48.5% used) 1: id: /dev/sda model: ASUS size: 4.0GB
           2: id: /dev/sdb model: ASUS size: 8.1GB 3: USB id: /dev/sdc model: CardReader_SD0 size: 8.1GB
Partition: ID: / size: 4.5G used: 4.2G (99%) fs: ext4 ID: /home size: 987M used: 539M (58%) fs: ext4
           ID: swap-1 size: 2.00GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 53.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 1290
Info:      Processes: 142 Uptime: 1 day Memory: 384.4/2008.3MB Runlevel: 2 Gcc sys: 4.7.3 Client: Shell inxi: 1.8.4

It works fine but some time ago I made some mess with the kernel. Following the suggestions I had on another forum (unfortunately it's not writen in English, you could try with Google Translate), I inadvertedly disabled the kernel, Mint entered in 'software rendering' mode and then I've been helped to reinstall it. Since then, the pc works good but at each boot I see GRUB starting with the following options:
Code: Select all
Linux Mint 15 Cinnamon 32-bit, 3.8.0-19 generic (/dev/sda1)
Linux Mint 15 Cinnamon 32-bit, 3.8.0-19 generic (/dev/sda1) -- recovery mode
Memory test (memtest86+)
Memory test (memtest86+, serial console 115200)
Linux Mint 15 Olivia (15)
Advanced Options for Linux Mint 15 Olivia (15)

I've tried both 'Cinnamon' and 'Olivia' options but they really seem to be exactly the same. Every object in my desktop appears in both. So, since I have some disk space problems, I'd like to remove the least useful kernel - of course, without having another kernel crash. So:
- Which kernel should I remove between 'Cinnamon' and 'Olivia'?
- How should I do it?
- After removing the extra kernel, will the GRUB screen be skipped at boot? If not, how should I disable it?

Thanks a lot to everyone!
Marco
Linux Mint 15 Cinnamon
eee-900 2GB RAM
Spix73
Level 1
Level 1
 
Posts: 3
Joined: Mon Jan 06, 2014 4:40 pm

Linux Mint is funded by ads and donations.
 

Re: Remove extra kernel

Postby computerbob on Mon Jan 06, 2014 6:32 pm

My boot folder is 78.5MB
That extra kernel is not going to cause space problems.
The last time I did the kernel update to 3.12.0 and I knew I had 3.11.6 still in there
I did the kernel removal for 3.12 which is sudo apt-get purge linux-image-3.12*
When I rebooted, I had no kernel and had to do a complete reload.

If were you, look at the system monitor / the file systems tab
computerbob
Level 4
Level 4
 
Posts: 284
Joined: Wed Jan 01, 2014 1:55 pm

Re: Remove extra kernel

Postby kyphi on Mon Jan 06, 2014 11:36 pm

To identify all kernels in a terminal window type
Code: Select all
ls /boot

To identify which kernel is in use type
Code: Select all
uname -a

Then go to synaptic and delete those that are not used - some people recommend that you should keep two but this would not be necessary if your current kernel has functioned without any problems. Please make sure that you do not delete the currently used kernel.
The items to delete are
1. linux-image-x.x.xx-generic
2. linux-headers-x.x.xx-generic
3. linux-headers-x.x.xx

grub should update automatically after kernel removal.
If all your entries lead to the same goal, you could install "grub customizer" which will let you remove the surplus entries. You will find it in the Launchpad ppa - here is the installation sequence:
Code: Select all
sudo add-apt-repository ppa:danielrichter2007/grub-customizer

Code: Select all
sudo apt-get update

Code: Select all
sudo apt-get install grub-customizer

I know that drive space is at a premium in the eeepc (I had a 700 series and currently still have a 1000H series - the latter runs fairly well with the xfce desktop).
kyphi
Level 5
Level 5
 
Posts: 571
Joined: Sat Jul 09, 2011 1:14 am
Location: Australia

Re: Remove extra kernel

Postby Spix73 on Tue Jan 07, 2014 8:03 pm

First of all thanks to everyone for your answers.
Now a briefing with some order.

Giving 'ls /boot' command the answer is:
Code: Select all
abi-3.8.0-19-generic     grub                         memtest86+.bin            System.map-3.8.0-19-generic
config-3.8.0-19-generic  initrd.img-3.8.0-19-generic  memtest86+_multiboot.bin  vmlinuz-3.8.0-19-generic

/boot folder is 251 items, 44.4 MB (free space 90 MB).
Giving 'uname -a' I have:
Code: Select all
Linux ee-spix 3.8.0-19-generic #30-Ubuntu SMP Wed May 1 16:36:13 UTC 2013 i686 i686 i686 GNU/Linux

whatever it means, I tried to check Synaptic to see what it was telling me. After entering system pwd, I saw the program window, but it freezed still empty and a warning window appeared in front of it, displaying the following message:
Code: Select all
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/linux-mint.froonix.org_dists_olivia_import_i18n_Translation-en
E: Impossible to analyze or to open the list of packages or status file. (*)
E: _cache->open() failed, please report.

(*) This single row was a translation of mine from Italian to English.
After clicking OK, the whole program shuts down. I tried again but the behavior was the same.
I don't have (yet) grub customizer but I do have Ububtu Tweak, so I checked it (it started at least) and entered into 'Administration > Application center' (my translation). It didn't crash but under 'installed applications' showed an empty list. After Synaptic I tried even with gksu mintinstall (applications manager) and after giving pwd, it didn't start at all.
It seems like the system has lost track of the installed packages list, but still works.

Aside from this and about the original doubt about double kernel, and considering the answer to 'uname -a', it seems that both options 'Cinnamon' and 'Olivia' lead to the same kernel, that is, the only one that's installed on the system.
By the way, in origin I installed 'Mint 15 Cinnamon' but it looks (unchanged after kernel reinstall) really similar to xfce look. Anyway I'm a newbie about distros.
Do you think (as I do) that those two problems (the packages mess and the fake double kernel) are related? How should I solve everything?

I didn't remember to tell it first, but you should also consider that during my first install on this machine, I created a specific partition for /home folder, so that I could format only root folder one day, reinstall OS without overwriting /home and finding not only my documents, but also my system settings and applications already up and running since first install. Anyway I've not formatted it yet, so I don't know how it really goes.
Marco
Linux Mint 15 Cinnamon
eee-900 2GB RAM
Spix73
Level 1
Level 1
 
Posts: 3
Joined: Mon Jan 06, 2014 4:40 pm

Re: Remove extra kernel

Postby kyphi on Tue Jan 07, 2014 11:45 pm

You only have one kernel installed = 3.8.0-19 so there is nothing to remove other than the superfluous grub menu entry.
You can edit /etc/default/grub (and run sudo update-grub afterwards) but it would be far simpler and safer to install grub-customizer and effect the grub menu changes that way. This is not within the capabilities of ubuntu-tweak. The error messages will most likely disappear when you have done that.

Establishing a separate partition for /home is good policy, so that you would have 3 partitions = /, swap and /home. That way you can re-install the operating system into / without the loss of your personal files.

Good Luck, Spix73.
kyphi
Level 5
Level 5
 
Posts: 571
Joined: Sat Jul 09, 2011 1:14 am
Location: Australia

Re: Remove extra kernel

Postby Spix73 on Fri Jan 10, 2014 5:27 am

Hi, the installation of Grub Customizer did not work:
Code: Select all
spix@ee-spix ~ $ sudo add-apt-repository ppa:danielrichter2007/grub-customizer
[sudo] password for spix:
You are about to add the following PPA to your system:
 This PPA contains the latest release of Grub Customizer.

sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update
sudo apt-get install grub-customizer
 More info: https://launchpad.net/~danielrichter2007/+archive/grub-customizer
Press [ENTER] to continue or ctrl-c to cancel adding it

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.UdWJQT41CB --trustdb-name /etc/apt//trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv-keys 3F055C03
gpg: request for key 3F055C03 from server hkp keyserver.ubuntu.com
gpg: key 3F055C03: public key «Launchpad PPA for Daniel Richter» imported
gpg: no definitively trustworthy key found (*) my translation
gpg: Total number of examinated items: 1
gpg:               Imported: 1  (RSA: 1)

Code: Select all
spix@ee-spix ~ $ sudo apt-get update
Downloading:1 http://security.ubuntu.com raring-security Release.gpg [933 B]
Found http://archive.canonical.com raring Release.gpg                                                           
Downloading:2 http://ppa.launchpad.net raring Release.gpg [316 B]                                             
Found http://archive.canonical.com raring Release                                                               
Downloading:3 http://ppa.launchpad.net raring Release [9778 B]                                                 
Downloading:4 http://linux-mint.froonix.org olivia Release.gpg [198 B]                                         
Downloading:5 http://security.ubuntu.com raring-security Release [40,8 kB]                                     
Found http://mirrors.liquidweb.com raring Release.gpg                                                           
Downloading:6 http://linux-mint.froonix.org olivia Release [18,5 kB]   
Found http://archive.canonical.com raring/partner i386 Packages                                                 
Downloading:7 http://ppa.launchpad.net raring/main Sources [806 B]                                             
Downloading:8 http://mirrors.liquidweb.com raring-updates Release.gpg [933 B]                                 
Downloading:9 http://security.ubuntu.com raring-security/main i386 Packages [149 kB]                           
Downloading:10 http://ppa.launchpad.net raring/main i386 Packages [785 B]                                     
Downloading:11 http://linux-mint.froonix.org olivia/main i386 Packages [23,5 kB]                               
Found http://mirrors.liquidweb.com raring Release                                                               
Downloading:12 http://linux-mint.froonix.org olivia/upstream i386 Packages [9237 B]                           
Downloading:13 http://mirrors.liquidweb.com raring-updates Release [40,8 kB]                                   
Downloading:14 http://linux-mint.froonix.org olivia/import i386 Packages [40,2 kB]                             
Downloading:15 http://security.ubuntu.com raring-security/restricted i386 Packages [14 B]                     
Downloading:16 http://security.ubuntu.com raring-security/universe i386 Packages [49,6 kB]                     
Downloading:17 http://security.ubuntu.com raring-security/multiverse i386 Packages [3862 B]                   
Ign http://archive.canonical.com raring/partner Translation-it_IT                                                 
Found http://mirrors.liquidweb.com raring/main i386 Packages                                                     
Found http://mirrors.liquidweb.com raring/restricted i386 Packages                                               
Found http://mirrors.liquidweb.com raring/universe i386 Packages                                                 
Downloading:18 http://security.ubuntu.com raring-security/main Translation-en [75,1 kB]                       
Found http://security.ubuntu.com raring-security/multiverse Translation-en                                       
Ign http://archive.canonical.com raring/partner Translation-it                                                     
Ign http://archive.canonical.com raring/partner Translation-en                                                     
Ign http://ppa.launchpad.net raring/main Translation-it_IT                                                         
Ign http://ppa.launchpad.net raring/main Translation-it                                                           
Found http://mirrors.liquidweb.com raring/multiverse i386 Packages                                               
Found http://security.ubuntu.com raring-security/restricted Translation-en                                       
Ign http://ppa.launchpad.net raring/main Translation-en                                                           
Found http://mirrors.liquidweb.com raring/main Translation-it                                                   
Downloading:19 http://security.ubuntu.com raring-security/universe Translation-en [30,0 kB]       
Found http://mirrors.liquidweb.com raring/main Translation-en                                                   
Found http://mirrors.liquidweb.com raring/multiverse Translation-it                                       
Found http://mirrors.liquidweb.com raring/multiverse Translation-en                                       
Found http://mirrors.liquidweb.com raring/restricted Translation-it                                       
Found http://mirrors.liquidweb.com raring/restricted Translation-en         
Ign http://linux-mint.froonix.org olivia/import Translation-it_IT             
Ign http://linux-mint.froonix.org olivia/import Translation-it                 
Ign http://linux-mint.froonix.org olivia/import Translation-en
Ign http://linux-mint.froonix.org olivia/main Translation-it_IT
Found http://mirrors.liquidweb.com raring/universe Translation-it
Ign http://linux-mint.froonix.org olivia/main Translation-it                   
Ign http://linux-mint.froonix.org olivia/main Translation-en                   
Found http://mirrors.liquidweb.com raring/universe Translation-en
Ign http://security.ubuntu.com raring-security/main Translation-it_IT         
Ign http://linux-mint.froonix.org olivia/upstream Translation-it_IT           
Ign http://security.ubuntu.com raring-security/main Translation-it             
Ign http://linux-mint.froonix.org olivia/upstream Translation-it               
Ign http://security.ubuntu.com raring-security/multiverse Translation-it_IT   
Ign http://linux-mint.froonix.org olivia/upstream Translation-en               
Downloading:20 http://mirrors.liquidweb.com raring-updates/main i386 Packages [212 kB]
Ign http://security.ubuntu.com raring-security/multiverse Translation-it
Ign http://security.ubuntu.com raring-security/restricted Translation-it_IT
Ign http://security.ubuntu.com raring-security/restricted Translation-it
Ign http://security.ubuntu.com raring-security/universe Translation-it_IT
Ign http://security.ubuntu.com raring-security/universe Translation-it
Downloading:21 http://mirrors.liquidweb.com raring-updates/restricted i386 Packages [14 B]
Downloading:22 http://mirrors.liquidweb.com raring-updates/universe i386 Packages [165 kB]
Downloading:23 http://mirrors.liquidweb.com raring-updates/multiverse i386 Packages [4796 B]
Downloading:24 http://mirrors.liquidweb.com raring-updates/main Translation-en [102 kB]                       
Found http://mirrors.liquidweb.com raring-updates/multiverse Translation-en                                     
Found http://mirrors.liquidweb.com raring-updates/restricted Translation-en                                     
Downloading:25 http://mirrors.liquidweb.com raring-updates/universe Translation-en [83,8 kB]                   
Ign http://mirrors.liquidweb.com raring/main Translation-it_IT                                                     
Ign http://mirrors.liquidweb.com raring/multiverse Translation-it_IT                                               
Ign http://mirrors.liquidweb.com raring/restricted Translation-it_IT                                               
Ign http://mirrors.liquidweb.com raring/universe Translation-it_IT                                                 
Ign http://mirrors.liquidweb.com raring-updates/main Translation-it_IT                                             
Ign http://mirrors.liquidweb.com raring-updates/main Translation-it                                               
Ign http://mirrors.liquidweb.com raring-updates/multiverse Translation-it_IT                                       
Ign http://mirrors.liquidweb.com raring-updates/multiverse Translation-it                                         
Ign http://mirrors.liquidweb.com raring-updates/restricted Translation-it_IT                                       
Ign http://mirrors.liquidweb.com raring-updates/restricted Translation-it                                         
Ign http://mirrors.liquidweb.com raring-updates/universe Translation-it_IT                                         
Ign http://mirrors.liquidweb.com raring-updates/universe Translation-it                                           
Downloaded 1062 kB in 15s (66,7 kB/s)                                                                             
Reading packages list... Error
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/linux-mint.froonix.org_dists_olivia_import_i18n_Translation-en
E: Packages list or status file could not be read or opened.

Code: Select all
spix@ee-spix ~ $ sudo apt-get install grub-customizer
Reading packages list... Error
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/linux-mint.froonix.org_dists_olivia_import_i18n_Translation-en
E: Packages list or status file could not be read or opened.
spix@ee-spix ~ $

Moreover, as I've already said, nor Packages Manager nor Programs Manager work.
I also noticed that the program for system update does not work. I guess that's probably the reason for which I've not been propmted for upgrade to Mint 16 yet. I had a similar problem with Kubuntu on my desktop some time ago, but at least the update through line command did work so I could solve the problem by... updating tha updater. Here in Mint not even line command seems to work.

About Grub, I will try to edit it manually - but I'm beginning to opt for formatting '/', wipe it all and install Mint 16. This pc seems to be a mess... and all because I followed a suggestion in a forum, which was given by a superficial user who didn't think about what he was writing.
Marco
Linux Mint 15 Cinnamon
eee-900 2GB RAM
Spix73
Level 1
Level 1
 
Posts: 3
Joined: Mon Jan 06, 2014 4:40 pm


Return to Software & Applications

Who is online

Users browsing this forum: MSNbot Media, Yahoo [Bot] and 23 guests