Apt-get failes..

Questions about applications and software
Forum rules
Before you post please read this

Apt-get failes..

Postby Hjess on Thu Aug 07, 2008 2:28 pm

Hi.

Im wondering whats going on with apt-get ;-)

Im getting those errors and no clue what to do - "the HTTP server sent an invalid reply header".

(I've paste the debugging output to get the most out of the support)


the output is from a apt-get update -o Debug::Acquire::http=true and the error is

Code: Select all

GET /dists/elyssa/community/binary-i386/Packages.gz HTTP/1.1
Host: packages.linuxmint.com
Connection: keep-alive
If-Modified-Since: Mon, 19 May 2008 20:25:43 GMT
User-Agent: Ubuntu APT-HTTP/1.3 (0.7.9ubuntu17)


HTTP/1.0 304
Date: Thu, 07 Aug 2008 18:17:06 GMT
Content-Type: application/x-gzip
Last-Modified: Thu, 12 Jun 2008 20:41:22 GMT
Age: 936
X-Cache: HIT from localhost
X-Cache-Lookup: HIT from localhost:3128
Via: 1.0 localhost (squid/3.0.STABLE7)
Proxy-Connection: keep-alive

Err http://packages.linuxmint.com elyssa/main Packages   
  The HTTP server sent an invalid reply header
99% [Waiting for headers]GET /dists/elyssa/romeo/binary-i386/Packages.gz HTTP/1.1
Host: packages.linuxmint.com
Connection: keep-alive
If-Modified-Since: Thu, 24 Jul 2008 22:22:29 GMT
User-Agent: Ubuntu APT-HTTP/1.3 (0.7.9ubuntu17)


HTTP/1.0 304
Date: Mon, 04 Aug 2008 17:36:32 GMT
Content-Type: application/x-gzip
Last-Modified: Thu, 31 Jul 2008 19:33:06 GMT
Age: 49478
X-Cache: HIT from localhost
X-Cache-Lookup: HIT from localhost:3128
Via: 1.0 localhost (squid/3.0.STABLE7)
Proxy-Connection: keep-alive

Err http://packages.linuxmint.com elyssa/upstream Packages
  The HTTP server sent an invalid reply header
99% [Waiting for headers]HTTP/1.0 304
Date: Thu, 07 Aug 2008 18:17:06 GMT
Content-Type: application/x-gzip
Last-Modified: Thu, 10 Jul 2008 20:57:15 GMT
Age: 936
X-Cache: HIT from localhost
X-Cache-Lookup: HIT from localhost:3128
Via: 1.0 localhost (squid/3.0.STABLE7)
Proxy-Connection: keep-alive

Err http://packages.linuxmint.com elyssa/import Packages
  The HTTP server sent an invalid reply header
99% [Waiting for headers]HTTP/1.0 304
Date: Thu, 07 Aug 2008 18:17:06 GMT
Content-Type: application/x-gzip
Last-Modified: Mon, 19 May 2008 20:25:43 GMT
Age: 936
X-Cache: HIT from localhost
X-Cache-Lookup: HIT from localhost:3128
Via: 1.0 localhost (squid/3.0.STABLE7)
Proxy-Connection: keep-alive

Err http://packages.linuxmint.com elyssa/community Packages
  The HTTP server sent an invalid reply header
99% [Waiting for headers]HTTP/1.0 304
Date: Mon, 04 Aug 2008 17:36:32 GMT
Content-Type: application/x-gzip
Last-Modified: Thu, 24 Jul 2008 22:22:29 GMT
Age: 49478
X-Cache: HIT from localhost
X-Cache-Lookup: HIT from localhost:3128
Via: 1.0 localhost (squid/3.0.STABLE7)
Proxy-Connection: keep-alive

Err http://packages.linuxmint.com elyssa/romeo Packages
  The HTTP server sent an invalid reply header
Fetched 8760B in 1s (4410B/s)
W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/hardy-security/main/binary-i386/Packages.gz  The HTTP server sent an invalid reply header

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/hardy-security/restricted/binary-i386/Packages.gz  The HTTP server sent an invalid reply header

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/hardy-security/universe/binary-i386/Packages.gz  The HTTP server sent an invalid reply header

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/hardy-security/multiverse/binary-i386/Packages.gz  The HTTP server sent an invalid reply header

W: Failed to fetch http://packages.linuxmint.com/dists/elyssa/main/binary-i386/Packages.gz  The HTTP server sent an invalid reply header

W: Failed to fetch http://packages.linuxmint.com/dists/elyssa/upstream/binary-i386/Packages.gz  The HTTP server sent an invalid reply header

W: Failed to fetch http://packages.linuxmint.com/dists/elyssa/import/binary-i386/Packages.gz  The HTTP server sent an invalid reply header

W: Failed to fetch http://packages.linuxmint.com/dists/elyssa/community/binary-i386/Packages.gz  The HTTP server sent an invalid reply header

W: Failed to fetch http://packages.linuxmint.com/dists/elyssa/romeo/binary-i386/Packages.gz  The HTTP server sent an invalid reply header

E: Some index files failed to download, they have been ignored, or old ones used instead.

"Ah, women. They make the highs higher and the lows more frequent." - Friedrich Nietzsche
"No notice is taken of a little evil, but when it increases it strikes the eye." - Aristotle
Hjess
Level 2
Level 2
 
Posts: 71
Joined: Fri May 30, 2008 5:55 pm
Location: Planet Earth

Linux Mint is funded by ads and donations.
 

Re: Apt-get failes..

Postby Husse on Sat Aug 09, 2008 12:27 pm

All the time?
We have problems with our servers - they go down more or less now and then. It's almost always for short periods of time at the most half an hour.
We are aware of it and are considering what steps to take
I fear that it is some kind of attack at least in some cases
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Apt-get failes..

Postby Hjess on Sun Aug 10, 2008 5:02 pm

Husse wrote:All the time?
We have problems with our servers - they go down more or less now and then. It's almost always for short periods of time at the most half an hour.
We are aware of it and are considering what steps to take
I fear that it is some kind of attack at least in some cases


Hi Huse.

Just an update on this issue.

I downloaded the lastest ISO, burn it out and now my GF is running Mint to! (Great!).. But but but.. - samme errors on a FRESH! install.

(Sorry its in danish)
Hentede 8760B på 2s (2932B/s)
W: Kunne ikke hente http://archive.ubuntu.com/ubuntu/dists/ ... ion-da.bz2 http-serveren sendte et ugyldigt svarhovede [IP: 91.189.88.31 80]

W: Kunne ikke hente http://archive.ubuntu.com/ubuntu/dists/ ... ion-da.bz2 http-serveren sendte et ugyldigt svarhovede [IP: 91.189.88.45 80]

W: Kunne ikke hente http://security.ubuntu.com/ubuntu/dists ... ackages.gz http-serveren sendte et ugyldigt svarhovede

W: Kunne ikke hente http://security.ubuntu.com/ubuntu/dists ... ackages.gz http-serveren sendte et ugyldigt svarhovede

W: Kunne ikke hente http://security.ubuntu.com/ubuntu/dists ... ackages.gz http-serveren sendte et ugyldigt svarhovede

W: Kunne ikke hente http://security.ubuntu.com/ubuntu/dists ... ackages.gz http-serveren sendte et ugyldigt svarhovede

W: Kunne ikke hente http://packages.linuxmint.com/dists/ely ... ackages.gz http-serveren sendte et ugyldigt svarhovede

W: Kunne ikke hente http://packages.linuxmint.com/dists/ely ... ackages.gz http-serveren sendte et ugyldigt svarhovede

W: Kunne ikke hente http://packages.linuxmint.com/dists/ely ... ackages.gz http-serveren sendte et ugyldigt svarhovede

E: Nogle indeksfiler kunne ikke hentes, de er blevet ignoreret eller de gamle bruges i stedet.
"Ah, women. They make the highs higher and the lows more frequent." - Friedrich Nietzsche
"No notice is taken of a little evil, but when it increases it strikes the eye." - Aristotle
Hjess
Level 2
Level 2
 
Posts: 71
Joined: Fri May 30, 2008 5:55 pm
Location: Planet Earth

Re: Apt-get failes..

Postby Husse on Sun Aug 10, 2008 6:09 pm

It works for me right now
I think it's in your internet connection - do you use a proxy?
Can you go to another location and try?
(och jag förstår danska :))
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Software & Applications

Who is online

Users browsing this forum: tenry and 30 guests