Print from OpenOffice

Questions about applications and software
Forum rules
Before you post please read this

Print from OpenOffice

Postby oliverjames on Fri Sep 05, 2008 3:55 am

I've been using OOffice for many years and living with an annoying problem. Today, whether in Mint or XP, using the latest OOffice version, I cannot print a page if it contains an embedded image (the image prints but not the text). I can make a pdf of the page and print it but I would prefer to print from OOffice. I've scoured the OOffice forum but none of the suggested "fixes" have worked for me.

Has anyone seen a fix for this?

I also find it impossible to print envelopes from OOffice when under Linux (works under XP); usually end up writing them out by hand (good practice in these electronic text days). Is it just my system or does Sun not care about printing?

Oliverjames
oliverjames
Level 3
Level 3
 
Posts: 194
Joined: Fri Aug 10, 2007 3:00 am
Location: Divonne-les-Bains, France

Linux Mint is funded by ads and donations.
 

Re: Print from OpenOffice

Postby Fornhamfred on Fri Sep 05, 2008 2:25 pm

Hello Oliverjames

Have just tested your problem on my setup Elyssa Gnome printing to a Epson DX4850 on my network and have had no problem printing your text with a photo inserted in the document. Open Office is 2.4.

Have also tried envelopes and although more fiddly than our windows alternative I was as successful with 2.4 in mint as 3.0 on XP. No difference at all.

What versions are you running?
Fornhamfred
Level 6
Level 6
 
Posts: 1131
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: Print from OpenOffice

Postby rivenought on Fri Sep 05, 2008 3:02 pm

Oliver,

I use OpenOffice every day for my correspondence and envelopes. I am using the current version in Mint 5 and have used OpenOffice for several years in Mint, openSUSE, Mandriva, and a few others. I can print just fine and dandy.

I have a Canon s750 using the Gutenprint simplified s630 driver. There were three choices for drivers listed in relation to the s630. There was nothing for the s750, so I picked something close, and it worked. Perhaps the problem with your printing might be in the printer / driver choice. That is the fist thing I would check or fiddle with. I hope your problem can be fixed with one simple adjustment. Good luck.
rivenought
Level 5
Level 5
 
Posts: 780
Joined: Wed Apr 09, 2008 10:34 am

Re: Print from OpenOffice

Postby oliverjames on Fri Sep 05, 2008 5:51 pm

Thanks for your reassurance Guys. I'm using OOffice 2.4.1 in Mint and in WinXP . In both cases I can print text only with no problem but as soon as I inset a jpeg, gif or bitmap file into the text, I can only print the image, the text doesn't show.

I can solve the problem if I convert the format and open with an old version of Word. Alternatively I can pdf and then print.

I'm printing over the network to an HP Deskjet 970CXi. using the recommended hp driver. I'll try a Gutenprint driver if there is one for Linux but I don't think I've seen them for Windows.

The envelope issue only relates to Linux. I cannot find a way of configuring the layout so that the address appears in the right place.

Bit late for that tonight though, back tomorrow.

Oliverjames
oliverjames
Level 3
Level 3
 
Posts: 194
Joined: Fri Aug 10, 2007 3:00 am
Location: Divonne-les-Bains, France

Re: Print from OpenOffice

Postby oliverjames on Mon Sep 15, 2008 10:41 am

All problems solved under Mint. No change under WinXP. Curious.
oliverjames
Level 3
Level 3
 
Posts: 194
Joined: Fri Aug 10, 2007 3:00 am
Location: Divonne-les-Bains, France

Re: Print from OpenOffice

Postby psych1610 on Mon Sep 15, 2008 1:43 pm

Mind saying how you solved them under Mint?
psych1610
Level 3
Level 3
 
Posts: 152
Joined: Mon Mar 03, 2008 5:12 pm

Re: Print from OpenOffice

Postby oliverjames on Tue Sep 16, 2008 10:26 am

Apologies, I should has said resolved not solved in Mint. I simply reinstalled the latest OOffice package in the repo. I can now print docs with embedded pictures without problems. I still have a little glitch with envelopes but I'm sure that changing to a standard C5/6 size will do this. At the moment I have to offset the address slightly within its frame.

Not very scientific I know but the problem is partly resolved in Mint. Still the same hassle under Windows but then I can always use my old Word2000 software, which still works well under XP.
oliverjames
Level 3
Level 3
 
Posts: 194
Joined: Fri Aug 10, 2007 3:00 am
Location: Divonne-les-Bains, France

Re: Print from OpenOffice

Postby psych1610 on Tue Sep 16, 2008 10:36 am

At least you can do what you need to do now. It was probably just a problem with the config. If it happens again try backing up the .config files to .config-bak or whatever and then deleting the originals. Open Office will recreate them on start and you can see if maybe a configuration got messed up along the way or something
psych1610
Level 3
Level 3
 
Posts: 152
Joined: Mon Mar 03, 2008 5:12 pm

Re: Print from OpenOffice

Postby oliverjames on Tue Sep 16, 2008 10:53 am

Thanks for the tip. I wish it was so easy in XP. It appears from a web search that a lot of people have a similar problem.
oliverjames
Level 3
Level 3
 
Posts: 194
Joined: Fri Aug 10, 2007 3:00 am
Location: Divonne-les-Bains, France

Re: Print from OpenOffice

Postby psych1610 on Tue Sep 16, 2008 12:15 pm

Does open office have anything living in %appdata%?

If it does it probably stores its files in there for your configuration. You might be able to delete that and start again. Or at least see if thats the problem.

Back it up though :)
psych1610
Level 3
Level 3
 
Posts: 152
Joined: Mon Mar 03, 2008 5:12 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot], senbagaraman04 and 29 guests