Graphic problem with World of Warcraft solved

Questions about applications and software
Forum rules
Before you post please read this

Graphic problem with World of Warcraft solved

Postby Leo93 on Sun Sep 07, 2008 5:10 pm

Hi all!!!
Today I've successfully installed WoW on my Linux Mint Elyssa with Wine, but when I launched it my screen got crazy!!! That is what I saw:
Image Image
I also tried to make a snapshot of my screen and that was the result:
Image

Why in the snapshot there are no problems but I could not see anything in the screen??? I have installed the video driver of my ATI Radeon X1300 Series with EnvyNG and Compiz works perfectly...
Leo93
Level 1
Level 1
 
Posts: 6
Joined: Sun Sep 07, 2008 3:57 am

Linux Mint is funded by ads and donations.
 

Re: Graphic problem with World of Warcraft

Postby Husse on Mon Sep 08, 2008 6:08 am

Is the screenshot (and I suppose you mean screenshot when you write snapshot) from the same screen as the garbled output in the photos?
Any other video problems?
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Graphic problem with World of Warcraft

Postby Leo93 on Mon Sep 08, 2008 6:41 am

Yes, I meant screenshot, and it is from the same screen as the garbled output...
I didn't found any other video problems...
Leo93
Level 1
Level 1
 
Posts: 6
Joined: Sun Sep 07, 2008 3:57 am

Re: Graphic problem with World of Warcraft

Postby Husse on Tue Sep 09, 2008 7:24 am

????
This is about the weirdest I've heard of - you take a screenshot of a garbled screen and it's perfectly ok
I'm out of time and ideas today, I have to think and ask around and come back to you
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Graphic problem with World of Warcraft

Postby AK Dave on Tue Sep 09, 2008 5:23 pm

Dang thats freakish!

Okay, my thought is that the video is getting messed up between the card and the glass. If the card wasn't rendering the image properly, I'd think the screenshot would be garbled. But only the photo is garbled. So that suggests to me that the data from the app is going through the video card to be rendered properly and when routed to /dev/sda0 as a screenshot it is fine but when routed to the screen itself it goes bonkers.

What I'd do first is check all my cables and try playing with the settings on the monitor itself, downgrading the resolution from the computer, and maybe changing from DVI to VGA cabling. Then I'm thinking the answer might be in xorg.conf since in pic1 it looks like the proper image (pic3) has been de-laced into two parallel images. The monitor looks like a big widescreen. Are you asking it to display the game in a mode that the game is physical incapable of being rendered in? The screencap doesn't appear to match the display dimensions of the monitor (19" widescreen?).
User avatar
AK Dave
Level 6
Level 6
 
Posts: 1042
Joined: Wed May 14, 2008 3:39 pm
Location: Anchorage, AK USA

Re: Graphic problem with World of Warcraft

Postby Husse on Wed Sep 10, 2008 6:13 am

According to my hardware specialist this is due to an error in the ATI driver - he also suggests that it may go away if you wait a while.
If not you should revert to an older version of the ATI driver
You could let Envy uninstall and then install with the manual option and select a version - there should be a couple of versions
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Graphic problem with World of Warcraft

Postby Leo93 on Thu Sep 11, 2008 1:20 pm

Thank you very much Husse, I installed the 8.5 version of the video driver and now it works!!!! Thank you very much!!!!
Leo93
Level 1
Level 1
 
Posts: 6
Joined: Sun Sep 07, 2008 3:57 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: Bing [Bot] and 18 guests