Linux Mint 17 Desktop Sharing Vino Settings not working

Questions about applications and software
Forum rules
Before you post please read this

Linux Mint 17 Desktop Sharing Vino Settings not working

Postby remus174 on Thu Jun 05, 2014 4:35 pm

I installed a clean installation of Mint 17, with all suggested updates.
I am able to set under Preferences-Desktop Sharing my usual configuration settings. Sharing both are checked, Security only Required Password and Automatically config UPNP. And show notification icon only when someone is connected.

Unfortunately, when trying to remote in with Tightvnc viewer from windows 7. I get a "no security types supported".
I can see Vino-Server running using lsof -i :5900 and my fw port 5900 is open.

There is something strange going on with Mint 17 vs Mint 16. When using dconf editor on Mint 16 I can see under desktop-gnome-remote-access is listed there with options. Under Mint 17 using the dconf editor desktop-gnome-remote-access tree is completely MISSING altogether.

I can't get VNC to work. I guess I can look into installing tightvncserver.
remus174
Level 1
Level 1
 
Posts: 3
Joined: Thu Sep 06, 2012 2:42 pm

Linux Mint is funded by ads and donations.
 

Re: Linux Mint 17 Desktop Sharing Vino Settings not working

Postby trevorbest on Mon Jun 09, 2014 7:20 am

try the following in a terminal:
gsettings set org.gnome.Vino require-encryption false
trevorbest
Level 1
Level 1
 
Posts: 1
Joined: Mon Dec 17, 2012 6:58 pm

Re: Linux Mint 17 Desktop Sharing Vino Settings not working

Postby remus174 on Tue Jun 24, 2014 1:10 pm

When I enter that I get the following:
dconf-WARNING **:failed to commit changes to dconf: The connection is closed
remus174
Level 1
Level 1
 
Posts: 3
Joined: Thu Sep 06, 2012 2:42 pm

Re: Linux Mint 17 Desktop Sharing Vino Settings not working

Postby DrHu on Tue Jun 24, 2014 2:05 pm

Combination of your vnc (tightvnc) and media service..
http://askubuntu.com/questions/408365/g ... pe-for-vnc
--you can check through the Tightvnc security settings, or change the programs you are using, one use on these posts had a combination that worked AOK (as stated by user post)..
X11VNC was the program the poster indicated worked OK
[list][*]I would be ignoring the Gnome nomenclature 3.xx, and only pay attention to the security support available within Tightvnc
[*]Also check the Vino security settings[list]
--even if it happened that UPNC seemed to work at some point !
https://help.ubuntu.com/community/VNC/Servers
User avatar
DrHu
Level 16
Level 16
 
Posts: 6796
Joined: Wed Jun 17, 2009 8:20 pm

Re: Linux Mint 17 Desktop Sharing Vino Settings not working

Postby remus174 on Tue Jun 24, 2014 3:55 pm

Vino settings under desktop sharing are not reflective of the settings listed when performing "gsettings list-recursively org.gnome.Vino".

There is clearly something wrong with Vino. Using other vnc clients or doesn't work either.
Also if you download and install GConf configuration tool remote access is not listed under desktop/gnome/

I can't be the only one seeing this fault.
remus174
Level 1
Level 1
 
Posts: 3
Joined: Thu Sep 06, 2012 2:42 pm

Re: Linux Mint 17 Desktop Sharing Vino Settings not working

Postby ro55mo on Mon Jul 14, 2014 4:03 pm

Remus 174, you are not the only one having this issue.

This is mildly disappointing. Remote desktop sharing is something that should work out of the box. I am not pointing the finger at Mint, the issue appears to lie elsewhere.

The easiest solution I have found is teamviewer (provided you are using it for personal use).

https://www.teamviewer.com/en/download/linux.aspx
ro55mo
Level 1
Level 1
 
Posts: 16
Joined: Tue Dec 03, 2013 5:32 pm

Re: Linux Mint 17 Desktop Sharing Vino Settings not working

Postby om62 on Sat Jul 26, 2014 1:02 pm

This works for LMDE201403, but I see no reason why it would not work for 17:

OK, I managed to get Vino to work on LMDE201403.

vino-server is not enabled so we have to do that first:

Code: Select all
gsettings set org.gnome.Vino enabled true


Still, there is no easy way to configure vino, so we need to get dconf-Editor so we can configure it - install dconf-Editor with Synaptic.

Launch dconf-Editor and navigate to:

desktop.gnome.remote-access

Here you will be able apply the settings to vino like we used to see in previous versions when "vino-preferences" used to work. Password, encryption, notify on connection etc.

Finally, add
Code: Select all
 /usr/lib/vino/vino-server
to the Start Up Applications and you are done for good!
om62
Level 1
Level 1
 
Posts: 3
Joined: Fri Jul 25, 2014 6:36 pm

Re: Linux Mint 17 Desktop Sharing Vino Settings not working

Postby kissinger on Sat Aug 30, 2014 3:50 pm

gsettings set org.gnome.Vino require-encryption false

This worked! I can now use VNC to control Mint 17 Mate.
I hope this issue will be resolved, although it may not be the fault of Mint. Being able to access Mint via VNC should happen right after installation.

Thanks!
kissinger
Level 1
Level 1
 
Posts: 12
Joined: Mon May 28, 2012 10:53 am

Re: Linux Mint 17 Desktop Sharing Vino Settings not working

Postby ShinyPC on Tue Sep 02, 2014 11:27 pm

I followed all the suggestions but turning off encryption that made vnc work for me. Many thanks. New install of 17 and vnc from 2nd 17 should work but didn't.
ShinyPC
Level 1
Level 1
 
Posts: 9
Joined: Fri Apr 13, 2012 8:16 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: Preyed and 12 guests