Do I need openssl and libssl?

Questions about applications and software
Forum rules
Before you post please read this

Do I need openssl and libssl?

Postby expat_tony on Tue Jun 24, 2014 10:14 am

Update manager is offering me openssl and libssl, both in version e-3ubuntu1.6., as level 3 updates
I dug out a wiki saying that openssl is something to do with cryptography but has a long history of vulnerabilities to attack.
So what do these files do in LM 16 and what would I need them for?
expat_tony
Level 3
Level 3
 
Posts: 151
Joined: Thu Mar 27, 2014 6:52 pm

Linux Mint is funded by ads and donations.
 

Re: Do I need openssl and libssl?

Postby xenopeek on Tue Jun 24, 2014 10:30 am

These are critical system componenets, many programs you have installed use them. Hence you should upgrade them, to get the security fixes. BTW Linux Mint 16 becomes obsolete and reaches end of support on July 17th; so start thinking about upgrade to Linux Mint 17 (which is supported for 5 years).

Let's see what happens when we try to remove openssl. I'm doing that on Linux Mint 17 BTW, but for 16 it will have similar results. It would remove 31 packages:
Code: Select all
bluez-cups
ca-certificates
ca-certificates-java
cups
cups-core-drivers
cups-daemon
default-jre
default-jre-headless
hplip
icedtea-7-jre-jamvm
icedtea-7-plugin
icedtea-netx
icedtea-plugin
libatk-wrapper-java
libatk-wrapper-java-jni
oneconf-common
openjdk-7-jre
openjdk-7-jre-headless
openssl
printer-driver-gutenprint
printer-driver-hpcups
printer-driver-postscript-hp
printer-driver-splix
python-httplib2
python-oneconf
python-piston-mini-client
python-ubuntu-sso-client
python3-httplib2
python3-oneconf
python3-piston-mini-client
ssl-cert

Let's see what happens when we try to remove libssl1.0.0. It first refuses to do it, stating openssh-client and openssh-server also need to be removed. So trying to remove all three. It would remove 312 packages:
Code: Select all
adobe-flashplugin
apt-clone
apt-xapian-index
aptdaemon
apturl
apturl-common
avahi-daemon
avahi-utils
bind9-host
bluetooth
bluez
bluez-alsa
bluez-cups
bluez-gstreamer
ca-certificates
ca-certificates-java
caribou
cinnamon
cinnamon-bluetooth
cinnamon-common
cinnamon-screensaver
command-not-found
crda
cups
cups-core-drivers
cups-daemon
default-jre
default-jre-headless
dh-python
dnsutils
duplicity
eog
firefox
foomatic-db-compressed-ppds
freerdp-x11
gconf2
gdb
gdebi
gdebi-core
gedit
gimp
gir1.2-peas-1.0
gir1.2-totem-1.0
gksu
gnome-bluetooth
gnome-menus
gnome-panel
gnome-terminal
gnome-terminal-data
gnome-user-share
gstreamer0.10-gconf
gstreamer0.10-plugins-bad
gvfs-backends
hexchat
hplip
hplip-data
icedtea-7-jre-jamvm
icedtea-7-plugin
icedtea-netx
icedtea-plugin
language-selector-common
libatk-wrapper-java
libatk-wrapper-java-jni
libbind9-90
libbonoboui2-0
libdns100
libemail-valid-perl
libfreerdp1
libgksu2-0
libgnome2-0
libgnome2-bin
libgnome2-common
libgnomeui-0
libgnomevfs2-0
libgnomevfs2-common
libhpmud0
libio-socket-ssl-perl
libisccfg90
libmailtools-perl
libnet-smtp-ssl-perl
libnet-ssleay-perl
libnss-mdns
libpam-freerdp
libpeas-1.0-0
libpurple0
libpython-stdlib
libpython2.7
libpython2.7-stdlib
libpython3-stdlib
libpython3.4
libpython3.4-minimal
libpython3.4-stdlib
libreoffice-gnome
libsane-hpaio
libsasl2-modules
libsmbclient
libsnmp30
libspice-server1
libssl1.0.0
libtotem0
lintian
linux-image-extra-3.13.0-24-generic
linux-kernel-generic
lsb-release
mdm
mint-artwork-common
mint-artwork-gnome
mint-common
mint-meta-cinnamon
mint-meta-codecs
mint-meta-core
mintbackup
mintdrivers
mintinstall
mintlocale
mintnanny
mintsources
mintstick
mintsystem
mintupdate
mintupload
mintwelcome
nemo
nemo-fileroller
nemo-share
network-manager
network-manager-gnome
network-manager-pptp
network-manager-pptp-gnome
ntpdate
oneconf-common
openjdk-7-jre
openjdk-7-jre-headless
openprinting-ppds
openssh-client
openssl
pidgin
pidgin-libnotify
ppp
pppconfig
pppoe
pppoeconf
pptp-linux
printer-driver-foo2zjs
printer-driver-foo2zjs-common
printer-driver-gutenprint
printer-driver-hpcups
printer-driver-postscript-hp
printer-driver-ptouch
printer-driver-pxljr
printer-driver-sag-gdi
printer-driver-splix
python
python-apt
python-apt-common
python-aptdaemon
python-aptdaemon.gtk3widgets
python-beautifulsoup
python-cairo
python-central
python-chardet
python-commandnotfound
python-configglue
python-crypto
python-cups
python-cupshelpers
python-dbus
python-debian
python-debtagshw
python-defer
python-dirspec
python-dnspython
python-feedparser
python-gconf
python-gdbm
python-gi
python-gi-cairo
python-glade2
python-gnome2
python-gnomekeyring
python-gobject
python-gobject-2
python-gtk2
python-gtksourceview2
python-httplib2
python-imaging
python-imaging-compat
python-ldb
python-libxml2
python-lockfile
python-lxml
python-mako
python-markupsafe
python-notify
python-ntdb
python-numpy
python-oauthlib
python-oneconf
python-opencv
python-openssl
python-pam
python-paramiko
python-parted
python-pexpect
python-pil
python-piston-mini-client
python-pkg-resources
python-protobuf
python-pyatspi
python-pyatspi2
python-pycurl
python-pyinotify
python-pyorbit
python-qt4
python-qt4-dbus
python-renderpm
python-reportlab
python-reportlab-accel
python-samba
python-serial
python-sexy
python-sip
python-six
python-smbc
python-support
python-talloc
python-tdb
python-twisted-bin
python-twisted-core
python-twisted-names
python-twisted-web
python-ubuntu-sso-client
python-utidylib
python-vte
python-webkit
python-xapian
python-xdg
python-zope.interface
python2.7
python3
python3-apt
python3-aptdaemon
python3-aptdaemon.gtk3widgets
python3-aptdaemon.pkcompat
python3-brlapi
python3-cairo
python3-chardet
python3-commandnotfound
python3-crypto
python3-dbus
python3-debian
python3-defer
python3-dirspec
python3-gdbm
python3-gi
python3-gi-cairo
python3-httplib2
python3-icu
python3-louis
python3-lxml
python3-minimal
python3-oauthlib
python3-oneconf
python3-pam
python3-piston-mini-client
python3-pkg-resources
python3-pyatspi
python3-pycurl
python3-pyicu
python3-six
python3-speechd
python3-uno
python3-virtkey
python3-xdg
python3-xkit
python3.4
python3.4-minimal
samba
samba-common-bin
samba-dsdb-modules
samba-libs
sbsigntool
sessioninstaller
smbclient
ssl-cert
system-config-printer-common
system-config-printer-gnome
system-config-printer-udev
tcpdump
thin-client-config-agent
tomboy
totem
totem-mozilla
totem-plugins
totem-plugins-extra
transmission-gtk
ubiquity
ubiquity-frontend-gtk
ubuntu-drivers-common
ubuntu-minimal
ubuntu-system-adjustments
ubuntu-system-service
ufw
unattended-upgrades
vlc
vlc-nox
vlc-plugin-notify
vlc-plugin-pulse
wget
wpasupplicant
xserver-xorg-video-all
xserver-xorg-video-qxl

Basically that erases your entire Linux Mint installation...
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14713
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands


Return to Software & Applications

Who is online

Users browsing this forum: floppybird and 24 guests