apt-get not updating OpenSSL on Olivia (15) x64

Questions about applications and software
Forum rules
Before you post please read this

apt-get not updating OpenSSL on Olivia (15) x64

Postby mten on Tue Jun 24, 2014 10:42 am

I've noticed in recent months that apt-get has been finding new versions of software much more rarely than it used to, and the updates that it finds seem to be only from PPAs that I've added manually. Today I confirmed (I think) my suspicions that something is amiss when I realized that I still have an old (Heartbleed-prone) version of OpenSSL installed. I've read viewtopic.php?f=47&t=31954 and correct me if I'm wrong, but it seems like I should have a newer version by now.

What I've done:
Code: Select all
zaphod@HeartOfGold ~ $ sudo apt-get update
[sudo] password for zaphod:
Ign file: binary/ Release.gpg
Ign file: binary/ Release                                                                                                                               
Ign file: binary/ Translation-en_US                                                                                                                     
Ign file: binary/ Translation-en                                                                                                                         
Hit http://download.virtualbox.org raring Release.gpg                                                                                                   
Get:1 http://packages.linuxmint.com olivia Release.gpg [198 B]                                                                                           
.
.
.
<Normal stuff, no errors or problems reported. Can post if interested>
.
.
.
Fetched 164 kB in 20s (7,855 B/s)
Reading package lists... Done
zaphod@HeartOfGold ~ $ apt-cache policy openssl
openssl:
  Installed: 1.0.1c-4ubuntu8.2
  Candidate: 1.0.1c-4ubuntu8.2
  Version table:
 *** 1.0.1c-4ubuntu8.2 0
        500 http://mirrors.us.kernel.org/ubuntu/ raring-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ raring-security/main amd64 Packages
        100 /var/lib/dpkg/status
     1.0.1c-4ubuntu8 0
        500 http://mirrors.us.kernel.org/ubuntu/ raring/main amd64 Packages


If I go to http://mirrors.us.kernel.org/ubuntu/pool/main/o/openssl/, I can see that there are a bunch of newer versions than 1.0.1c. Am I wrong in thinking that my computer should be finding and installing one of these?

Thanks!
mten
Level 1
Level 1
 
Posts: 2
Joined: Tue Jun 24, 2014 9:37 am

Linux Mint is funded by ads and donations.
 

Re: apt-get not updating OpenSSL on Olivia (15) x64

Postby xenopeek on Tue Jun 24, 2014 10:56 am

Linux Mint 15 reached end of support and is obsolete as of January 2014. Since then you are no longer getting security updates. I highly recommend you replace it with Linux Mint 17, which has support for next 5 years.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14864
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: apt-get not updating OpenSSL on Olivia (15) x64

Postby mten on Tue Jun 24, 2014 12:15 pm

Well that would do it I guess. I'll work on updating this weekend.

Thanks for the quick reply!
mten
Level 1
Level 1
 
Posts: 2
Joined: Tue Jun 24, 2014 9:37 am


Return to Software & Applications

Who is online

Users browsing this forum: steffanllyn and 22 guests