G-Thumb won't set as default [SOLVED]

Questions about applications and software
Forum rules
Before you post please read this

G-Thumb won't set as default [SOLVED]

Postby RamBurner on Wed Jun 25, 2014 9:07 am

System;
Mint 17 Cinnamon i386

In all of the places to set G-Thumb as the default application to open pictures it always reverts to the application called 'Image Viewer'
That slows things down that I have to right click each time to choose to 'Open With' G-Thumb
I have looked at every place to set it as the default, but it won't keep that setting.
The places I have changed are from preferred applications in system settings and setting G-Thumb as the default, right clicking on the image and going down to properties then to 'Open With' and there when I attempt to set G-Thumb as default it won't set.
Any solution for this ?
Last edited by RamBurner on Thu Jun 26, 2014 1:28 pm, edited 1 time in total.
User avatar
RamBurner
Level 2
Level 2
 
Posts: 56
Joined: Wed Nov 23, 2011 7:31 pm

Linux Mint is funded by ads and donations.
 

Re: G-Thumb won't set as default

Postby txba516 on Wed Jun 25, 2014 12:18 pm

Hi RamBurner,

I tested both places for setting the default viewer for images. First I changed the Mint installed default of Image Viewer to gThumb in the System Settings -> Preferred Applications -> Photos location. With just this setting applied, my system now opens all of the various types of images (.bmp, .jpg, .png, etc) with gThumb. If I look at the properties of any image and examine the Open With tab, it also reflects this default setting.

However, if I change the default application for a specific image, the default app is only changed for the that file type (again, only .bmp images or only .png images but not both). This will seem to show conflicting information but it's not really the case. What has happened is that the system wide default viewer is still the app listed in the Preferred Applications list. But specific image types may be customized to open with a different image viewing/editing app and that will not be reflected anywhere except under the properties of that file type.

You may need to verify the system wide setting first for the default Photo application (Preferred Applications section in System Settings). Then go to each image file type (get properties for an image of that type) and set the default to the desired application (gThumb in this instance).

Cheers!
LM17 x64 Cinnamon
Help the forums get answers faster! Mark your fixed problem thread as [SOLVED]
User avatar
txba516
Level 3
Level 3
 
Posts: 106
Joined: Fri Aug 10, 2007 11:57 am
Location: Atlanta, GA

Re: G-Thumb won't set as default

Postby RamBurner on Thu Jun 26, 2014 1:17 pm

This I have already done, it always opens with the 'Image viewer' instead of G-Thumb
The only way to open it with G-Thumb is to right click, then go to 'Open With'
It will not change at all in the Preferred Applications in System Settings, I left click on it to highlight it, then click on 'Set as Default' and it will not change it to default.
User avatar
RamBurner
Level 2
Level 2
 
Posts: 56
Joined: Wed Nov 23, 2011 7:31 pm

Re: G-Thumb won't set as default

Postby RamBurner on Thu Jun 26, 2014 1:28 pm

I found the solution, I right clicked on a picture and went down to Properties then to 'Open With' tab and then clicked on 'Reset to system defaults' then it allowed me to change it to setting G-Thumb as the default, as well as letting me change it in 'Preferred Applications' in System Settings.
User avatar
RamBurner
Level 2
Level 2
 
Posts: 56
Joined: Wed Nov 23, 2011 7:31 pm


Return to Software & Applications

Who is online

Users browsing this forum: jcfuller, mosi13 and 28 guests