Bless hex editor won't save files & screwed up vim

Questions about applications and software
Forum rules
Before you post please read this

Bless hex editor won't save files & screwed up vim

Postby mggm on Fri Jun 27, 2014 6:17 pm

Hi. I though it would be useful to have a hex editor. After a short google search, I installed Bless from Mint's official repo. And I run into problems almost instantly.

First, the command File -> Save (Ctrl+S) won't work. Instead, it displays a popup saying: "Error saving file myfile. There is not enough space on the device to save '/some-random-string-of-letters/.bless'". I've read Bless' FAQ question 6.2.3, I am trying to save a large file (under the same name) but while saving Bless complains that there is no space left! I was sure I had enough space! What's going on?. I don't think this is relevant. The file is very small, and I have plenty of space on / . Frankly, File -> Save as (Shift+Ctrl+S) works as expected.

The second issue is that the installation of Bless broke Vim. Before the installation of Bless, the command %!xdd in vim worked as expected. But now whenerever I try to use this command, Vim tells me that "the shell returned 127". And this is what I see insted of the hexadecimal representation of the file: /bin/bash: xdd: command not found.

How to fix the above problems? Thanks in advance!

Last bumped by mggm on Fri Jun 27, 2014 6:17 pm.
Level 1
Level 1
Posts: 1
Joined: Wed Jun 25, 2014 9:49 am

Linux Mint is funded by ads and donations.

Return to Software & Applications

Who is online

Users browsing this forum: Google [Bot] and 11 guests