XFCE + Thunar won't work!

Questions about applications and software
Forum rules
Before you post please read this

XFCE + Thunar won't work!

Postby Minguo on Fri Oct 17, 2008 9:46 am

Hi, I've got two weird problems maybe they're related?

1.) Firefox - After downloading files in Firefox, if I open the 'downloads' page and select 'open containing folder', that doesn't work.

At first, I would get an error saying basically that there was no program associated with the file type or somesuch, and a dialog to select an appropriate program.

I followed the steps in this solution.

http://rubylution.ping.de/articles/2...ox-under-linux

and now, nothing happens. No error, and no folder.



2.) Wine - I've installed it, but whenever I open the 'Browse C drive' menu item, it refuses to work. At first it would throw this error.

Code: Select all
Failed to open URL "~/.wine/drive_c:".
The URL "~/.wine/drive_c:" is not supported.


Ok, did some googling and forumsearching and found threads like this one.
http://ubuntuforums.org/showthread.php?t=762074

and bugs like this one.

https://bugs.edge.launchpad.net/ubun...ne/+bug/223989

I changed the shortcut entry as directed (first to

Code: Select all
xdg-open ~/.wine/dosdevices/c:


and then to

Code: Select all
thunar ~/.wine/dosdevices/c:


Then I tried both methods using complete paths. /home/user_name/.wine/. . . instead of ~/.wine. . .

Everything I've tried here works if I type it into terminal. however, NOTHING works if I try to run it from the shortcut.

Anything with a ~/.wine prefix gives me a "~/.wine/drive_c" is not supported error, anything with a /home/user_name/ prefix doesn't do anything at all. No error, and no folder.

One of these solutions seems to have worked for everybody else asking the question. What's going on?
Minguo
 

Linux Mint is funded by ads and donations.
 

Re: XFCE + Thunar won't work!

Postby Husse on Wed Oct 22, 2008 5:50 am

The link to rubylution does not work
Do you mean that you don't find the downloaded file?
You write "and no folder." I think the desktop is the default folder
Check the Firefox forums for this
http://forums.mozillazine.org/index.php?c=4
Everything I've tried here works if I type it into terminal. however, NOTHING works if I try to run it from the shortcut.

I had another such problem which was solved by making a file which in your case would be something like
Code: Select all
#! /bin/bash
thunar ~/.wine/dosdevices/c:

Then point the launcher to that file
The logic behind this is that if it works from the terminal, but not else one can conclude that it needs to be executed by bash
(not necessarily though, can be something else)
This could be a question for the forums at winehq
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: XFCE + Thunar won't work!

Postby Minguo on Thu Oct 23, 2008 10:18 pm

Thanks for responding, here is the correct url

http://rubylution.ping.de/articles/2007 ... nder-linux


Let me clarify, in firefox: If I download a file, then open Firefox's 'downloads' window, right click on the listing for the file I have just created and select 'Open Containing Folder' , what is supposed to happen (and happened when I used Gnome desktop on ubuntu) is that the file manager will open up to the location the file was downloaded to.

Unfortunately, this does not work with XFCE Mint. If I select 'open containing folder' in the Firefox downloads window, nothing happens. Thunar does not open up at all, I get no error message, or any feedback at all. Before I would get an error about there being no associated program with that filetype, but after I followed the steps in the above linked article, I don't get that anymore.

Thanks for the help with the wine shortcut!
Minguo
 

Re: XFCE + Thunar won't work!

Postby Minguo on Mon Nov 03, 2008 2:42 pm

*bump*
Minguo
 

Re: XFCE + Thunar won't work!

Postby Husse on Wed Nov 05, 2008 8:07 am

I normally never use the option to open from the FF download window - I close it and go straight to the download folder usually desktop
I have to put his in my list and return when I have more time
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: XFCE + Thunar won't work!

Postby Minguo on Wed Nov 05, 2008 3:53 pm

Thank you for the response.

I will be very interested if you are able to figure it out.
Minguo
 

Re: XFCE + Thunar won't work!

Postby Husse on Fri Nov 07, 2008 6:33 pm

I have to fix my Virtualbox first - all the Mint CE has got the wrong resolution and I forgot the solution to the resolution (sorry - it's getting late :))
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: XFCE + Thunar won't work!

Postby hopetoregistersoon on Fri Nov 07, 2008 8:20 pm

on firefox go to Edit=>preferences
Then go to applications. For "file" select use thunar (if thunar is not on list select other and navigate to /usr/bin and select thunar)
hopetoregistersoon
 

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: ahduncu, bob1082 and 21 guests