Firefox shortcut problem

Questions about applications and software
Forum rules
Before you post please read this

Firefox shortcut problem

Postby G. Traynor on Wed Apr 18, 2007 12:12 pm

I'm new to Linux Mint and just installed the latest version of Firefox 2.0.0.3 and my Alt-right arrow / Alt-left arrow shortcuts on my keyboard don't work. I really use it a lot in Firefox for Windows. At the moment, I have to use the main Right/Left arrows in the main toolbar up above.

Is there some way to re-enable these keyboard shortcuts?

Thanks...
G. Traynor
Level 1
Level 1
 
Posts: 25
Joined: Wed Apr 18, 2007 11:57 am

Linux Mint is funded by ads and donations.
 

Postby telic on Wed Apr 18, 2007 1:11 pm

Odd. Those keyboard shortcuts work okay for me with Firefox 2.0.0.3 and GNOME Bianca.

Does everything look kosher in your Bianca > Preferences > Keyboard setup?

All else failing, have you considered mouse gestures? I don't leave Home without them.


-------
telic
Level 3
Level 3
 
Posts: 188
Joined: Thu Mar 22, 2007 7:48 am

Postby G. Traynor on Wed Apr 18, 2007 2:36 pm

No, it's a laptop. I use keyboard shortcuts. No mouse.

Page-up, page-down, Home and End keys work fine. It's weird, so I'm not sure what's going on. :(

Touchpad works fine too, although it's a little jumpy and needs the sensitivity on it turned down. Pushing the mouse arrow across a webpage sometimes opens hyperlinks on the webpage, I don't want opened. But that will be another topic.

-
Last edited by G. Traynor on Thu Apr 19, 2007 9:59 am, edited 2 times in total.
G. Traynor
Level 1
Level 1
 
Posts: 25
Joined: Wed Apr 18, 2007 11:57 am

Postby will on Wed Apr 18, 2007 6:39 pm

I had a similar problem. For me it was because the right Alt key isn't recognized while the left one is. If I use the left Alt key with the arrow keys the short cuts work again. Check to see if this is the case for you.

-Will
Image
will
Level 2
Level 2
 
Posts: 86
Joined: Thu Feb 15, 2007 10:28 pm

Postby G. Traynor on Wed Apr 18, 2007 8:48 pm

will wrote:I had a similar problem. For me it was because the right Alt key isn't recognized while the left one is. If I use the left Alt key with the arrow keys the short cuts work again. Check to see if this is the case for you.

-Will

Yup, that's the case, alright. :) The right Alt key is disabled in Firefox

I suspect it might have something to do with the keyboard combination (generic) that my system detected when I installed Linux Mint. However going into the different keyboard settings under System>Preferences>Keyboard>the Layouts tab doesn't help me much since my model keyboard for a Sony PCG-F580 isn't listed.

I always use that right Alt key with my index finger in combination with my middle finger (for Left arrow) and my pinky (for Right arrow) and toggle back and forth using only my right hand.

Any way to re-enable the right Alt key?
G. Traynor
Level 1
Level 1
 
Posts: 25
Joined: Wed Apr 18, 2007 11:57 am

Postby will on Wed Apr 18, 2007 9:52 pm

Not that I've found. I'm on a Sony Vaio VGN-FJ170 and have had to use awkward finger positions because of this too :(

Ah well... gotta love Mint anyway :D
Image
will
Level 2
Level 2
 
Posts: 86
Joined: Thu Feb 15, 2007 10:28 pm

Postby telic on Thu Apr 19, 2007 12:04 am

Any way to re-enable the right Alt key?


It's possible to tweak your keyboard operation in specific and low-level ways, but I've only just begun to look at how that's done properly (i.e. without causing my X server to have fits).

For example, I found that the Firefox shortcuts did work with my lefthand ALT key (LALT), but did not with my righthand ALT key (RALT), so I had the opposite of your situation. This had no practical impact on my use of the keyboard (as I don't normally use RALT), but I went snooping into the keyboard configuration section of my /etc/X11/xorg.conf file and found the following...

Option "XkbOptions" "lv3:ralt_switch"

That code meddles with my RALT key in a way that's meaningless to me, so I disabled that option (I put a # at the start of the line), and now my RALT key works as expected. A fix for your glitch might be as simple.

I've taken a quick peek at various config files in GNOME Bianca, and I see keyboard definitions that are specific to Sony and others, but I don't yet know how those might be applied.

Just a matter of time til this Linux n00b susses it out, though. ;-)


-------
telic
Level 3
Level 3
 
Posts: 188
Joined: Thu Mar 22, 2007 7:48 am

Postby will on Thu Apr 19, 2007 6:51 am

Nice find! Your situation is the same as ours, I believe. I will have to check this out when I installed Mint KDE this weekend :D
Image
will
Level 2
Level 2
 
Posts: 86
Joined: Thu Feb 15, 2007 10:28 pm

Postby telic on Thu Apr 19, 2007 7:39 am

For folk who have this same glitch and need a step-by-step HOWTO undo...

To edit the xorg.conf file in superuser mode, go Terminal and type...
Code: Select all
gksu gedit /etc/X11/xorg.conf

(KDE users may need to type sudo kate /etc/X11/xorg.conf instead).

Do a CTRL-F and search for "ralt_switch". If you find code that looks like what's in my previous post, then comment-out the option by putting a # at the start of the text line. Like so...
Code: Select all
#    Option "XkbOptions" "lv3:ralt_switch"


Then save the file, close gedit (or kate) and all of your other open apps, and restart your PC so that the change in configuration can take effect cleanly.

UPDATE: I booted the Bianca KDE Beta 020 LiveCD and found it has the same problem, and that the fix described here works.

-------
telic
Level 3
Level 3
 
Posts: 188
Joined: Thu Mar 22, 2007 7:48 am

Postby G. Traynor on Thu Apr 19, 2007 9:47 am

telic wrote:
Any way to re-enable the right Alt key?


For example, I found that the Firefox shortcuts did work with my lefthand ALT key (LALT), but did not with my righthand ALT key (RALT), so I had the opposite of your situation.

Actually, that's the same situation. Left Alt works, right one doesn't.

telic wrote:For folk who have this same glitch and need a step-by-step HOWTO undo...

To edit the xorg.conf file in superuser mode, go Terminal and type...
Code: Select all
gksu gedit /etc/X11/xorg.conf

(KDE users may need to type sudo kate /etc/X11/xorg.conf instead).

Do a CTRL-F and search for "ralt_switch". If you find code that looks like what's in my previous post, then comment-out the option by putting a # at the start of the text line. Like so...
Code: Select all
#    Option "XkbOptions" "lv3:ralt_switch"


Then save the file, close gedit (or kate) and all of your other open apps, and restart your PC so that the change in configuration can take effect cleanly.

UPDATE: I booted the Bianca KDE Beta 020 LiveCD and found it has the same problem, and that the fix described here works.

-------

I appreciate that. I'm gonna give it a try when I get home tonight. If it works, for all the other right Alt key users out there, this will be great since I've been using my right hand doing this with browser navigation for years.

Will, if you have any success with this, please let us know. Thanks.

-
G. Traynor
Level 1
Level 1
 
Posts: 25
Joined: Wed Apr 18, 2007 11:57 am

Postby will on Thu Apr 19, 2007 10:12 am

Well I was just going to let it be and keep using my left Alt key but I decided to test it out just for you! :D

And guess what.. it worked! Just "sudo gedit /etc/X11/xorg.conf" and put a "#" before that line mentioned before and then save. You don't have to reboot, just restart X (Ctrl + Alt + Backspace) <-- last time you'll be forced to use the left alt key :wink:

Let us know if you run into any problems... you can always undo the changes to you xorg.conf file from tty1 so if something drastic happens get on another computer and head to the forums and I will help you fix everything.

-Will
Image
will
Level 2
Level 2
 
Posts: 86
Joined: Thu Feb 15, 2007 10:28 pm

Postby G. Traynor on Thu Apr 19, 2007 10:42 am

will wrote:Well I was just going to let it be and keep using my left Alt key but I decided to test it out just for you! :D

And guess what.. it worked! Just "sudo gedit /etc/X11/xorg.conf" and put a "#" before that line mentioned before and then save. You don't have to reboot, just restart X (Ctrl + Alt + Backspace) <-- last time you'll be forced to use the left alt key :wink:

Let us know if you run into any problems... you can always undo the changes to you xorg.conf file from tty1 so if something drastic happens get on another computer and head to the forums and I will help you fix everything.

-Will

Thanks, Will. Hopefully this will be a bug fix for later Mint versions. Are you or telic on the Dev team? Maybe one of you all can submit it?

Anyway, I'll let ya'll know... I got other Mint issues I'll get to in other threads, later. One day I hope to blow the Windows 2000 partition off this machine altogether and go strictly Linux with it.

_
G. Traynor
Level 1
Level 1
 
Posts: 25
Joined: Wed Apr 18, 2007 11:57 am

Postby will on Thu Apr 19, 2007 10:56 am

Yep. I'm on the Development Team and I'll let Clem know about it.

-Will
Image
will
Level 2
Level 2
 
Posts: 86
Joined: Thu Feb 15, 2007 10:28 pm

Postby telic on Thu Apr 19, 2007 11:30 am

Actually, that's the same situation. Left Alt works, right one doesn't.


This might be the time for fessing-up about my living in the Mirror Universe...


------
telic
Level 3
Level 3
 
Posts: 188
Joined: Thu Mar 22, 2007 7:48 am

Postby G. Traynor on Thu Apr 19, 2007 10:34 pm

will wrote:Yep. I'm on the Development Team and I'll let Clem know about it.

-Will

Well good job. It worked. :)

Thanks
G. Traynor
Level 1
Level 1
 
Posts: 25
Joined: Wed Apr 18, 2007 11:57 am

Postby telic on Thu Apr 19, 2007 11:00 pm

You're welcome. ;-)

------
telic
Level 3
Level 3
 
Posts: 188
Joined: Thu Mar 22, 2007 7:48 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: rossdv8 and 13 guests