Games oddly switch to windowed mode!

Questions about applications and software
Forum rules
Before you post please read how to get help

Games oddly switch to windowed mode!

Postby ddavid123 on Wed Feb 25, 2009 5:37 pm

I am using Linux Mint 6 32 bit main. I am still having problems with games like tremulous and Nexiuz switching from full screen mode to windowed mode within 5 minutes of starting. When this happens, I lose control of the game. I can not re-size nor kill the game because the cursor is not visible, and the keyboard input is non existent! I can run GTA Vice City with Wine, and it is not affected!

This problem affects no other program to my knowledge, just 3-D games. I have installed Regnum Online, and it is affected the same way! I have reinstalled Mint twice, and every time the problem persist. I am not sure, but it seems to start after Mint update installs all the updates after the fresh install!

Has anyone had this problem? I am not at my Mint computer now, I will list the output of lspci, lsusb, and lsmod later!

Thanks!

ddavid123
Image

Microsoft Windows, as easy to break as it's name suggests!

Linux, as cool as cool can get!
User avatar
ddavid123
Level 2
Level 2
 
Posts: 65
Joined: Mon Dec 03, 2007 4:26 pm
Location: Dawson Texas

Linux Mint is funded by ads and donations.
 

Re: Games oddly switch to windowed mode!

Postby clem on Wed Feb 25, 2009 7:42 pm

Hi,

It usually happens with SDL games. I'm not entirely sure why but I think it's because SDL doesn't tell the OS it's actually doing something... so Gnome basically assumes you're not here and activates the screensaver. You can appreciate how this doesn't happen for instance when you're watching a movie... even though you're not moving the mouse, the screensaver doesn't start.

Workaround: Disable the screensaver :)

Clem
Image
User avatar
clem
Level 15
Level 15
 
Posts: 5566
Joined: Wed Nov 15, 2006 8:34 am

Re: Games oddly switch to windowed mode!

Postby ddavid123 on Wed Feb 25, 2009 8:22 pm

clem wrote:Hi,

It usually happens with SDL games. I'm not entirely sure why but I think it's because SDL doesn't tell the OS it's actually doing something... so Gnome basically assumes you're not here and activates the screensaver. You can appreciate how this doesn't happen for instance when you're watching a movie... even though you're not moving the mouse, the screensaver doesn't start.

Workaround: Disable the screensaver :)

Clem


Thanks, I will give that a try and report back!
Image

Microsoft Windows, as easy to break as it's name suggests!

Linux, as cool as cool can get!
User avatar
ddavid123
Level 2
Level 2
 
Posts: 65
Joined: Mon Dec 03, 2007 4:26 pm
Location: Dawson Texas

Re: Games oddly switch to windowed mode!

Postby ddavid123 on Thu Apr 16, 2009 1:04 am

Sorry I haven't posted back sooner! Your tip proved beneficial! Since I have disabled the screen saver, I have had no problems. Thanks for the input.
Image

Microsoft Windows, as easy to break as it's name suggests!

Linux, as cool as cool can get!
User avatar
ddavid123
Level 2
Level 2
 
Posts: 65
Joined: Mon Dec 03, 2007 4:26 pm
Location: Dawson Texas


Return to Software & Applications

Who is online

Users browsing this forum: Google [Bot] and 20 guests