Trouble installing certain apps - libc6-related?

Questions about applications and software
Forum rules
Before you post please read this

Trouble installing certain apps - libc6-related?

Postby theseus on Mon Mar 09, 2009 5:00 am

Yesterday I installed Mint 4 or 5 (I thought it was 5, but the menu is still Daryna so I'm not sure) and upgraded to 6 using the upgrade tool I found on the blog.
All of this went well.
When this was done, I started installing applications. VLC, Picasa, AIR+Twhirl, GnuCash, Amarok, and the basic GNOME game set installed without a problem, but gPodder, Gourmet, and Kipinä wouldn't install.

I tried both synaptic package manager, which gave me E: Internal Error, Could not perform immediate configuration (2) on libc6 on gPodder and Gourmet, and E: Couldn't configure pre-depend libc6 for findutils, probably a dependency cycle on Kipinä, and package installer, which gave me installArchives() failed and Could not install all dependencies.

I'm not sure if it's related, but the changes to be applied seemed to be a rather long list. Earlier when using synaptic I didn't pay much attention to it since it generally went well, so it may just seem odd to me when it's actually normal, but I thought I'd mention it anyway. I added an odt file of it as an attachment.

Earlier, either during the installation from CD or during the upgrade, I got some notification involving libc6, but I paid no attention to it since it didn't seem to make a difference at that point.

Could this have something to do with the upgrade? If so, I could always just buy some blank CDs and reinstall. I've made very few changes so far, so it's best to do it now.
If not (or even if so), does anyone know of a way to fix this or have any suggestions for alternative applications? I could do without Kipinä and Gourmet but I would really miss gPodder.
Attachments
changes to be applied - synaptic.odt
(19.48 KiB) Downloaded 39 times
theseus
Level 1
Level 1
 
Posts: 5
Joined: Mon Mar 09, 2009 4:10 am
Location: The Netherlands

Linux Mint is funded by ads and donations.
 

Re: Trouble installing certain apps - libc6-related?

Postby viking777 on Mon Mar 09, 2009 7:13 am

Well as an easy starting point, open up synaptic, type libc6 into the quicksearch box and see if it is installed. On my system I have libc6, libc6-dev and libc6-i686. If you don't have any of those install them then try your installations again.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Trouble installing certain apps - libc6-related?

Postby theseus on Mon Mar 09, 2009 10:10 am

Thanks! I found that on my computer, libc6-dev wasn't installed so I tried installing that one. Unfortunately, I got an error message again, E: Couldn't configure pre-depend libc6 for findutils, probably a dependency cycle. I've tried unmarking findutils, but then basically everything else gets unmarked as well. I've attempted to just upgrade libc6, but that one involves findutils as well.

I just tried it on package installer again, using a file I got from getdeb.net, where the terminal window had this to say: gdebi-gtk: Fatal IO errpr 9 (Bad file descriptor) on X server :0.0.
theseus
Level 1
Level 1
 
Posts: 5
Joined: Mon Mar 09, 2009 4:10 am
Location: The Netherlands

Re: Trouble installing certain apps - libc6-related?

Postby viking777 on Mon Mar 09, 2009 12:10 pm

I've no idea what your error messages mean.

Another thing to try. Open synaptic, quick search for gpodder, right click on the entry, select properties then the Dependencies tab. Make a note of these and use Synaptic to search for each of them in turn and see if they are installed. If not then install them. Then try again with gpodder. If this doesn't work then try it from a terminal. Open a root terminal then run:

Code: Select all
sudo dpkg -i gpodder


The terminal sometimes gives a better report as to why it can't install something (sometimes but not always :) )
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Trouble installing certain apps - libc6-related?

Postby theseus on Mon Mar 09, 2009 12:32 pm

Thanks. I tried that for a few of them, but it didn't really work. I bought a few empty CDs so I'll try installing Mint again the recommended way. If I really went from 4 to 6 using something designed to take 5 to 6, things might've gone wrong a bit somewhere.
theseus
Level 1
Level 1
 
Posts: 5
Joined: Mon Mar 09, 2009 4:10 am
Location: The Netherlands

Re: Trouble installing certain apps - libc6-related?

Postby viking777 on Mon Mar 09, 2009 12:39 pm

Probably a good plan - I wish you luck.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Trouble installing certain apps - libc6-related?

Postby theseus on Mon Mar 09, 2009 5:21 pm

Thanks. Will report back. :)
theseus
Level 1
Level 1
 
Posts: 5
Joined: Mon Mar 09, 2009 4:10 am
Location: The Netherlands

Re: Trouble installing certain apps - libc6-related?

Postby theseus on Tue Mar 10, 2009 3:54 pm

I just reinstalled using a CD. When that was done I managed to install gPodder without a problem. Turns out I made a slight mess of my backups, but that's another matter.
theseus
Level 1
Level 1
 
Posts: 5
Joined: Mon Mar 09, 2009 4:10 am
Location: The Netherlands

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: ummagumma and 26 guests