Slow Internet connection with Mint 6

Questions about applications and software
Forum rules
Before you post please read this

Slow Internet connection with Mint 6

Postby emgy on Fri Mar 27, 2009 5:54 pm

I have had Daryna installed since it was released and it has behaved perfectly in all that time.
I did try Elyssa for a short while, but it had a problem where, if I mounted a second hard disk to access data, then logged out, and someone else logged on (eg wife or son) then that disk became inaccessible.
It appears that the disk remains mounted with the first user's credentials after logging off.
viewtopic.php?f=55&t=14259

I could not solve this problem, and returned to Daryna.
I recently decided to install Mint 6 Felicia, to see if the problem had been cured.
Unfortunately it is still there.

However, there is now another problem as well.
The download speed that I can achieve with Firefox is only a fraction of that which I achieved with Daryna installed.
I used www.broadbandspeedchecker.co.uk to check download and upload speeds.
With Felicia, I can achieve about 400Kbps download speed. With Daryna, the speed is about 4500 Kbps.
I booted into Windows and achieved similar speeds to Daryna.
I then tried my live disk for Elyssa, and the download speed was about 1700Kbps. Better, but still not right.

Next I tried my Daryna live disk, and reached over 4600Kbps.
Back to the Felicia live disk, and now less than 400Kbps.
I retried the installed Felicia and got around 400 Kbps again.

I installed Opera , in case Firefox was causing the issue, but the same problem remains.
After all this, I gave up and reinstalled Daryna.
I have just run the test 2 minutes ago in Daryna and got 4352 Kbps download and 928 Kbps upload.

I have now read that Daryna will reach end of life on April 18th.
Disaster looms.
Only Daryna works properly.


Has anyone got any ideas what is happening.

Incidentally, I have a laptop with Mint, and upgraded from Mint4 to Mint5 to Mint6, all without any problems around internet speed. This rules out CD problems.
The disk mount problem is still there on the laptop though. I have just learned to live with it.
User avatar
emgy
Level 1
Level 1
 
Posts: 34
Joined: Wed Dec 20, 2006 8:58 am
Location: Manchester, UK

Linux Mint is funded by ads and donations.
 

Re: Slow Internet connection with Mint 6

Postby Husse on Fri Mar 27, 2009 6:26 pm

It could be that you have the wrong mtu - check this out
viewtopic.php?f=150&t=19837&start=15&st=0&sk=t&sd=a#p127456
Strangely enough I've seen some problems with mtu recently - I thought they were long gone
And this can vary between the live CD and the installed version
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Slow Internet connection with Mint 6

Postby twodogs on Mon Mar 30, 2009 4:29 pm

i am running mint 6 felicia and have 6816 kbps download and 425 kbps upload according to the link given in post one. that is a uk website? if so, i think my speeds are good considering i am in florida, usa.
User avatar
twodogs
Level 4
Level 4
 
Posts: 265
Joined: Sat Jun 09, 2007 9:18 pm

Re: Slow Internet connection with Mint 6 and 7

Postby emgy on Fri Jun 19, 2009 7:24 am

Further to my internet speed problem, I downloaded Mint 7 Gloria, in the hope that the slow download speed problem might have disappeared. Unfortunately, the same problem still exists.
It is still the case that Daryna works perfectly, but the internet download speeds on any later version of Mint are so slow as to be unusable.
I can no longer access updates on Daryna, so I am now desperate to upgrade.
Something obviously changed when Daryna was upgraded to Elyssa, does anyone have any idea what it might be?
Husse - I did try the MTU you suggested, but it had no effect.
User avatar
emgy
Level 1
Level 1
 
Posts: 34
Joined: Wed Dec 20, 2006 8:58 am
Location: Manchester, UK

Re: Slow Internet connection with Mint 6

Postby Husse on Sat Jun 20, 2009 1:27 pm

I have definitely not noticed a slower internet with Gloria.....
I feel a bit lost here
Could you post your lspci (l is a lower case L) and your lsusb so we can have a look at your hardware
There may be something there....
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Slow Internet connection with Mint 6

Postby emgy on Sat Jun 20, 2009 4:04 pm

Here is my lspci and lsusb

david@dominator:~$ lspci
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82945G/GZ/P/PL PCI Express Root Port (rev 02)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc RV370 5B60 [Radeon X300 (PCIE)]
01:00.1 Display controller: ATI Technologies Inc RV370 [Radeon X300SE]
03:00.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 50)
03:00.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 50)
03:00.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 51)
03:01.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)


david@dominator:~$ lsusb
Bus 008 Device 002: ID 058f:6362 Alcor Micro Corp.
Bus 008 Device 001: ID 0000:0000
Bus 007 Device 003: ID 03f0:c602 Hewlett-Packard
Bus 007 Device 006: ID 05e3:0606 Genesys Logic, Inc.
Bus 007 Device 004: ID 05e3:0606 Genesys Logic, Inc.
Bus 007 Device 001: ID 0000:0000
Bus 006 Device 001: ID 0000:0000
Bus 003 Device 004: ID 046d:c505 Logitech, Inc. Cordless Mouse+Keyboard Receiver
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 004 Device 002: ID 04a9:220e Canon, Inc. CanoScan N1240U/LiDE 30
Bus 004 Device 001: ID 0000:0000
Bus 005 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000


Hope this helps
User avatar
emgy
Level 1
Level 1
 
Posts: 34
Joined: Wed Dec 20, 2006 8:58 am
Location: Manchester, UK

Re: Slow Internet connection with Mint 6

Postby Husse on Sat Jun 20, 2009 4:53 pm

When I saw that you have a Ralink 2500 I vaguely remembered something about speed and this card
It's even mentioned in one of the Gloria released topics
What you do is
Code: Select all
gksu gedit /etc/rc.local

Before exit 0 add
Code: Select all
iwconfig wlan0 rate 54M

This is provided your wifi is called wlan0
Check with iwconfig (in a terminal)
If this does not work try to add
ifconfig wlan0 up
before the iwconfig command
You need to reboot
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

SOLVED: Slow Internet connection with Mint 6 and 7

Postby emgy on Wed Jun 24, 2009 3:38 pm

This seems to have cured the problem.

Using the live disk, I did a download test using www.broadbandspeedchecker.co.uk, and got a result of 289Kbps

I then entered in a terminal:

sudo iwconfig wlan0 rate 54M

and ran the test again.
The download speed was then about 5300 Kbps

I will install Mint 7 this weekend and put the line in rc.local

Thanks for the help Husse.

I put the solution in Google, and discovered that there are a number of Ubuntu users who have encountered the same problem with this card.
Does this mean that it is an inherited bug, or is it a faulty driver?
Can Mint not be modified to cure the problem even if Ubuntu cannot fix it?
User avatar
emgy
Level 1
Level 1
 
Posts: 34
Joined: Wed Dec 20, 2006 8:58 am
Location: Manchester, UK

Re: Slow Internet connection with Mint 6

Postby Husse on Wed Jun 24, 2009 5:41 pm

I don't remember the exact cause but it is something "deep down" - I don't want to take time looking it up so I'll be a bit vague
It is something (a register of sorts) in the card that is feed with faulty information, like putting the brakes on
Adding iwconfig wlan0 rate 54M at boot tells it not to put brakes on - You might try with 11M too, 54M may be too fast for a stable connection (experience talks) Use only the speeds defined in the different standards (11, 54 and 108) no other value as it calls for that standard to be used, you do not set a speed as such.
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: echofly and 14 guests