FIREFOX Trouble

Questions about applications and software
Forum rules
Before you post please read this

FIREFOX Trouble

Postby youdkelon on Wed Apr 01, 2009 9:18 pm

Hi everyone, quick question. When I use firefow, it take sup the entire screen...it also covers the toolbar on the desktop and its missing the minimize, maximize, and exit button. so when ever I want to minimize, I can't--I have to go to File and then Quit. Has anyone had this problem? Anyone know what to do?

Thanks
youdkelon
Level 1
Level 1
 
Posts: 26
Joined: Tue Mar 31, 2009 10:46 am

Linux Mint is funded by ads and donations.
 

Re: FIREFOX Trouble

Postby emorrp1 on Wed Apr 01, 2009 9:40 pm

Hi, not quite sure exactly what you mean, could you post a screenshot? However if it's the same problem I've had in the past, holding down alt will allow to click and drag anywhere in the window so you can hopefully drag the top bar back into view.
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: FIREFOX Trouble

Postby merlwiz79 on Wed Apr 01, 2009 9:46 pm

Hit F11
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: FIREFOX Trouble

Postby JohnH on Thu Apr 02, 2009 4:08 am

Hi there youdkelon

You can fix the problem by going into your Compiz Settings Manager (this is found in Control Center or on the optional compiz icon - downloadable from Synaptic).

Once in the Settings Manager, click on the "Workarounds" icon in the "Utility" section of the menu. Having clicked on the Workarounds icon you will get a list of options you can choose to select or unselect by putting a check in the box. Choose "Legacy full screen support" (at the top of the list) and uncheck the box. This will fix it for you.

This is a firefox regression that has crept back into the latest version.

Regards
John
If you get too big for your britches, you will be exposed in the end.
User avatar
JohnH
Level 4
Level 4
 
Posts: 215
Joined: Wed Nov 22, 2006 4:15 am
Location: Caboolture, Oz

Re: FIREFOX Trouble

Postby youdkelon on Thu Apr 02, 2009 5:16 am

JohnH wrote:Hi there youdkelon

You can fix the problem by going into your Compiz Settings Manager (this is found in Control Center or on the optional compiz icon - downloadable from Synaptic).

Once in the Settings Manager, click on the "Workarounds" icon in the "Utility" section of the menu. Having clicked on the Workarounds icon you will get a list of options you can choose to select or unselect by putting a check in the box. Choose "Legacy full screen support" (at the top of the list) and uncheck the box. This will fix it for you.

This is a firefox regression that has crept back into the latest version.

Regards
John


Wow thank you very much John, it works!Thanks also merlwiz79 and emorrp. Much appreciated.

I also noticed that the look of firefox, such as the lettering and tabs for example, don't look as smooth as they do in windows. Is that just a Linux thing or is there actually something that can be done about it?

Thanks again
Daniel
youdkelon
Level 1
Level 1
 
Posts: 26
Joined: Tue Mar 31, 2009 10:46 am

Re: FIREFOX Trouble

Postby emorrp1 on Thu Apr 02, 2009 6:43 am

There's a font config tool, I think it's under appearance settings, where you can turn on "anti-aliasing", which I think is what you're after
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: FIREFOX Trouble

Postby JohnH on Thu Apr 02, 2009 6:49 am

Dan,

The fonts can be improved, but it is up to you to fiddle with them to get what you like. this is governed by a number of factors.

1) what fonts you have loaded
2) The theme you are running
3) Your preferences

You can find the fonts in FF Edit > Preferences > Content > Advanced .

Here are my settings:
Proportional: serif Size = 14
Serif: DejaVu Serif
Sans: DejaVu Sans
Monospace: Courier New 12

My current theme is Camifox. I prefer the Aero themes but they have a rendering problem with the Forecast Fox I like to run in the bottom bar.

Hope this helps.

John
If you get too big for your britches, you will be exposed in the end.
User avatar
JohnH
Level 4
Level 4
 
Posts: 215
Joined: Wed Nov 22, 2006 4:15 am
Location: Caboolture, Oz

Re: FIREFOX Trouble

Postby youdkelon on Thu Apr 02, 2009 7:51 am

emorrp1 wrote:There's a font config tool, I think it's under appearance settings, where you can turn on "anti-aliasing", which I think is what you're after


I couldn't find it, thanks for the help though.

JohnH wrote:Dan,

The fonts can be improved, but it is up to you to fiddle with them to get what you like. this is governed by a number of factors.

1) what fonts you have loaded
2) The theme you are running
3) Your preferences

You can find the fonts in FF Edit > Preferences > Content > Advanced .

Here are my settings:
Proportional: serif Size = 14
Serif: DejaVu Serif
Sans: DejaVu Sans
Monospace: Courier New 12

My current theme is Camifox. I prefer the Aero themes but they have a rendering problem with the Forecast Fox I like to run in the bottom bar.

Hope this helps.

John


I tried that but it for some reason it didn't look any different.
I found this: http://ubuntusite.com/fix-get-best-firefox-font-linux/
It looks better now and I also changed the theme which also helped but it still doesn't look as sharp as the one on windows.

Thanks again for your help
youdkelon
Level 1
Level 1
 
Posts: 26
Joined: Tue Mar 31, 2009 10:46 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 27 guests