Not possible to select KDE apps. as "preferred" in gnome

Questions about applications and software
Forum rules
Before you post please read this

Not possible to select KDE apps. as "preferred" in gnome

Postby tux-sven on Mon May 04, 2009 3:06 pm

I alwas used KDE 3.5 earlier but now I decided to give Gnome a try. This was because Linux Mint was so good-looking and well-performing. Everything worked so good out of the box, which I never had met before.
Now to the point: I installed the KDE application Digikam. (This i a really good photo manager with integrated advanced photo-editor :D )
I works all right but I can not select it as a "preferred application" to start automatically when i connect my camera. :(
I think it's the same with K3b. You can't select it as a preferred application. I prefer K3b (CD-burning) because i automatically shows MD5-sum before burning and also automatically verifies the newly burned CD/DVD. :D
Perhapes you can make the integration of KDE applications better? :?:

Thanks for your really good "flavor" of Linux. :D
User avatar
tux-sven
Level 3
Level 3
 
Posts: 111
Joined: Sun Mar 08, 2009 6:44 am
Location: Sweden (@ Kinnekulle)

Linux Mint is funded by ads and donations.
 

Re: Not possible to select KDE apps. as "preferred" in gnome

Postby exploder on Tue May 05, 2009 8:50 am

I think the problem that you are describing is likely a Gnome issue. I think there is a way to set the path to your preferred applications but I can not remember off the top of my head. I do understand your reasoning on the applications you have mentioned.
exploder
Level 15
Level 15
 
Posts: 5872
Joined: Tue Feb 13, 2007 10:50 am
Location: HartfordCity, Indiana USA

Re: Not possible to select KDE apps. as "preferred" in gnome

Postby rhodry on Wed May 06, 2009 1:32 am

You need to distinguish between "file associations" and "volume preferred applications" in Gnome.

The simplest method of "file association" in Gnome is to highlight a file with the relevant extension (actually it just needs to be the file type, not necessarily have an extension) such as .mp3; right click on the file; select Properties --> Open With; and select the application you want to be the default, eg Audacious. Remember in Gnome you do not have to 'Apply'. The selection does that as you go.

However, your problem is that the Digital Camera is not a 'file type', it is a 'removable media volume' - the same as a usb external drive or any other pluggable media device.

To set the default action for these, you:

Open Nautilus (File Browser) and go to Edit --> Preferences --> Media tab. Here you will find all sorts of options for default actions when dealing with removable media, including Digital Cameras (Digikam) and Blank DVDs (K3b) etc. You should be able to find what you want in there somewhere.

Remember two things. Gnome changes the option when you select it, so, you should note somewhere the original entry should you wish to return to it. I keep a little 'config' notebook for this purpose.

Also, people don't remember, or simply don't realize, that Nautilus is more than a File Manager. It actually controls many aspects of the Gnome desktop - that is why the options to control removable media ( that put icons on the Desktop) is in it's preferences.

Just to expand on that - if you want to use Nautilus as your File Manager whilst running under KDE or XFCE (for example) you have to run it as "nautilus --no-desktop". Something else controls the Desktop in KDE etc and you have to tell Nautilus not to try to take over the Desktop in those environments.

Hope this helps,
Rhodry.
rhodry
Level 4
Level 4
 
Posts: 347
Joined: Mon Jun 04, 2007 7:32 am

Re: Not possible to select KDE apps. as "preferred" in gnome

Postby tux-sven on Wed May 06, 2009 10:18 am

Thanks for your very infomative and fast reply. :D
Today I substituded Mint 6 to a Mint 7 RC 1 installation. Im gonna use your advises in Mint 7 RC 1 later.
At the moment I have great sound problems, probably due to my ATI 3650-AGP-graphics card. I must try to solve that first, othewise its hard to use the computer in a nice way. :wink:
By the way, Linux Mint 7 looks great! :D
User avatar
tux-sven
Level 3
Level 3
 
Posts: 111
Joined: Sun Mar 08, 2009 6:44 am
Location: Sweden (@ Kinnekulle)

Re: Not possible to select KDE apps. as "preferred" in gnome

Postby ypout on Mon Jun 08, 2009 4:59 am

rhodry wrote:You need to distinguish between "file associations" and "volume preferred applications" in Gnome.

To set the default action for these, you:

Open Nautilus (File Browser) and go to Edit --> Preferences --> Media tab. Here you will find all sorts of options for default actions when dealing with removable media, including Digital Cameras (Digikam) and Blank DVDs (K3b) etc. You should be able to find what you want in there somewhere.

Hope this helps,
Rhodry.


I am having the same issue here, if I follow the above instructions there are no applications available to select under Photos - If I install F spot it appears but Digikam is not available.

Any ideas?

EDIT - I got this to work by following some steps from here -->http://ubuntuforums.org/showthread.php?t=779363&page=2

Try this - copied from above but with a bit of a modification:

A nice and easy way for replacing F-Spot with Digikam or other software under Gnome as default photo import program:
- Open a command line with Alt+F2 and run "gconf-editor"
- Navigate to "desktop / gnome / volume_manager"
- Change the line "autophoto_command" to read "digikam --download-from %m"

the autophoto_command string may be blank if you have nothing configured currently; double click on the command and paste the digikam --download-from %m as the new string.

Works for me in Mint 7 :D
ypout
Level 1
Level 1
 
Posts: 4
Joined: Wed Nov 26, 2008 5:10 am

Re: Not possible to select KDE apps. as "preferred" in gnome

Postby tux-sven on Sun Jun 14, 2009 4:03 pm

ypout,
now I have tried to do as you suggest, but it does not work for me. :(
I think it is because the camera gets mounted automatic when I connect it to the computer. Digikam can't import photos from a mounted camera. (Probably Digikam itself wants to mount the camera to be able to use it.
Now I have came to that situation when the window should appear, where you normally select what to do with your newly connected camera, this window does not show up any longer. I think the reason is that I have checked in "do this every time" or something similar. :(
1. How do I get back this window? (asking me what to do with the camera)
2. How do I get the camera detected by Digikam without being mounted?

:?:
User avatar
tux-sven
Level 3
Level 3
 
Posts: 111
Joined: Sun Mar 08, 2009 6:44 am
Location: Sweden (@ Kinnekulle)

Re: Not possible to select KDE apps. as "preferred" in gnome

Postby ypout on Tue Jun 23, 2009 5:31 am

Hi

I'm sorry I'm not sure how to get the option window back, try through Nautilus:
Open Nautilus (File Browser) and go to Edit --> Preferences --> Photos tab - hopefully you get the option to set this back to ask every time.

If not let me know and I'll have a play on a VM, having got my system working I'm reluctant to mess it up.

I use a card reader to get my photos, but it definitely gets mounted first.

EDIT:

You may want to look here... http://www.linuxquestions.org/questions ... ed-694249/
ypout
Level 1
Level 1
 
Posts: 4
Joined: Wed Nov 26, 2008 5:10 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 32 guests