Screen dims when opening VLC and other applications [SOLVED]

Questions about applications and software
Forum rules
Before you post please read this

Screen dims when opening VLC and other applications [SOLVED]

Postby nebcanuck on Fri May 08, 2009 6:49 pm

Pretty simple problem, I would think, but haven't seen an answer yet.

When I open VLC, ltris, lbreakout2, Frozen Bubble, and a number of other applications the screen brightness dims considerably. I can fix this by unplugging my computer and plugging it back in, or by opening the preferences to power manager, but those are really aggravating to repeat every time you open common applications.

I'm running the RC to Linux Mint Gloria, and pretty much everything else is perfect! I'm using a Lenovo SL400 with an Intel graphics chip. The brightness controls don't work well under Linux, and haven't since I got the computer. They've been improving, but to date the only distribution which works well with my computer's brightness is Fedora. But in general it's not an issue until I run into something like this issue with VLC, where I'm not able to turn up the brightness except through workarounds!

Hoping the solution's pretty simple! Thanks in advance!
Last edited by nebcanuck on Tue Jun 02, 2009 2:51 pm, edited 1 time in total.
...loving life for Christ's glory...
User avatar
nebcanuck
Level 2
Level 2
 
Posts: 80
Joined: Fri Jun 27, 2008 6:27 pm
Location: Peterborough, Ontario, Canada

Linux Mint is funded by ads and donations.
 

Re: Screen dims when opening VLC and other applications

Postby Husse on Sat May 09, 2009 4:35 pm

This may be part of the Intel regression in recent kernel or drivers
I find you are not alone but I fail to find a solution.... (apart from the one you already have found)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Screen dims when opening VLC and other applications

Postby nebcanuck on Tue Jun 02, 2009 2:50 pm

Found a solution, albeit a temporary one, at https://bugs.launchpad.net/ubuntu/+source/vlc/+bug/273685:

just add the line

Option "DPMS" "false"

in the monitor section of your xorg.conf. It works!


Works for me. Hopefully will not matter once Intel problems get worked out.
...loving life for Christ's glory...
User avatar
nebcanuck
Level 2
Level 2
 
Posts: 80
Joined: Fri Jun 27, 2008 6:27 pm
Location: Peterborough, Ontario, Canada


Return to Software & Applications

Who is online

Users browsing this forum: Google Adsense [Bot], Yahoo [Bot] and 19 guests