cpu throtteling

Questions about applications and software
Forum rules
Before you post please read how to get help

cpu throtteling

Postby Ledda on Thu May 17, 2007 1:31 pm

hi

i'm having some problems with kpowersave on my laptop... it is not efficient. The powersave in kubuntu dapper was much better than this version.
if i set the kpowersave in bianca to :"energy saving" my fans just keep blowing, in dapper they went silent. Is there a way to downgrade?
Last edited by Ledda on Thu May 17, 2007 6:50 pm, edited 1 time in total.
User avatar
Ledda
Level 2
Level 2
 
Posts: 59
Joined: Mon May 14, 2007 11:35 am
Location: Gent, Belgium

Linux Mint is funded by ads and donations.
 

Postby Ledda on Thu May 17, 2007 5:01 pm

anybody with a solution?? its really annoying... my laptop keeps shutting it self out for protection.

i cant find Klaptop to install that instead of kpowersave...


also i have some shutting down problems, i cant shutdown or reboot properly. Have to use powerswitch on laptop.
User avatar
Ledda
Level 2
Level 2
 
Posts: 59
Joined: Mon May 14, 2007 11:35 am
Location: Gent, Belgium

Postby Ledda on Thu May 17, 2007 5:36 pm

okay, back on windows, i have like 10 minutes of working time before my laptop overheats and shuts it self down.

in windows i have no problems at all (linux can learn from their powersaving knowledge :p)

but i'm coming to a solution myself: when i do a sudo apt-get install klaptopdaemon i'm receiving a 404 error from the sources.list, some kind of source is down (a feisty source) my internet is up and working. is there a alternate source with klaptop and it deps availeble?
User avatar
Ledda
Level 2
Level 2
 
Posts: 59
Joined: Mon May 14, 2007 11:35 am
Location: Gent, Belgium

Postby Ledda on Thu May 17, 2007 6:48 pm

i've removed mint sources and replaced them with official feisty sources (only to install klaptopdaemon)

i've installed it, but still i cant throttle my cpu speed, i've installe kpowersave en powersaved from feisty but still i cant throttle my cpu speed... (i could throttle it with dapper, what so different so that i cant throttle it now?)
User avatar
Ledda
Level 2
Level 2
 
Posts: 59
Joined: Mon May 14, 2007 11:35 am
Location: Gent, Belgium

Postby D1Wayne on Thu May 17, 2007 8:48 pm

may not be relevant, but if you are running beryl, check
what is eating your CPU,

system->admin->System-monitor

if beryl then look here
Code: Select all
beryl settings manager
    Extras
         Mini-Viewport


if checked, uncheck it, when doing nothing on my system beryl was using 64% cpu
gnome was eating the rest

with Mini-viewport off, beryl uses 0% when not actually doing something
D1Wayne
Level 3
Level 3
 
Posts: 198
Joined: Tue Apr 24, 2007 6:11 am
Location: Pacific North West

Postby Ledda on Fri May 18, 2007 5:40 am

not running beryl.

but thats the problem, nothing is eating from my cpu, because i have no throttle capabilitys the fan just keep blowing at a standard rate, and thats too intensive for my laptop. Because the fan is blowing at high speed, it needs a lot of power, a lot of power causes even more heat, more heat is causing the fan too blow even much harder... its an endless cirkle. When it is getting too hot it shuts itself down.

In dapper i had klaptop, with klaptop i could scale my cpu in 5 steps (525MHz - 1900MHz) But now in mint i have no scaling option, whats so different about mint?

( in kpowersave i see a option "cpu throttling, but it is not highlited, i can not enable it)
User avatar
Ledda
Level 2
Level 2
 
Posts: 59
Joined: Mon May 14, 2007 11:35 am
Location: Gent, Belgium

Postby nick on Fri May 18, 2007 5:47 am

Might be worth chance. try installing powernowd, it may remove kpowersave, but my CPU thrittles back nicely with it
Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby Ledda on Fri May 18, 2007 5:59 am

that helped a little thx , the fans wont blow at max speed. But still i cant scale it, might there be a chance so i can scale it, just like in dapper?
User avatar
Ledda
Level 2
Level 2
 
Posts: 59
Joined: Mon May 14, 2007 11:35 am
Location: Gent, Belgium

Postby Ledda on Fri May 18, 2007 6:06 am

this is my powernowd output:

Code: Select all
stefan@ledda:~$ sudo powernowd
Password:
powernowd: PowerNow Daemon v0.97, (c) 2003-2006 John Clemens
powernowd: Found 1 scalable unit:  -- 1 'CPU' per scalable unit
powernowd:   cpu0: 530Mhz - 1855Mhz (7 steps)
User avatar
Ledda
Level 2
Level 2
 
Posts: 59
Joined: Mon May 14, 2007 11:35 am
Location: Gent, Belgium

Postby Ledda on Fri May 18, 2007 6:16 am

hmm i've installed KIMA ( a cpu speed checker) and i see that powernowd is scaling the cpu at it needs. the more load i put on it, the more power the cpu gets.

i think powernowd did the trick.
User avatar
Ledda
Level 2
Level 2
 
Posts: 59
Joined: Mon May 14, 2007 11:35 am
Location: Gent, Belgium

Postby nick on Fri May 18, 2007 6:27 am

nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby Ledda on Fri May 18, 2007 6:39 am

dont have beagle installed on my amd laptop.

When i read trough the topics I've learned that my cpu is scalable.

Code: Select all
stefan@ledda:~/Downloads$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies
1855154 1457621 1192599 927577 795066 662555 530044
stefan@ledda:~/Downloads$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors
userspace powersave ondemand conservative performance


I think that powernowd (that is doing its job fine) is working on "on demand" .

the fans even stopped blowing for a moment, but I'll search further so that i can control my cpu speed manually. (with userspace/powersave/ondemand...)
User avatar
Ledda
Level 2
Level 2
 
Posts: 59
Joined: Mon May 14, 2007 11:35 am
Location: Gent, Belgium

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: esturniolo and 19 guests