chroot problems

Questions about applications and software
Forum rules
Before you post please read how to get help

chroot problems

Postby tdexor on Wed Jun 17, 2009 2:23 pm

Hello I work for a school and have been experimenting with LTSP. I tried Mint as a recommendation and love it. But I am having some problems with getting the chroot to work. I type in the command "chroot /opt/ltsp/i386" and it says "chroot: cannot run command '/bin/bash': No such file or directory. I have went and verified that there is a folder for that path. I have done chroot --help and it gives me the help for it. I have tried searching forums and websites. If anyone has any ideas that would help I would really appreciate it. Thanks
tdexor
Level 1
Level 1
 
Posts: 5
Joined: Wed Jun 17, 2009 12:44 pm

Linux Mint is funded by ads and donations.
 

Re: chroot problems

Postby atlef on Wed Jun 17, 2009 2:44 pm

sudo chroot /opt/ltsp/i386 would be more correct, you need sudo at the beginning of the command.

atlef.
User avatar
atlef
Level 4
Level 4
 
Posts: 306
Joined: Sun Nov 18, 2007 8:20 am
Location: Stavanger NORWAY

Re: chroot problems

Postby tdexor on Wed Jun 17, 2009 2:48 pm

Well I am logging in as root to get it set up so I didn't think that I needed it. And I just double checked and tried it and it says the same exact thing. Thanks for the quick response.
tdexor
Level 1
Level 1
 
Posts: 5
Joined: Wed Jun 17, 2009 12:44 pm

Re: chroot problems

Postby emorrp1 on Wed Jun 17, 2009 2:48 pm

well, unless he's running it from a root bash shell. As I understand it he's got passed that stage by getting the bash error. As for the problem, have you checked that bash is installed at /opt/ltsp/i386/bin/bash?
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: chroot problems

Postby tdexor on Fri Jun 19, 2009 8:20 am

No there is nothing past the /opt/ltsp/i386 it is empty. Any ideas on how to get it installed there?
tdexor
Level 1
Level 1
 
Posts: 5
Joined: Wed Jun 17, 2009 12:44 pm

Re: chroot problems

Postby emorrp1 on Fri Jun 19, 2009 9:56 am

Look at the installing bash section at http://www.ffnn.nl/pages/articles/linux ... or-cvs.php (second google hit)
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: chroot problems

Postby tdexor on Fri Jun 19, 2009 4:27 pm

Thanks I'll check it out and get back to you ASAP.
tdexor
Level 1
Level 1
 
Posts: 5
Joined: Wed Jun 17, 2009 12:44 pm

Re: chroot problems

Postby tdexor on Mon Jun 22, 2009 9:19 am

Well I still couldn't get it to work so unless there are any other ideas I'm going to try Ubuntu for LTSP again. But thank you everyone for the effort.
tdexor
Level 1
Level 1
 
Posts: 5
Joined: Wed Jun 17, 2009 12:44 pm

Re: chroot problems

Postby emorrp1 on Mon Jun 22, 2009 9:54 am

Well any LTSP setup instructions that work for ubuntu should work for mint too (I believe the edubuntu addon provides LTSP functionality), but if there's an ubuntu-based distro specifically written for LTSP, I'd say go for it.
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: paulgk and 26 guests