Pidgin problem possibly after update

Questions about applications and software
Forum rules
Before you post please read this

Pidgin problem possibly after update

Postby hansencomputers on Thu Jun 18, 2009 5:41 pm

Hi,
I have two system running Mint 7. I am experiencing problems with Pidgin. Pidgin worked fine initially.

As far as I can tell, the problem developed after installing an update. I think it was the following update:

mintsystem 7.4.8 which was a level 1 update



I installed this update on two computers, and afterwards Pidgin does not function properly. I have the connecting symbol in the tray, and sometimes it connects, but the symbol is always there. Mostly, my Pidgin window is blank (no contacts showing) and I don't know if it has a connection.

Is it a coincidence? Could that update have affected Pidgin? Two separate PCs are affected the same way.


Thanks for any and all help


Mike
hansencomputers
Level 3
Level 3
 
Posts: 120
Joined: Sat Oct 25, 2008 12:51 am

Linux Mint is funded by ads and donations.
 

Re: Pidgin problem possibly after update

Postby optimize me on Thu Jun 18, 2009 7:13 pm

You can try installing Pidgin from the developers branch. It's the version I use, and I haven't had any problems with it.

After completely purging your current install of Pidgin, add these lines to your sources.list file
Code: Select all
## Pidgin developers
# deb http://ppa.launchpad.net/pidgin-developers/ubuntu jaunty main
# deb-src http://ppa.launchpad.net/pidgin-developers/ubuntu jaunty main
Save & exit. Follow it up at a terminal with
Code: Select all
sudo apt-get update
...and...
Code: Select all
sudo aptitude install pidgin
Notice I use aptitude for the install command. Since this is the development version of Pidgin, this is just to ensure that any missing dependencies get caught and installed too.

They call it a developers version, but I've been using Pidgin off that PPA for around 6 mos. or a year and whatever they put out to use seems pretty darn stable to me.
AMD Phenom II X6 1045T 2.8GHz 8GB DDR3 RAM ATI Radeon HD6970
User avatar
optimize me
Level 5
Level 5
 
Posts: 639
Joined: Wed Jun 03, 2009 5:25 pm

Re: Pidgin problem possibly after update

Postby hansencomputers on Thu Jun 18, 2009 7:36 pm

where do I find the "sources.list" file?

Mike
hansencomputers
Level 3
Level 3
 
Posts: 120
Joined: Sat Oct 25, 2008 12:51 am

Re: Pidgin problem possibly after update

Postby nebcanuck on Thu Jun 18, 2009 7:59 pm

/etc/apt/sources.list
...loving life for Christ's glory...
User avatar
nebcanuck
Level 2
Level 2
 
Posts: 80
Joined: Fri Jun 27, 2008 6:27 pm
Location: Peterborough, Ontario, Canada

Re: Pidgin problem possibly after update

Postby cloudsifter on Thu Jun 18, 2009 11:57 pm

i too cannot connect to my yahoo account with pidgin or any other instant messenger client I've tried to connect to yahoo
to, after the update.

James
cloudsifter
Level 1
Level 1
 
Posts: 1
Joined: Thu Jun 18, 2009 11:53 pm

Re: Pidgin problem possibly after update

Postby Salamancero on Fri Jun 19, 2009 12:29 am

same story here with pidgin. Thanks for the tip though optimize me!
Salamancero
Level 1
Level 1
 
Posts: 26
Joined: Sat Apr 18, 2009 12:24 am

Re: Pidgin problem possibly after update

Postby angelbeast on Fri Jun 19, 2009 12:34 am

optimize me wrote:You can try installing Pidgin from the developers branch. It's the version I use, and I haven't had any problems with it.

After completely purging your current install of Pidgin, add these lines to your sources.list file
Code: Select all
## Pidgin developers
# deb http://ppa.launchpad.net/pidgin-developers/ubuntu jaunty main
# deb-src http://ppa.launchpad.net/pidgin-developers/ubuntu jaunty main
Save & exit. Follow it up at a terminal with
Code: Select all
sudo apt-get update
...and...
Code: Select all
sudo aptitude install pidgin
Notice I use aptitude for the install command. Since this is the development version of Pidgin, this is just to ensure that any missing dependencies get caught and installed too.

They call it a developers version, but I've been using Pidgin off that PPA for around 6 mos. or a year and whatever they put out to use seems pretty darn stable to me.


How do you completely purge Pidgin?
Linux Mint 7 “Gloria”
HP DV8000 Laptop
Broadcom 4318 wireless
angelbeast
Level 3
Level 3
 
Posts: 153
Joined: Sun Dec 23, 2007 2:38 am

Re: Pidgin problem possibly after update

Postby fwc on Fri Jun 19, 2009 4:05 am

I am having this problem also but only for my Yahoo account. I will try developers version


optimize me wrote:After completely purging your current install of Pidgin, add these lines to your sources.list file
Code: Select all
## Pidgin developers
# deb http://ppa.launchpad.net/pidgin-developers/ubuntu jaunty main
# deb-src http://ppa.launchpad.net/pidgin-developers/ubuntu jaunty main



There is a gui for this in Synaptic for this also, no? I think you go into settings>repositories and click new. You will see a new entry provided with 3 fields. Set the binary as deb for the first link optimize provided, copy and paste the link into the URI field, paste jaunty into the distribution field and main into source field. Use the same pattern for the second link optimize provided only set the binary as deb-src. Hit reload and continue the process.

angelbeast wrote:
How do you completely purge Pidgin?

You should be able to go to the package manager and type Pidgin into the quick search and right-click>mark for complete removal
User avatar
fwc
Level 4
Level 4
 
Posts: 249
Joined: Sun Feb 15, 2009 12:23 am

Re: Pidgin problem possibly after update

Postby cldx3000 on Fri Jun 19, 2009 4:09 am

Should be
Code: Select all
sudo apt-get remove --purge pidgin*


wherein the * is a wildcard for any pidgin package like pidgin-dev or pidgin-libnotify if you have that installed (you can check for that in Synaptic)

Im not sure if you have to remove the User Settings as well but youll find them in /home/yourname/.purple, you could just remove the whole folder to make sure everythings gone, but remember your stored Account Information will be GONE.

...second thoughts anybody?

[EDIT] Sorry the --purge goes before the package name/s of course...
cldx3000
Level 1
Level 1
 
Posts: 9
Joined: Thu Jun 18, 2009 4:20 am

Re: Pidgin problem possibly after update

Postby angelbeast on Fri Jun 19, 2009 7:11 am

cldx3000 wrote:Should be
Code: Select all
sudo apt-get remove --purge pidgin*


wherein the * is a wildcard for any pidgin package like pidgin-dev or pidgin-libnotify if you have that installed (you can check for that in Synaptic)

Im not sure if you have to remove the User Settings as well but youll find them in /home/yourname/.purple, you could just remove the whole folder to make sure everythings gone, but remember your stored Account Information will be GONE.

...second thoughts anybody?

[EDIT] Sorry the --purge goes before the package name/s of course...


Excellent, thank you...I still keep ending up with version 2.5.5 though *LOL*...If that's a dev version then the dev version is not the solution as i'm still having the same problem :-)
Linux Mint 7 “Gloria”
HP DV8000 Laptop
Broadcom 4318 wireless
angelbeast
Level 3
Level 3
 
Posts: 153
Joined: Sun Dec 23, 2007 2:38 am

Re: Pidgin problem possibly after update

Postby hansencomputers on Fri Jun 19, 2009 9:10 am

I installed Kopete, but it has the same problem. Wont connect to my Yahoo account.

My wife's PC, still running Mint 6, is working normally with Pidgin and Yahoo



Mike
hansencomputers
Level 3
Level 3
 
Posts: 120
Joined: Sat Oct 25, 2008 12:51 am

Re: Pidgin problem possibly after update

Postby rivenathos on Fri Jun 19, 2009 9:14 am

There are several threads over in the Ubuntu forum in regards to the current Yahoo problem. You folks may wish to look over there. I saw a couple of fixes that worked.
Debian 7 with GNOME 64-bit
User avatar
rivenathos
Level 6
Level 6
 
Posts: 1066
Joined: Wed May 06, 2009 7:32 am
Location: USA

Re: Pidgin problem possibly after update

Postby fwc on Fri Jun 19, 2009 9:16 am

rivenathos wrote:There are several threads over in the Ubuntu forum in regards to the current Yahoo problem. You folks may wish to look over there. I saw a couple of fixes that worked.

are we sure its not that yahoo changed its server settings?

EDIT:
I found the thread and the information to update. The thread is http://ubuntuforums.org/showthread.php? ... gin&page=3
and the information to change is
Instead of: scs.msg.yahoo.com, I'm using: cn.scs.msg.yahoo.com


EDIT2:
Seems to work for me in Pidgin
User avatar
fwc
Level 4
Level 4
 
Posts: 249
Joined: Sun Feb 15, 2009 12:23 am

Re: Pidgin problem possibly after update

Postby hansencomputers on Fri Jun 19, 2009 11:10 am

I resolved my issues by adding the "cn." to the pager server

Thanks all who looked into this.

Mike
hansencomputers
Level 3
Level 3
 
Posts: 120
Joined: Sat Oct 25, 2008 12:51 am

Re: Pidgin problem possibly after update

Postby BandonRandon on Sun Jun 21, 2009 2:47 am

Version 2.5.7 of Pidgin Released which according to the pidgin site addresses the yahoo issue. http://developer.pidgin.im/wiki/ChangeLog meaning this most likely had nothing to do with the mintsystem update just an unfortunate coincidence.
User avatar
BandonRandon
Level 1
Level 1
 
Posts: 25
Joined: Fri Apr 17, 2009 2:33 am
Location: Seattle, WA

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: Yahoo [Bot] and 20 guests