Trying to use Kolourpaint

Questions about applications and software
Forum rules
Before you post please read how to get help

Trying to use Kolourpaint

Postby lexon on Fri Jul 10, 2009 5:00 pm

Rather than hijacking a thread, I decided to start this thread.

I have a question about Kolourpaint in Mint 7. I use to use it in Ubuntu 8.04 with no problem. Now it will not work in Mint 7 which does not seem much different than Ubuntu 8.04. Please explain in plain English. I do not understand dependencies and other Linux thingies. I guess Mint and Ubuntu are both Gnome.

I really need the Undo option that GNU Paint does not have. Sometimes I want to add text for certain things in photos and Gimp makes this extremely difficult. I have to close out GNU and start over again if I make a mistake. I now find Gimp is becoming unnecessarily complex for certain things I do with photos. I find now Gimp is doing something with layers. I am not an artist type.

Right now I have to slip in a Ubuntu 8.04 drive to do certain things with photos using Kolourpaint.

Any help will be appreciated.

lexon
Lindows, Linspire, Freespire, Ubuntu, Mint 15 Cinnamon, Mint 16 XFCE, Mint 17 Cinnamon 64 bit.
lexon
Level 5
Level 5
 
Posts: 726
Joined: Sat Jan 31, 2009 10:53 pm
Location: MA USA

Linux Mint is funded by ads and donations.
 

Re: Trying to use Kolourpaint

Postby DrHu on Fri Jul 10, 2009 5:33 pm

lexon wrote: I have a question about Kolourpaint in Mint 7. I use to use it in Ubuntu 8.04 with no problem. Now it will not work in Mint 7 which does not seem much different than Ubuntu 8.04.
I really need the Undo option that GNU Paint does not have
..
I find now Gimp is doing something with layers. I am not an artist type.

I really need the Undo option that GNU Paint does not have
I would have suggested Gpaint (Gnome paint) as an alternative, but that doesn't have undo..

Maybe not the graphic designer type, as layers are a big part of image editing..

KolourPaint is a simple drawing and image editing application for KDE 4.
It aims to be easy to use, providing a level of functionality targeted towards
the average user. It is ideal for common tasks such as drawing simple graphics
and touching-up photos.
This package is part of the KDE 4 graphics module.

Ubuntu 8.x doesn't use kde as the desktop, it is gnome based, however Kubuntu is the kde desdktop version of Ubuntu
--also that application kcolrpaint, unless you have an older version is being furher developed for kde 4x, the newest version of the kde desktop..

Kcolorpaint4 is in the mint reposiory, however it will have to pull in some kde4x software to maybe allow it to run ok on this Gnome desktop based distribution..

Some draw/painter program choices..
http://kolourpaint.sourceforge.net/
--which version ?, you can try the install of kcolorpaint4 within Linux mint 7 -gloria, it is in the repository, so presumably will install ok..
http://www.inkscape.org/
http://www.xara.com/us/
http://www.openoffice.org/product/draw.html
Last edited by DrHu on Fri Jul 10, 2009 5:48 pm, edited 1 time in total.
User avatar
DrHu
Level 17
Level 17
 
Posts: 7033
Joined: Wed Jun 17, 2009 8:20 pm

Re: Trying to use Kolourpaint

Postby lexon on Fri Jul 10, 2009 5:41 pm

Thanks for the answer but I did not understand much of that.

I would think Ubuntu 8.04 Gnome would be the same as Mint 7 Gnome.

lexon
Lindows, Linspire, Freespire, Ubuntu, Mint 15 Cinnamon, Mint 16 XFCE, Mint 17 Cinnamon 64 bit.
lexon
Level 5
Level 5
 
Posts: 726
Joined: Sat Jan 31, 2009 10:53 pm
Location: MA USA

Re: Trying to use Kolourpaint

Postby DrHu on Fri Jul 10, 2009 5:51 pm

lexon wrote:Thanks for the answer but I did not understand much of that.
I would think Ubuntu 8.04 Gnome would be the same as Mint 7 Gnome.

Thanks for the answer but I did not understand much of that.
The part you didn't understand is the difference between Gnome and kde as a desktop..
for, if you use kdecolorpaint4 and install it from the mint repository mint menu>Package Manager>kcolorpaint; it will require a lot of extra support software and kde libraries (system software ) in order to run this single application

Now it will not work in Mint 7 which does not seem much different than Ubuntu 8.04.
If you mean me..
The answer is no, Mint 7 is Ubuntu jaunty (9.4) version compatible..
--and finally, I said go ahead try kcolorpaint4, it is in the Mint repository..

Screenshot of kcolorpaint 4 installed
on Linux mint 7-gloria (Ubuntu desktop)
--it pulls in ~108mb of kde support files needed to enable a kde4 type
environment to run the application kcolorpaint4
Attachments
Screenshot.png
Screenshot.png (56.15 KiB) Viewed 695 times
User avatar
DrHu
Level 17
Level 17
 
Posts: 7033
Joined: Wed Jun 17, 2009 8:20 pm

Re: Trying to use Kolourpaint

Postby lexon on Fri Jul 10, 2009 7:17 pm

Hi Dr HU

I will give it a try. Right now I am using the Ubuntu drive with kolourpaint for a small project. I guess I did not recognize kcolorpaint 4 as an application by the label. I saw a reference to Kubuntu which I do not use.
Thanks.

lexon
Lindows, Linspire, Freespire, Ubuntu, Mint 15 Cinnamon, Mint 16 XFCE, Mint 17 Cinnamon 64 bit.
lexon
Level 5
Level 5
 
Posts: 726
Joined: Sat Jan 31, 2009 10:53 pm
Location: MA USA

Re: Trying to use Kolourpaint

Postby lexon on Fri Jul 10, 2009 7:57 pm

I did not find kcolorpaint 4. When I opened Package Manager, I searched for kcolorpaint 4. What was at the top of the results was Konqueror. I scrolled down and eventually found KolourPaint4. Is that what you meant?

lexon
Lindows, Linspire, Freespire, Ubuntu, Mint 15 Cinnamon, Mint 16 XFCE, Mint 17 Cinnamon 64 bit.
lexon
Level 5
Level 5
 
Posts: 726
Joined: Sat Jan 31, 2009 10:53 pm
Location: MA USA

Re: Trying to use Kolourpaint Solved

Postby lexon on Fri Jul 10, 2009 8:27 pm

Ok, no reply on my question so I downloaded Kolourpaint4. It looks the same as the Kolourpaint I use in Ubuntu 8.04.

The main issue, the application crashes when I try to undo a change. I get a link to a bug page and they want me to sign up. No thanks. Not another forum.

I will stick with the Ubuntu drive for Kolourpaint use. I learned nearly five years ago the with Linux, I have to sometimes do things my way.

I really miss the beauty of Linspire 5.1.427. It was the best OS for former Windows users and was rock solid but eventually support died.

Thanks for those who tried to help.

Consider this solved.

Cheers

lexon
Lindows, Linspire, Freespire, Ubuntu, Mint 15 Cinnamon, Mint 16 XFCE, Mint 17 Cinnamon 64 bit.
lexon
Level 5
Level 5
 
Posts: 726
Joined: Sat Jan 31, 2009 10:53 pm
Location: MA USA

Re: Trying to use Kolourpaint

Postby DrHu on Fri Jul 10, 2009 8:29 pm

lexon wrote:I did not find kcolorpaint 4. When I opened Package Manager, I searched for kcolorpaint 4. What was at the top of the results was Konqueror. I scrolled down and eventually found KolourPaint4. Is that what you meant?
lexon

Yes, but since I installed it and removed it, updates from mint seem to have caused it to not be available ..
--there was also a meta package there (dummy transitional..), but it was the package named kcolorpaint4 that installed and run correctly, using some kde4x libraries and support software, like phonon etc..

apt search kcolor
kcolorchooser - color chooser and palette editor for KDE 4
kcoloredit - color palette file editor for KDE 4
kcoloredit-kde4 - Transitional package

--this is all I see now, kcoloredit not the same thing as kcolorpaint4, so if you have it in repository, I would get it installed before it disappears..
Last edited by DrHu on Fri Jul 10, 2009 8:49 pm, edited 4 times in total.
User avatar
DrHu
Level 17
Level 17
 
Posts: 7033
Joined: Wed Jun 17, 2009 8:20 pm

Re: Trying to use Kolourpaint

Postby lexon on Fri Jul 10, 2009 8:36 pm

DrHu wrote:
lexon wrote:I did not find kcolorpaint 4. When I opened Package Manager, I searched for kcolorpaint 4. What was at the top of the results was Konqueror. I scrolled down and eventually found KolourPaint4. Is that what you meant?
lexon


Hi Dr Hu

You started to say something but did not finish. I already un-installed Kolourpaint4. Not to worry. If it does not work out of the box, I do not need it.

lexon
Lindows, Linspire, Freespire, Ubuntu, Mint 15 Cinnamon, Mint 16 XFCE, Mint 17 Cinnamon 64 bit.
lexon
Level 5
Level 5
 
Posts: 726
Joined: Sat Jan 31, 2009 10:53 pm
Location: MA USA

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: Google Adsense [Bot] and 28 guests