no bash prompt in terminal

Questions about applications and software
Forum rules
Before you post please read how to get help

no bash prompt in terminal

Postby fossfollow on Mon Jul 27, 2009 4:19 pm

When I open the terminal, i get no bash prompt, then bash takes up 50% of my cpu even if i exit the terminal, and i have to kill the process. I tried reinstalling the terminal from synaptic, but that did nothing. Any ideas?
fossfollow
Level 1
Level 1
 
Posts: 21
Joined: Sat Jan 10, 2009 3:27 pm
Location: Ontario, Canada

Linux Mint is funded by ads and donations.
 

Re: no bash prompt in terminal

Postby lagagnon on Mon Jul 27, 2009 5:03 pm

Please tell us what you did to get that situation. Have you recently installed new pacakges, updates, made any system file changes, removed users, home directory folders, etc???

Try installing a different terminal program such as "urxvt", open it up and type "gnome-terminal" and show us any errors you get...
User avatar
lagagnon
Level 7
Level 7
 
Posts: 1888
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: no bash prompt in terminal

Postby DrHu on Mon Jul 27, 2009 6:09 pm

Try this first..
  • ctrl alt F1
    --try the terminal in the full screen console
    ctrl alt F7
    --gets the graphic desktop reloaded..
  • If this works without hanging the system and does give you a prompt
  • sudo apt-get update
    --will refresh the system, the /etc/apt/sources.list file
  • sudo apt-get upgrade
    --clean up any older data
  • sudo apt-get clean
  • sudo apt-get autoclean
  • sudo apt-get autoremove
    --you will get a list of what the command is about to do..
  • env
    --shows the terminals, bash environment, which should have: as the last 4 lines..
    DISPLAY=:0.0
    XAUTHORITY=/home/mintuserID/.Xauthority
    COLORTERM=gnome-terminal
    =/usr/bin/env

Next try this..
In mint menu>control center>System>Users and Groups
--create a new user include in the admin group or match the settings you have for the first user as far as groups go..
Now see if that users' gnome-terminal has the correct bash prompt and does/does not cause any problems
If this works, the problem is something in your settings/customization for the initial user
--so some careful checking of the control panel settings is required..

Finally..last option...
Instead of reinstalling gnome-terminal, use remove and install

So, in synaptic (package manager) ..mint menu>system>Package Manager
    Search for gnome-terminal or terminal
  • Mark for complete removal
  • If you don't have bleachbit installed, install bleachbit and clean up your user files, by running bleachbit
    http://bleachbit-project.appspot.com/
User avatar
DrHu
Level 17
Level 17
 
Posts: 7034
Joined: Wed Jun 17, 2009 8:20 pm


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 8 guests