Broken Dependencies

Questions about applications and software
Forum rules
Before you post please read this

Broken Dependencies

Postby Dalamar on Mon Jul 27, 2009 6:26 pm

I was installing a .deb file when I encountered this message:

Your System has broken dependencies. Application cannot continue until this is fixed. To fix it, run 'gksudo synaptic' or 'sudo apt-get install -f' in a terminal window.

I tried sudo apt-get install -f first but it wasn't successful.
Code: Select all
sudo apt-get install -f
[sudo] password for jason:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libemeraldengine0
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  arc-wise
The following NEW packages will be installed:
  arc-wise
0 upgraded, 1 newly installed, 0 to remove and 69 not upgraded.
1 not fully installed or removed.
Need to get 0B/414kB of archives.
After this operation, 590kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  arc-wise
Authentication warning overridden.
(Reading database ... 128803 files and directories currently installed.)
Unpacking arc-wise (from .../arc-wise_2.6-0~ppa1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/arc-wise_2.6-0~ppa1_all.deb (--unpack):
 trying to overwrite `/usr/share/gdm/themes/Arc-Wise/suspend.png', which is also in package mint-artwork-gnome
Errors were encountered while processing:
 /var/cache/apt/archives/arc-wise_2.6-0~ppa1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
jason@Archmage ~ $
jason@Archmage ~ $ apt-get autoremove
E: Could not open lock file /var/lib/dpkg/lock - open (13 Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
jason@Archmage ~ $ sudo apt-get autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  arc-colors: Depends: arc-wise but it is not installed
E: Unmet dependencies. Try using -f.
jason@Archmage ~ $ apt-get -f install
E: Could not open lock file /var/lib/dpkg/lock - open (13 Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
jason@Archmage ~ $ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libemeraldengine0
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  arc-wise
The following NEW packages will be installed:
  arc-wise
0 upgraded, 1 newly installed, 0 to remove and 69 not upgraded.
1 not fully installed or removed.
Need to get 0B/414kB of archives.
After this operation, 590kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  arc-wise
Authentication warning overridden.
(Reading database ... 128803 files and directories currently installed.)
Unpacking arc-wise (from .../arc-wise_2.6-0~ppa1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/arc-wise_2.6-0~ppa1_all.deb (--unpack):
 trying to overwrite `/usr/share/gdm/themes/Arc-Wise/suspend.png', which is also in package mint-artwork-gnome
Errors were encountered while processing:
 /var/cache/apt/archives/arc-wise_2.6-0~ppa1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Then I tried gksudo synaptic and tried "fix broken dependencies but I got an error message (please see screenshot to view the message because I can't copy it).

Any ideas on how to fix this? Thanks!
Attachments
Error.png
Error.png (215.19 KiB) Viewed 771 times
Dalamar
Level 1
Level 1
 
Posts: 41
Joined: Wed Jan 14, 2009 1:34 am

Linux Mint is funded by ads and donations.
 

Re: Broken Dependencies

Postby DrHu on Mon Jul 27, 2009 6:47 pm

I didn't install Arc-Wise, and it is already there
    locate Arc-Wise
    /usr/share/gdm/themes/Arc-Wise
    /usr/share/gdm/themes/Arc-Wise/GdmGreeterTheme.desktop
    /usr/share/gdm/themes/Arc-Wise/background.png
    ...
On your console screen, arc-wise is already in mint-artwork-gnome In terminal, check
    apt search mint-artwork
    i mint-artwork-gnome - Default artwork for Linux Mint
Do you have any of the other possible requirements/ combinations needed..
http://packages.debian.org/sid/gnome/arc-wise
    Arc-Colors is a set of wallpapers and GDM themes made to complement the Shiki-Colors GTK+ themes and the GNOME-Colors icon themes.
    This package includes the Wise (Green) variation
User avatar
DrHu
Level 16
Level 16
 
Posts: 6297
Joined: Wed Jun 17, 2009 8:20 pm

Re: Broken Dependencies

Postby Dalamar on Mon Jul 27, 2009 7:18 pm

I think I tried to install it before, but it got broken somehow. I am trying to install a .deb of Moodle this time, but I can't because of the broken dependencies error message.
Dalamar
Level 1
Level 1
 
Posts: 41
Joined: Wed Jan 14, 2009 1:34 am

Re: Broken Dependencies

Postby Dalamar on Mon Jul 27, 2009 8:32 pm

Is it okay to remove arcwise if that'll solve the problem?
Dalamar
Level 1
Level 1
 
Posts: 41
Joined: Wed Jan 14, 2009 1:34 am

Re: Broken Dependencies

Postby Dalamar on Tue Jul 28, 2009 9:06 am

Bumping. I really need to fix this ASAP. I need to install a .deb file.

Thanks!
Dalamar
Level 1
Level 1
 
Posts: 41
Joined: Wed Jan 14, 2009 1:34 am

Re: Broken Dependencies

Postby DrHu on Tue Jul 28, 2009 1:15 pm

Dalamar wrote:Bumping. I really need to fix this ASAP. I need to install a .deb file. Thanks!

Sure get rid of the install that is causing the problem and try something else

http://packages.debian.org/sid/gnome/arc-wise
In your case that is Arc-Wise, you were installing from elsewhere
--not using it as part of Gnome/Linux mint 7-gloria
locate to find the data
    apt-get remove
    apt-get purge
http://www.debian.org/doc/manuals/apt-h ... et.en.html
--the various filename(s)/packages..
User avatar
DrHu
Level 16
Level 16
 
Posts: 6297
Joined: Wed Jun 17, 2009 8:20 pm

Re: Broken Dependencies

Postby Dalamar on Thu Jul 30, 2009 9:33 am

I got rid of the troublesome installation and now it's fixed. Thanks!
Dalamar
Level 1
Level 1
 
Posts: 41
Joined: Wed Jan 14, 2009 1:34 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: buzzbored, Elt10W, jefboyardee, MSNbot Media and 12 guests