Flash update problem

Questions about applications and software
Forum rules
Before you post please read this

Flash update problem

Postby David42 on Fri Aug 07, 2009 2:48 am

I have a very frustrating problem, trying to update the Firefox (3.0.13) flash plugin in Elyssa (KDE). Everything is fine with the original
installation. On the 'about:plugins' page, it shows as ver. 10.0.b218, but if I try to replace libflashplayer.so in /usr/lib/flashplugin-nonfree/
with any later version, it effectively "disappears". Firefox doesn't find it. Same with Opera. I restore the original libflashplayer.so and
everything works again.

Any help much appreciated - I'm new to Mint, still finding my way around.
David42
Level 1
Level 1
 
Posts: 2
Joined: Fri Aug 07, 2009 2:17 am
Location: Australia

Linux Mint is funded by ads and donations.
 

Re: Flash update problem

Postby Husse on Sun Aug 09, 2009 8:49 am

Welcome to Mint
There are multiple posts about updating/replacing flash in the forum(search for flash purge)
Try
Code: Select all
apt remove --purge -y flashplugin-nonfree nspluginwrapper

Code: Select all
apt install flashplugin-nonfree

Or just the first command and then install Adobe's flash
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Flash update problem

Postby David42 on Sun Aug 09, 2009 11:55 pm

Thanks for the reply, Husse. I tried re-installing 'flashplugin-nonfree', but that just
created an empty directory, so removed again and tried 'adobe-flashplugin'. That did
the trick - on the 'about:plugins' page, I now get the current version.

Thanks again!
David42
Level 1
Level 1
 
Posts: 2
Joined: Fri Aug 07, 2009 2:17 am
Location: Australia


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 16 guests