Locked setting in Configuration Editor.[Resolved not Solved]

Questions about applications and software
Forum rules
Before you post please read this

Locked setting in Configuration Editor.[Resolved not Solved]

Postby optimize me on Fri Aug 07, 2009 1:05 pm

I'm trying to change the name of my Trash icon on my desktop. When I click on it, write a new name and press return, it just reverts back to Trash.

I tried going into the Configuration Editor and changing the key by hand, but the key (trash_icon_name) at apps>nautilus>desktop says "This key is not writable." when I select it. I see no options for locking or for unlocking this key. I can't change it as root; i.e., if I gksu gconf-editor. Deleting the key and making a new one creates a new, non-writable key. None of the other keys in that section have this problem.

How can I make it so I can re-name my Trash icon again?

EDIT: I should add that I've also opened Mandatory & Default windows from the File drop-down menu. The key did appear in the Default Window but I was able to remove it. It is also in the Mandatory window (and is the only key there) but I am unable to remove it, even with superuser privileges. I've tried editing the relevant .xml files in both /etc/gconf and ~/.gconf and restarting X, but nothing works.
Last edited by optimize me on Sat Aug 08, 2009 12:16 pm, edited 1 time in total.
AMD Phenom II X6 1045T 2.8GHz 8GB DDR3 RAM ATI Radeon HD6970
User avatar
optimize me
Level 5
Level 5
 
Posts: 639
Joined: Wed Jun 03, 2009 5:25 pm

Linux Mint is funded by ads and donations.
 

Re: Locked setting in Configuration Editor.

Postby DrHu on Sat Aug 08, 2009 12:21 am

I don't know which one it will be, but it should be under /usr/share/icons, under your theme selection or Mint..

The other location ~/.icons is empty, so it must be using the system directory for icons (/usr/share/icons)

In terminal, check
--might help in locating file..
    locate user-trash
    locate gnome-fs-trash
User avatar
DrHu
Level 16
Level 16
 
Posts: 6921
Joined: Wed Jun 17, 2009 8:20 pm

Re: Locked setting in Configuration Editor.

Postby optimize me on Sat Aug 08, 2009 5:29 am

I'm not looking for the icon.. I know where that is. I want to rename it on my desktop so it doesn't say "Trash" underneath it - I just want to have a single space so that it appears blank when it's sitting there. Reason being I have a new wallpaper where the Trash icon blends in nicely with the background and looks almost like part of the photo, but the text underneath is a dead giveaway.

No matter what I do, I'm not allowed to rename that icon.
Attachments
Screenshot-Configuration Editor - desktop.png
Screenshot-Configuration Editor - desktop.png (87.1 KiB) Viewed 749 times
AMD Phenom II X6 1045T 2.8GHz 8GB DDR3 RAM ATI Radeon HD6970
User avatar
optimize me
Level 5
Level 5
 
Posts: 639
Joined: Wed Jun 03, 2009 5:25 pm

Re: Locked setting in Configuration Editor.

Postby viking777 on Sat Aug 08, 2009 7:48 am

When I look at that key in my system it is set to 'Integer' as the key type. Right click on the key select 'Edit' and change the 'Type' box to 'String'. This will introduce a 'Value' box underneath it which you can type into or leave blank as you like.

If it doesn't work for you first time then try again as root (Alt/F2 then gksu gconf-editor).
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Locked setting in Configuration Editor.

Postby optimize me on Sat Aug 08, 2009 9:15 am

viking777 wrote:When I look at that key in my system it is set to 'Integer' as the key type. Right click on the key select 'Edit' and change the 'Type' box to 'String'. This will introduce a 'Value' box underneath it which you can type into or leave blank as you like.

As myself:
Image
viking777 wrote:If it doesn't work for you first time then try again as root (Alt/F2 then gksu gconf-editor).

As superuser:
Image

The key isn't writable by me or by super-user - you can see the options to change anything are grayed out. I think that since gconf saves settings on a per-user basis, that when running gconf as super user or as root I get the settings for the root user. I should note that when I change to root in a terminal via sudo -su and run gconf-editor, the key there is editable and has no problems, but has no effect on my personal settings.

You'll also note that the given key value shows as blank. This is what I'm after anyways, and I think I got that because I edited the %gconf.xml file in ~/.gconf/desktop that holds that key. However, looking at my desktop, you can see that it's still labeled "Trash" and trying to rename it has no effect. Renaming the files in the hopes gconf will re-create new ones with default settings is also unsuccessful.

Image

I tried running this command from a terminal both as myself and as super-user, in the hopes that it would reset all the values in the apps>nautilus>desktop folder
Code: Select all
 gconftool-2 --recursive-unset /apps/nautilus/desktop
But that didn't unstick it either.
AMD Phenom II X6 1045T 2.8GHz 8GB DDR3 RAM ATI Radeon HD6970
User avatar
optimize me
Level 5
Level 5
 
Posts: 639
Joined: Wed Jun 03, 2009 5:25 pm

Re: Locked setting in Configuration Editor.

Postby viking777 on Sat Aug 08, 2009 11:46 am

Sorry I can't help you then, but at least I see how the idea fits into your desktop - very clever!
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Locked setting in Configuration Editor.

Postby optimize me on Sat Aug 08, 2009 12:15 pm

I don't know what happened. I don't know how it changed. I was just explaining to my wife the problem I was having with renaming that icon and showing her you guys' replies. I clicked on the icon, hit F2 to rename which highlighted the name that was there, hit space & pressed enter to give it a blank name, and it stuck!

I haven't rebooted, I haven't restarted X... I... just don't know.

Anyway.. here's the finished product:
Image
AMD Phenom II X6 1045T 2.8GHz 8GB DDR3 RAM ATI Radeon HD6970
User avatar
optimize me
Level 5
Level 5
 
Posts: 639
Joined: Wed Jun 03, 2009 5:25 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 19 guests