Issue installing texinfo

Questions about applications and software
Forum rules
Before you post please read how to get help

Issue installing texinfo

Postby GroovingClockwork on Sat Nov 21, 2009 8:16 am


EDIT: I got it to install and run by creating the nonexistent directories as root; still wondering why it didn't happen automagically though.

I am wanting to install texinfo in order to install Octave, but I get this error (most of it is in French but the error mssg is in English):

Code: Select all
~ $ sudo apt install texinfo
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Paquets suggérés :
  texinfo-doc-nonfree texlive-base texlive-generic-recommended
Les NOUVEAUX paquets suivants seront installés :
0 mis à jour, 1 nouvellement installés, 0 à enlever et 287 non mis à jour.
Il est nécessaire de prendre 0o/347ko dans les archives.
Après cette opération, 2195ko d'espace disque supplémentaires seront utilisés.
ATTENTION : les paquets suivants n'ont pas été authentifiés.
Avertissement d'authentification ignoré.
Sélection du paquet texinfo précédemment désélectionné.
(Lecture de la base de données... 142151 fichiers et répertoires déjà installés.)
Dépaquetage de texinfo (à partir de .../texinfo_4.11.dfsg.1-4_i386.deb) ...
Traitement des actions différées (« triggers ») pour « man-db »...
Paramétrage de texinfo (4.11.dfsg.1-4) ...
/usr/sbin/update-fmtutil: 633: cannot create /var/lib/texmf/web2c/ Directory nonexistent
update-fmtutil: cannot write to the temporary file '/var/lib/texmf/web2c/'
dpkg : erreur de traitement de texinfo (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
E: Sub-process /usr/bin/dpkg returned an error code (1)

Looks like it can't create a config file because the directory isn't there? What might prevent it from just creating that directory? Or is it not supposed to do that?

Level 1
Level 1
Posts: 40
Joined: Fri Jun 12, 2009 2:55 pm

Linux Mint is funded by ads and donations.

Re: Issue installing texinfo

Postby Husse on Sun Nov 29, 2009 8:54 am

Can't tell you why without some research and there is no time for that, but I had a similar problem solved not too long ago and if my memory serves me right it was a permissions issue
I think the command was make which tried to add something in usr for which you need to be root
Could be something similar
Don't fix it if it ain't broken, don't break it if you can't fix it
Level 23
Level 23
Posts: 19652
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Return to Software & Applications

Who is online

Users browsing this forum: Pjotr and 18 guests