Banshee not connecting to ipod

Questions about applications and software
Forum rules
Before you post please read how to get help

Banshee not connecting to ipod

Postby ruthy on Tue Jan 05, 2010 4:24 pm

i just did a fresh install and then installed banshee. Last time i did this as soon as the ipod was plugged in it showed up in Banshee but now it just wont show up.
i tried loging out and loging back in after connecting the ipod, but this didn't help ither.
ruthy
Level 3
Level 3
 
Posts: 109
Joined: Sat Aug 15, 2009 10:13 pm

Linux Mint is funded by ads and donations.
 

Re: Banshee not connecting to ipod

Postby Husse on Thu Jan 07, 2010 10:09 am

I just found this topic and made it sticky - hope it helps
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Banshee not connecting to ipod

Postby ruthy on Thu Jan 07, 2010 1:07 pm

Thanks for that, but there is no mention of Banshee not showing up a plugged in ipod. I just can't get Banshee to detect it.
ruthy
Level 3
Level 3
 
Posts: 109
Joined: Sat Aug 15, 2009 10:13 pm

Re: Banshee not connecting to ipod

Postby Husse on Fri Jan 08, 2010 7:09 am

Ah - much to read there
I found that this is a bug because of the switch from HAL to device-kit
Found a workaround
Start banshee, open a terminal and issue: nautilus -q
Then plug in your iPod and mount the iPod through nautilus - Banshee then picks up the iPod.
From here
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Banshee not connecting to ipod

Postby ruthy on Sat Jan 09, 2010 9:30 am

Thank you for taking the time to find that for me, you obviously had more success than I.
As requested i typed i typed nautilus -q (exactly like that) into the terminal, but it gave me this response: (nautilus:5869): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

Why is it saying failed?
ruthy
Level 3
Level 3
 
Posts: 109
Joined: Sat Aug 15, 2009 10:13 pm

Re: Banshee not connecting to ipod

Postby Husse on Sat Jan 09, 2010 11:10 am

Oh no - you can't use that in Helena - there's some change to Nautilus
I'll see if I can find a solution
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Banshee not connecting to ipod

Postby Husse on Sun Jan 10, 2010 6:50 am

Well the q option is not important - it's just quiet, Do not complain if no processes were killed.
Simply use killall nautilus (I've seen killall -9 but I still have to figure out what that is) and hope that's it
Sorry for not answering that immediately, it's very easy to find out
Banshee is supposed to work with an Ipod.....
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: Google Adsense [Bot] and 20 guests