No end of trouble with Cups

Questions about applications and software
Forum rules
Before you post please read this

No end of trouble with Cups

Postby A.Tim on Tue Jan 12, 2010 1:29 am

I solved a previous problem with cups with the help of husse. Now I have another one. In Firefox cups-pdf's status is set to failed. /var/log/cups/error_log containts these errors.

Code: Select all
E [11/Jan/2010:22:41:56 -0600] PID 9800 (/usr/lib/cups/backend/cups-pdf) stopped with status 5!
E [11/Jan/2010:22:42:14 -0600] PID 9814 (/usr/lib/cups/backend/cups-pdf) stopped with status 5!
E [11/Jan/2010:22:44:50 -0600] PID 9927 (/usr/lib/cups/backend/cups-pdf) stopped with status 5!
E [11/Jan/2010:22:45:07 -0600] PID 9942 (/usr/lib/cups/backend/cups-pdf) stopped with status 5!
E [11/Jan/2010:22:45:47 -0600] PID 9957 (/usr/lib/cups/backend/cups-pdf) stopped with status 5!
E [11/Jan/2010:22:46:56 -0600] CUPS-Add-Modify-Printer: Unauthorized
E [11/Jan/2010:22:47:34 -0600] PID 10036 (/usr/lib/cups/backend/cups-pdf) stopped with status 5!
E [11/Jan/2010:22:57:47 -0600] PID 10810 (/usr/lib/cups/backend/cups-pdf) stopped with status 5!
E [11/Jan/2010:22:58:05 -0600] PID 10817 (/usr/lib/cups/backend/cups-pdf) stopped with status 5!
E [11/Jan/2010:23:09:17 -0600] CUPS-Add-Modify-Printer: Unauthorized
E [11/Jan/2010:23:18:04 -0600] PID 13112 (/usr/lib/cups/backend/cups-pdf) stopped with status 5!
E [11/Jan/2010:23:24:50 -0600] PID 13725 (/usr/lib/cups/backend/cups-pdf) stopped with status 5!


I figured all of this stuff was supposed to work out of the box? It's frustrating trying to find out what's wrong. Anyway, I'm still using Gloria. Any idea what's going on? Any help would be really appreciated.

Thanks,

Tim
User avatar
A.Tim
Level 2
Level 2
 
Posts: 85
Joined: Tue May 05, 2009 3:33 pm
Location: USA

Linux Mint is funded by ads and donations.
 

Re: No end of trouble with Cups

Postby RedWagon on Tue Jan 12, 2010 4:57 am

Try running this:
Code: Select all
sudo aa-complain cupsd

That seems to be the best fix suggested in the bug report.
https://bugs.launchpad.net/ubuntu/+sour ... bug/295536
User avatar
RedWagon
Level 5
Level 5
 
Posts: 644
Joined: Tue May 26, 2009 6:41 pm

Re: No end of trouble with Cups

Postby A.Tim on Tue Jan 12, 2010 5:24 am

I tried that once and it didn't seem to work. Maybe restarting my machine helped. At any rate it's working now RedWagon. Thanks for responding!

Tim
User avatar
A.Tim
Level 2
Level 2
 
Posts: 85
Joined: Tue May 05, 2009 3:33 pm
Location: USA


Return to Software & Applications

Who is online

Users browsing this forum: JeremyPoynton, xenopeek and 24 guests