Cannot install software

Questions about applications and software
Forum rules
Before you post please read this

Cannot install software

Postby anthony2010 on Sun Jan 17, 2010 4:32 pm

Hi all.

In two years of running ubuntu and mint Ive failed every time to install a tar. whatever file.

Im aware of the procedure to cd to the file then ./configure - make - make install ( or sudo make install) It doesnt work. I get a confusing error message and installing the packages does jack.

So Please - is there a simple way to install tar. whatevers?

heres what I get:

anthony@anthony-desktop ~ $ cd Desktop
anthony@anthony-desktop ~/Desktop $ cd frameworks-0.3.6
anthony@anthony-desktop ~/Desktop/frameworks-0.3.6 $ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
/home/anthony/Desktop/frameworks-0.3.6/missing: Unknown `--run' option
Try `/home/anthony/Desktop/frameworks-0.3.6/missing --help' for more information
configure: WARNING: `missing' script is too old or missing
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for a BSD-compatible install... /usr/bin/install -c
checking for pkg-config... /usr/bin/pkg-config
checking for gtk+-2.0 gthread-2.0 libglade-2.0... Package gtk+-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gtk+-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gtk+-2.0' found Package gthread-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gthread-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gthread-2.0' found Package libglade-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `libglade-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'libglade-2.0' found
configure: error: Library requirements (gtk+-2.0 gthread-2.0 libglade-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
anthony@anthony-desktop ~/Desktop/frameworks-0.3.6 $ make
make: *** No targets specified and no makefile found. Stop.
anthony@anthony-desktop ~/Desktop/frameworks-0.3.6 $ ,/configure
bash: ,/configure: No such file or directory
anthony@anthony-desktop ~/Desktop/frameworks-0.3.6 $ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
/home/anthony/Desktop/frameworks-0.3.6/missing: Unknown `--run' option
Try `/home/anthony/Desktop/frameworks-0.3.6/missing --help' for more information
configure: WARNING: `missing' script is too old or missing
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for a BSD-compatible install... /usr/bin/install -c
checking for pkg-config... /usr/bin/pkg-config
checking for gtk+-2.0 gthread-2.0 libglade-2.0... Package gtk+-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gtk+-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gtk+-2.0' found Package gthread-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gthread-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gthread-2.0' found Package libglade-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `libglade-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'libglade-2.0' found
configure: error: Library requirements (gtk+-2.0 gthread-2.0 libglade-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
anthony@anthony-desktop ~/Desktop/frameworks-0.3.6 $

Any thoughts all?

cheers,

ant.
anthony2010
Level 3
Level 3
 
Posts: 159
Joined: Tue Jul 01, 2008 7:31 pm

Linux Mint is funded by ads and donations.
 

Re: Cannot install software

Postby markcynt on Mon Jan 18, 2010 6:36 am

You need to search each error as it comes up

For example searching for Package gtk+-2.0 was not found in the pkg-config search path gives you this http://www.google.com/search?q=Package+ ... =firefox-a and the first result is this http://ubuntuforums.org/showthread.php?t=375866.

Might be the solution to get you further.
Image
P5N-E SLI, Core2Duo E6850 3GHZ X 2
2 GB DDR2 800MHZ
EVGA 8800GTS 320MB
2x320GB Hitachi
Arctic Cooling Freezer 7 Pro
User avatar
markcynt
Level 6
Level 6
 
Posts: 1131
Joined: Sun May 17, 2009 10:53 am
Location: Lakeland Florida


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 14 guests