Pymusique

Questions about applications and software
Forum rules
Before you post please read this

Pymusique

Postby BrooksJohn on Sat Aug 04, 2007 6:49 am

Has anyone managed to get Pymusique installed on Mint? I have tried the various packages and instructions on the ubuntu forums as well as the debian packages from fuware,net but am unable to resolve some dependencies even though synaptic indicates the correct packages are installed.
BrooksJohn
Level 1
Level 1
 
Posts: 14
Joined: Tue May 08, 2007 7:30 am
Location: Wirral, UK

Linux Mint is funded by ads and donations.
 

Postby Husse on Sat Aug 04, 2007 2:10 pm

It seems that Pymusique evolved into SharpMusique according to
http://ubuntuforums.org/showthread.php?t=79231

http://lukeplant.me.uk/blog.php?sf=1117580399
there the guy says he had
issues with the debs from PyMusique - in particular I ended up installing gstreamer0.8-faad and libfaad2-0 from marillat's Debian repositories, instead of using the PyMusique ones.
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby BrooksJohn on Sun Aug 05, 2007 3:51 am

Thanks. Couldn't get the version in the link but have got a slightly older one. However it still has one dependency problem that I can't resolve as follows.

Code: Select all
dpkg: dependency problems prevent configuration of sharpmusique:
 sharpmusique depends on libfaad2-0 (>= 2.0.0+cvs20060416); however:
  Version of libfaad2-0 on system is 2.0.0+cvs20040908+mp4v2+bmp-0ubuntu3.
dpkg: error processing sharpmusique (--install):
 dependency problems - leaving unconfigured


I cannot find a way of updating libfaad to the required version.
BrooksJohn
Level 1
Level 1
 
Posts: 14
Joined: Tue May 08, 2007 7:30 am
Location: Wirral, UK

Postby Husse on Sun Aug 05, 2007 6:08 am

I've tried to find a source for the offending file and this is probably it
Before check if you have the good Marillat repositry in your
sources.list (he changes recently) :
- Stable (i386, sparc) :
deb http://www.debian-multimedia.org stable main
- Testing (i386, amd64 and sparc) :
deb http://www.debian-multimedia.org testing main
- Unstable (i386, sparc) :
deb http://www.debian-multimedia.org sid main

Marillat is the guy behind mplayer
Add the stable to your sources.list and when you've got the file comment out the line. If its not in the stable try the others
After you've added (and removed) the repo you have to update
In this case I would just open up synaptics and push the reload button, and when its done search for libfaad2-0 and check the version. In this case I find it handier to use synaptics than apt-get
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby BrooksJohn on Sun Aug 05, 2007 8:41 am

The repositories do not include the version identified above as required. They do include a package libfaad0 with a version number of 2.5-2.1. Do you think it's worth trying this? Synaptic shows that installing this package will remove the following:
avidemux
gstreamer0.10-plugins-bad-multiverse
libfaad2-0

Thanks in advance.
BrooksJohn
Level 1
Level 1
 
Posts: 14
Joined: Tue May 08, 2007 7:30 am
Location: Wirral, UK


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 30 guests