Beryl Stuffing up my Titlebars

Questions about applications and software
Forum rules
Before you post please read this

Beryl Stuffing up my Titlebars

Postby LostOverThere on Fri Aug 31, 2007 1:23 am

Well, I'm not sure if anyone else has had this problem, but whenever I turn on Beryl, it eats my tooltips like so:

Uh, Like this

Pretty much all that happens is I start Beryl (It did this even before I started changing the Beryl Settings) and it seems to eat my top toolbar.

Any suggestions?
User avatar
LostOverThere
Level 2
Level 2
 
Posts: 88
Joined: Thu Aug 16, 2007 6:15 am

Linux Mint is funded by ads and donations.
 

Postby Husse on Fri Aug 31, 2007 3:14 pm

I don't see anything out of the ordinary except a red blob
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby LostOverThere on Fri Aug 31, 2007 9:43 pm

Husse wrote:I don't see anything out of the ordinary except a red blob


There's no title bar with the Title, Minimize, Close, Enlarge buttons.
User avatar
LostOverThere
Level 2
Level 2
 
Posts: 88
Joined: Thu Aug 16, 2007 6:15 am

Postby Husse on Sat Sep 01, 2007 6:43 am

Damn it - I did not see that, you were talking about tooltips :)
This is a well known Beryl "bug"
It can be caused by a theme without those buttons
or Beryl in general. Here is a post from when I knew less :)
http://www.linuxmint.com/forum/viewtopi ... bar&t=1814
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby newW2 on Sat Sep 01, 2007 8:48 am

And if you have nvidia graphics look here as well:

http://www.linuxmint.com/forum/viewtopi ... ryl&t=2220
User avatar
newW2
Level 6
Level 6
 
Posts: 1081
Joined: Fri Apr 06, 2007 10:24 am
Location: USA

Postby LostOverThere on Tue Sep 04, 2007 2:20 am

Thanks for the help so far but sorry, still no go. :?
User avatar
LostOverThere
Level 2
Level 2
 
Posts: 88
Joined: Thu Aug 16, 2007 6:15 am

Postby Husse on Tue Sep 04, 2007 5:54 am

If you have a nvidia card I think this helps
Code: Select all
sudo nvidia-xconfig --add-argb-glx-visuals -d 24
then restart X
There is an equivalent for ATI
If not search in the forum for "beryl close buttons" and select "search for all terms" You get nine hits and the solution is certainly in one or more of them
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby KernelJ on Wed Sep 05, 2007 4:00 am

Thanks again Husse.. :wink: Solved straight away!

How do you get Beryl to load automatically when the DE starts up?
KernelJ
Level 1
Level 1
 
Posts: 26
Joined: Sat Apr 21, 2007 2:33 am

Postby newW2 on Wed Sep 05, 2007 9:39 am

In sessions. This how to has it:
http://www.linuxmint.com/forum/viewtopi ... ryl&t=1036

Once beryl has started go to mintMenu > Preferences > Sessions and click on the “Startup Programsâ€￾ tab, once there click the add button and type
Code:
/usr/bin/beryl-manager

this will make the beryl manger start every time you login.
User avatar
newW2
Level 6
Level 6
 
Posts: 1081
Joined: Fri Apr 06, 2007 10:24 am
Location: USA

Postby Husse on Wed Sep 05, 2007 1:26 pm

I answered this yesterday ?! But it's gone....
Oh well perhaps I never pushed the submit button or answered in the wrong thread :lol:
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: Charles Letan, malcolmla, wuftanoz and 14 guests