Trying to upgrade FileZilla -- Please Help

Questions about applications and software
Forum rules
Before you post please read this

Trying to upgrade FileZilla -- Please Help

Postby WinsorWoods on Sun Nov 04, 2007 4:19 am

I have linux mint 3.0 cassandra installed. Using the synaptic package manager, I installed Filezilla but it is not the current version. I cannot get Synaptic to find the latest version of filezilla 3.0.2.1.

I downloaded the source for filezilla 3.0.2.1 and installed the required dependent packages for compilation from source (WxWidgets, libidn, and GnuTLS 1.5.4 or greater)

The ./configure command gets past the check for WxWidgets and libidn, but I always get an error for GnuTLS. I have installed GnuTLS 2.0.1. The error message I get from the ./configure command is:

Code: Select all
checking for libgnutls-config... /usr/local/bin/libgnutls-config
checking for libgnutls - version >= 1.5.4...
*** 'libgnutls-config --version' returned 2.0.1, but LIBGNUTLS (1.4.4)
*** was found! If libgnutls-config was correct, then it is best
*** to remove the old version of LIBGNUTLS. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If libgnutls-config was wrong, set the environment variable LIBGNUTLS_CONFIG
*** to point to the correct copy of libgnutls-config, and remove the file config.cache
*** before re-running configure
configure: error:
***
*** libgnutls was not found. You may want to get it from
*** ftp://ftp.gnutls.org/pub/gnutls/

The last line of this error message listing the ftp server is where I obtained the GnuTLS 2.0.1 to begin with. I don't know why it thinks that LIBGNUTLS is version 1.4.4. I am at a total loss for what to do here. I just want to upgrade my filezilla and never thought it would be so hard to do! I would greatly appreciate some guidance with this problem.

Dan
WinsorWoods
Level 1
Level 1
 
Posts: 2
Joined: Thu Oct 11, 2007 1:37 am

Linux Mint is funded by ads and donations.
 

Postby Husse on Sun Nov 04, 2007 8:53 am

If you have a later version than 1.4.4 then libgnutls-config was wrong and your message states

*** If libgnutls-config was wrong, set the environment variable LIBGNUTLS_CONFIG
*** to point to the correct copy of libgnutls-config, and remove the file config.cache
*** before re-running configure

I don't have this in my system(s) so I can't guide you much...
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

upgrading filezilla

Postby WinsorWoods on Sun Nov 04, 2007 3:11 pm

I think the portion of the error message that is pertinent to me is:

'libgnutls-config --version' returned 2.0.1, but LIBGNUTLS (1.4.4)
*** was found! If libgnutls-config was correct, then it is best
*** to remove the old version of LIBGNUTLS. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.


I don't know how to remove the old version of LIBGNUTLS. I tried to remove it with Synaptic, however Synaptic wants to remove just about all of the installed programs that I have on my system as part of the removal of LIBGNUTLS. Among these programs that it wants to remove are gedit, azureus, brassero, beyrl, firefox, pidgin, thunderbird, the list goes on.

As far as the LD_LIBRARY_PATH environment variable, how do I modify it to solve this problem. I have no idea how to do this, or what modification to make if i did know how to do this. I don't know even know where gnutls 2.0.1 is installed. I used the system search to try to find it, but that was not successful.

As far as the ld.so.conf file. The following is a complete listing of that file:

include /etc/ld.so.conf.d/*.conf


What would I change in this file???

I have also run ldconfig from the command line. I had to "sudo ldconfig" to get it to work. There is no output from this command, thus I'm not sure what it actually does.

Because I had installed the gnutls 2.0.1 from source, I ran a "make uninstall" and then tried to "./configure" the filezilla but it returned an error message that gnutls was not installed and to install it. When I recompiled gnutls 2.0.1 from source again and installed it, I get the same error message as in my first post.

I am really confused here.

So I guess there are two ways around this problem:

1. figuring out how to uninstall LIBGNUTLS 1.4.4 WITHOUT Synaptic wanting to remove the majority of my installed programs

2. figuring out how to get the ./configure to recognize that I REALLY do have the proper version of gnutls installed.

Any further assistance is GREATLY appreciated!

Dan
WinsorWoods
Level 1
Level 1
 
Posts: 2
Joined: Thu Oct 11, 2007 1:37 am


Return to Software & Applications

Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot], mama_Mint13Maya and 20 guests