Java Development in Mint?

Questions about applications and software
Forum rules
Before you post please read this

Java Development in Mint?

Postby oblivion02 on Mon Nov 19, 2007 1:37 am

Hey guys, I just recently installed Mint, so I am not too sure about what I have/can/cannot do with it. I downloaded Eclipse, and Netbeans from the Software Portal. I checked and it says I have java 5 sdk installed. But when I run NetBeans, it says im only using the jre, not the jdk. Any suggestions as to how I can fix this error? I want to be able to program in Java while in Linux.

Thanks in advance!

-Oblivion
oblivion02
Level 1
Level 1
 
Posts: 43
Joined: Sun Nov 18, 2007 1:35 pm

Linux Mint is funded by ads and donations.
 

Re: Java Development in Mint?

Postby oblivion02 on Mon Nov 19, 2007 5:09 pm

[UPDATE]
After a fresh install of Linux Mint, I decided to start Java Developing. Basically what I did was, not follow the mint-install way. I downloaded these files from the Synaptic Package Manager:
Code: Select all
sun-java6-demo (6-03-0ubuntu2)
sun-java6-fonts (6-03-0ubuntu2)
sun-java6-jdk (6-03-0ubuntu2)
sun-java6-source (6-03-0ubuntu2)

**I did not install the doc because I got an error afterwards. **

After that, I used mintInstall to install NetBeans or Eclipse. I personally installed them both. Up to you though. After that, everything should work fine.

**NOTE: The error I was originally getting was because I had 2 JDKs installed, 2 JREs, etc. The 5 and the 6. I now have only the 6, and everything works fine.
oblivion02
Level 1
Level 1
 
Posts: 43
Joined: Sun Nov 18, 2007 1:35 pm


Return to Software & Applications

Who is online

Users browsing this forum: BenTrabetere, yellowparachute and 17 guests