Opera 11, No module named LinuxMint

Questions about applications and software
Forum rules
Before you post please read how to get help

Opera 11, No module named LinuxMint

Postby HorrorCode on Wed May 04, 2011 4:31 pm

Linux MInt 10 Julia - gnome, kernel linux 2.6.35-28-generic, all updates, using voria kernel build i believe

Code: Select all
$ sudo dpkg -i opera_11.10.2092_amd64.deb(Reading database ... 242121 files and directories currently installed.)
Preparing to replace opera 11.10.2048 (using opera_11.10.2092_amd64.deb) ...
Unpacking replacement opera ...
Setting up opera (11.10.2092) ...
Error in file "/usr/share/applications/gnumeric.desktop": "zz-application/zz-winassoc-xls" is an invalid MIME type ("zz-application" is an unregistered media type)
Warning in file "/usr/share/applications/opera-browser.desktop": usage of MIME type "x-scheme-handler/http" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/opera-browser.desktop": usage of MIME type "x-scheme-handler/https" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/opera-browser.desktop": usage of MIME type "x-scheme-handler/ftp" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/opera-browser.desktop": usage of MIME type "x-scheme-handler/mailto" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/google-chrome.desktop": usage of MIME type "x-scheme-handler/http" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/google-chrome.desktop": usage of MIME type "x-scheme-handler/https" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/google-chrome.desktop": usage of MIME type "x-scheme-handler/ftp" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Traceback (most recent call last):
  File "/usr/sbin/update-software-center", line 34, in <module>
    from softwarecenter.db.update import rebuild_database
  File "/usr/share/software-center/softwarecenter/db/update.py", line 41, in <module>
    from softwarecenter.db.database import parse_axi_values_file
  File "/usr/share/software-center/softwarecenter/db/database.py", line 26, in <module>
    from softwarecenter.db.application import Application
  File "/usr/share/software-center/softwarecenter/db/application.py", line 31, in <module>
    from softwarecenter.distro import get_distro
  File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 127, in <module>
    distro_instance=_get_distro()
  File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 116, in _get_distro
    module =  __import__(distro_id, globals(), locals(), [], -1)
ImportError: No module named LinuxMint
dpkg: error processing opera (--install):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for hicolor-icon-theme ...
Processing triggers for man-db ...
Processing triggers for shared-mime-info ...
Unknown media type in type 'all/all'

Unknown media type in type 'all/allfiles'

Unknown media type in type 'uri/mms'

Unknown media type in type 'uri/mmst'

Unknown media type in type 'uri/mmsu'

Unknown media type in type 'uri/pnm'

Unknown media type in type 'uri/rtspt'

Unknown media type in type 'uri/rtspu'

Unknown media type in type 'fonts/package'

Unknown media type in type 'interface/x-winamp-skin'

Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for menu ...
Processing triggers for mintsystem ...
Processing triggers for software-center ...
Traceback (most recent call last):
  File "/usr/sbin/update-software-center", line 34, in <module>
    from softwarecenter.db.update import rebuild_database
  File "/usr/share/software-center/softwarecenter/db/update.py", line 41, in <module>
    from softwarecenter.db.database import parse_axi_values_file
  File "/usr/share/software-center/softwarecenter/db/database.py", line 26, in <module>
    from softwarecenter.db.application import Application
  File "/usr/share/software-center/softwarecenter/db/application.py", line 31, in <module>
    from softwarecenter.distro import get_distro
  File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 127, in <module>
    distro_instance=_get_distro()
  File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 116, in _get_distro
    module =  __import__(distro_id, globals(), locals(), [], -1)
ImportError: No module named LinuxMint
Processing triggers for python-support ...
Processing triggers for python-central ...
Errors were encountered while processing:
 opera


ive gotten this part with a couple other things recently, one being Jupiter,(which doesnt support Ubuntu directly), so it leads me to believe maybe these packages just aren't compatible with Ubuntu/Mint

Code: Select all
dpkg: error processing *app* (--install):
 subprocess installed post-installation script returned error exit status 1


perhaps this is better asked on Opera forums, but I thought I'd start here, I've tried completely removing opera and starting over, and just upgrading from the repo 10.x stable version, to either the 11.x stable or beta, and no difference. I'd go on using 10 but certain javascript functions don't work, and printing has issues, so if it comes down to that I'll stick with the errors with 11 stable since they don't really inhibit the installation of anything.

Thanks again!

EDIT- Also, I have tried adding Operas repos, and none of them fixed this, not the one on Ubuntu and not the one on Opera, even tried the Debian repo. The strange thing is, Opera links to the Ubuntu page, and Ubuntu mentions their repo for Opera being broken, and links back to Opera.
HorrorCode
Level 3
Level 3
 
Posts: 137
Joined: Mon Sep 20, 2010 12:39 am

Linux Mint is funded by ads and donations.
 

Re: Opera 11, No module named LinuxMint

Postby HorrorCode on Fri May 06, 2011 12:20 am

I followed this post viewtopic.php?f=47&t=65008 and something in there on another site that involved removing 2 files using sudo rm, helped me finally remove this altogether.

The question that remains is, why does Opera have packages specifically for Mint in their downloads, that just don't work? Is there someway of figuring out what the underlying problem is? I don't really see this as solved since it's been an ongoing issue for a while now, especially with Opera, so perhaps it calls for a bug report?
HorrorCode
Level 3
Level 3
 
Posts: 137
Joined: Mon Sep 20, 2010 12:39 am

Re: Opera 11, No module named LinuxMint

Postby HorrorCode on Fri May 13, 2011 1:49 am

bump

anyone out there had this issue or a resolution for it? can anyone confirm if the issue still exists or if its been resolved with a different release, in particular a newer one than the 10.x i've been forced to use?
''
HorrorCode
Level 3
Level 3
 
Posts: 137
Joined: Mon Sep 20, 2010 12:39 am

Re: Opera 11, No module named LinuxMint

Postby wakeupgod on Sun Feb 24, 2013 5:09 pm

Here's what I did to fix this issue (While logged in as root, I know it's bad practice but I'm a RHEL sysadmin and I get tired of typing sudo when fixing a problem on my home desktop). Sorry for posting to a dead thread but I was searching for a solution today and while this thread didn't hold the solution it triggered my brain to realize what the solution was.

Code: Select all
machine-name ~ # apt-get remove software-center
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  oneconf software-center-aptdaemon-plugins ubuntu-sso-client
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  software-center
0 upgraded, 0 newly installed, 1 to remove and 2 not upgraded.
1 not fully installed or removed.
After this operation, 4,522 kB disk space will be freed.
Do you want to continue [Y/n]?
(Reading database ... 169611 files and directories currently installed.)
Removing software-center ...
Processing triggers for man-db ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Setting up opera (12.14.1738-1linuxmint) ...
machine-name ~ # apt-get autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  oneconf software-center-aptdaemon-plugins ubuntu-sso-client
0 upgraded, 0 newly installed, 3 to remove and 2 not upgraded.
After this operation, 407 kB disk space will be freed.
Do you want to continue [Y/n]?
(Reading database ... 169160 files and directories currently installed.)
Removing oneconf ...
Removing software-center-aptdaemon-plugins ...
Removing ubuntu-sso-client ...
machine-name ~ #


At this point, you can stop if you want to use opera, though I would recommend reinstalling it with "apt-get --reinstall install opera". I wanted to remove it, and this worked normally for me:

Code: Select all
machine-name ~ # apt-get remove opera
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  opera
0 upgraded, 0 newly installed, 1 to remove and 2 not upgraded.
After this operation, 45.5 MB disk space will be freed.
Do you want to continue [Y/n]?
(Reading database ... 169060 files and directories currently installed.)
Removing opera ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for man-db ...
Processing triggers for shared-mime-info ...
machine-name ~ #
wakeupgod
Level 1
Level 1
 
Posts: 2
Joined: Sun Feb 24, 2013 4:58 pm


Return to Software & Applications

Who is online

Users browsing this forum: minin, RunningInPleasePass and 29 guests