Don't prompt for password after resume from standby

Questions about applications and software
Forum rules
Before you post please read this

Don't prompt for password after resume from standby

Postby meltdown on Thu Nov 17, 2011 12:35 pm

I just installed Mint 12 RC. I have disabled the prompt for password when the screen saver comes on after 10 minutes in the settings. However, when I suspend my computer and then resume it, it is still asking me for a password. How can I disable that?
meltdown
Level 1
Level 1
 
Posts: 7
Joined: Tue Nov 15, 2011 10:12 am

Linux Mint is funded by ads and donations.
 

Re: Don't prompt for password after resume from standby

Postby Beardedragon on Thu Nov 17, 2011 1:12 pm

meltdown wrote:I just installed Mint 12 RC. I have disabled the prompt for password when the screen saver comes on after 10 minutes in the settings. However, when I suspend my computer and then resume it, it is still asking me for a password. How can I disable that?

Check your Power Manager and see if there is an option to turn it off there.
Robert Collard, Madison, WI
HP s5710f, 2x AMD Athlon II 260@3.2Ghz, 3GB RAM, 640GB HD
Debian 7.1 Wheezy 3,2,0-4 Xfce 4.10 AMD-64
LMDE 3.10.5-1 Xfce 4.10 AMD-64
SalineOS 2.0 3.2.0-4 Xfce 4.8 AMD64
User avatar
Beardedragon
Level 4
Level 4
 
Posts: 346
Joined: Sat Jan 29, 2011 3:37 am

Re: Don't prompt for password after resume from standby

Postby meltdown on Fri Nov 18, 2011 8:17 am

In the Power section of the system settings I only have options for which behaviors to perform when closing the lid when low on power, on battery vs plugged in, etc. I don't see anything about prompting for a password. Is there a config file somewhere that I have to edit?
meltdown
Level 1
Level 1
 
Posts: 7
Joined: Tue Nov 15, 2011 10:12 am

Re: Don't prompt for password after resume from standby

Postby Pilosopong Tasyo on Fri Nov 18, 2011 8:37 am

A similar question has been asked before in this thread. The general consensus was, it's an intrinsic function of the OS to ask you to key in your password when you resume from sleep or hibernation.

That said, this page seem to explain how to disable it. It was written for an older version of Ubuntu (9.10, hence, corresponds to Mint 10). No guarantee it will work for you (read the comment section). Only way to find out is to try.
Image
o Give a man a fish and he will eat for a day. Teach him how to fish and he will eat for a lifetime!
o If an issue has been fixed, please edit your first post and add the word [SOLVED].
User avatar
Pilosopong Tasyo
Level 6
Level 6
 
Posts: 1002
Joined: Mon Jun 22, 2009 3:26 am
Location: Philippines

Re: Don't prompt for password after resume from standby

Postby meltdown on Fri Nov 18, 2011 6:59 pm

I tried that but gnome-power-manager wasn't listed in the gconf-editor. I tried forcing the setting from the command line but that didn't have any effect. Maybe there is a config file I could manually edit somewhere that would control this behavior? This is a dealbreaker for me if I can't turn this off.
meltdown
Level 1
Level 1
 
Posts: 7
Joined: Tue Nov 15, 2011 10:12 am

Re: Don't prompt for password after resume from standby

Postby idgforum on Sat Nov 26, 2011 5:04 pm

Same problem here. I don't understand why all distros don't let the user do it from the menus. I like Linux Mint Lisa but this is a huge problem for me.
idgforum
Level 1
Level 1
 
Posts: 10
Joined: Sat Nov 26, 2011 4:54 pm

Re: Don't prompt for password after resume from standby

Postby idgforum on Sun Nov 27, 2011 9:27 am

I get it!

First install: gconfig editor
Then read this: viewtopic.php?f=42&t=79230
idgforum
Level 1
Level 1
 
Posts: 10
Joined: Sat Nov 26, 2011 4:54 pm

Re: Don't prompt for password after resume from standby

Postby Michael451 on Thu Dec 01, 2011 10:17 am

Using gconf-editor had no effect for me. Following advice in an Ubuntu forum, I installed dconf-tools and ran dconf-editor. There is an identical setting to disable-lock-screen titled "lockdown" under org>gnome>desktop. After checking that I am able to resume from suspend without password prompt, even after having unchecked the setting in gconf.
Michael451
Level 1
Level 1
 
Posts: 1
Joined: Thu Dec 01, 2011 9:31 am

Re: Don't prompt for password after resume from standby

Postby rsvargas on Fri Dec 02, 2011 9:29 am

Just found it...

Applications -> System Tools -> System Settings

Under "Personal", there's an item called "Screen", click it, and then just change the "Lock" switch to OFF.

And you're done!
rsvargas
Level 1
Level 1
 
Posts: 1
Joined: Fri Dec 02, 2011 9:25 am

Re: Don't prompt for password after resume from standby

Postby quangv on Wed Dec 21, 2011 7:49 pm

Doesn't work for me, I'm on a thinkpad t40 if that makes a difference
quangv
Level 1
Level 1
 
Posts: 13
Joined: Tue Dec 06, 2011 3:04 am

Re: Don't prompt for password after resume from standby

Postby mikesmithv on Sun Dec 25, 2011 8:18 pm

I was VERY annoyed by this also. I finally discovered the solution.

First install the dconf editor if not already installed:

sudo apt-get install dconf-tools

Then run it:

dconf-editor

Check the check box at:

org -> gnome -> desktop -> lockdown -> disable-lock-screen

You know it is going to work right away if the "Lock Screen" menu item disappears from the Log Out menu.

Merry Christmas!
mikesmithv
Level 1
Level 1
 
Posts: 9
Joined: Mon Nov 28, 2011 5:38 pm

Re: Don't prompt for password after resume from standby

Postby phamps on Fri Oct 05, 2012 8:30 pm

Hey,

I have been having this same issue. I did the turn off lock screen, but it didn't work. It seems more like a screen saver lock to me (at least on my screen) I am very new to linux, so after searching a while and comeing up empty handed I did some pokeing around on my own. I hit the menu, typed in the search box "screen" and clicked on brightness and lock. Turn off screen saver, or if you would like to keep it, you can just turn off authentication. Hopefully this work for anyone still haveing this issue.
phamps
Level 1
Level 1
 
Posts: 1
Joined: Fri Oct 05, 2012 8:26 pm

Re: Don't prompt for password after resume from standby

Postby xenopeek on Sat Oct 06, 2012 1:15 pm

Please create a new topic to get support on this. The topic you are responding to is almost two years old :shock: See the forum rules for reasons; please don't respond to topics older than 6 months.

Locked.
Forum Rules | IRC Channel Rules
Image
Arch Linux / 64-bit / Gnome Shell
User avatar
xenopeek
Level 21
Level 21
 
Posts: 13708
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: powerhouse and 14 guests