master volume problem(solved)

Questions about applications and software
Forum rules
Before you post please read this

master volume problem(solved)

Postby sorrowsbitch on Sun Jan 20, 2008 12:32 am

hi,

As a total newbie, I have just noticed that changing Master Volume does not change anything. For example, the volume level adjuster on upper right corner of the screen does not do anything. When I double-clicked there I figured out that changing master does not do anything but I can change the volume via PCM (whatever that is).

one thing I should note though I added "options snd-hda-intel model=auto" to the end of /etc/modprobe.d/alsa-base, to increase th volume level. It helped but it might cause this problem as well. (I am not sure whether Master Volume is working before my operation)

any ideas

cheers


Edit: ANSWER: Apparently it is not a big deal. You can change the volume from PCM or Headphones; and the level of sound volume is good.
Last edited by sorrowsbitch on Sun Jan 27, 2008 12:22 pm, edited 1 time in total.
sorrowsbitch
Level 1
Level 1
 
Posts: 13
Joined: Thu Jan 17, 2008 8:06 pm

Linux Mint is funded by ads and donations.
 

Re: master volume problem

Postby be80be on Sun Jan 20, 2008 8:29 pm

its the master volume control ist most time set to most like 70%
be80be
Level 1
Level 1
 
Posts: 25
Joined: Wed Dec 26, 2007 9:48 pm

Re: master volume problem

Postby sorrowsbitch on Sun Jan 20, 2008 9:58 pm

I can't change it though. I mean, I can move the slider but nothing happens.
sorrowsbitch
Level 1
Level 1
 
Posts: 13
Joined: Thu Jan 17, 2008 8:06 pm

Re: master volume problem

Postby Kynan on Sun Jan 20, 2008 11:19 pm

I experienced this problem also and it seemed to fix itself after fiddling with some settings. from what i can remember i made sure of a few things.
1. when right clicking on the sound icon in the far right bottom corner and going to preferences it is set to the correct device and set to master. (for me alsa mixer)
2. double clicking on the icon going to file device check its set to the same device (for me alsa mixer)
3. daryna menu > search for sound > check playback is set to automatic and default mixer tracks is the same device as 1. and 2. (for me alsa mixer)
4. now i remember that the settings did not take effect immediately and i gave up and just kept using my computer it actually took 20minutes and i was just using it not fiddiling any further when it suddenly started working but i'd suggest a reset or log out/in.
User avatar
Kynan
Level 4
Level 4
 
Posts: 246
Joined: Thu Oct 04, 2007 7:39 pm

Re: master volume problem

Postby sorrowsbitch on Mon Jan 21, 2008 12:34 am

Thanks a lot but apparently all those were correctly set before. There is the other option of "OSS", I tried it it is worse. I guess my situation is not that bad. I can change the volume by changing PCM. My worry is that I am not getting maximum sound I can get; youtube videos seem to be quite low volume for example. But I guess, it is probably about flash video. Anyway, thanks again.

Let me know if anything comes to your mind
sorrowsbitch
Level 1
Level 1
 
Posts: 13
Joined: Thu Jan 17, 2008 8:06 pm

Re: master volume problem

Postby Kynan on Mon Jan 21, 2008 1:46 am

you are saying that your sound is low hmm did you hibernate by any chance? i've experienced low sound problems after waking up from that in ubuntu and in mint, in ubuntu a reboot fixed it i can't remember if it fixed it in mint tho..
User avatar
Kynan
Level 4
Level 4
 
Posts: 246
Joined: Thu Oct 04, 2007 7:39 pm

Re: master volume problem

Postby mcss on Mon Jan 21, 2008 3:44 am

If you are using external speakers, master volume may not work. Right-click the sound icon in the panel and then click preferences. You can change the setting to PCM or headphone (at least in my case) to control the volume from the panel. Double-click the icon to change the levels for PCM, headphone, and master volume (I only use PCM and headphone volume settings, keeping the master volume muted since I use a laptop with external speakers.) Hope this helps.
mcss
 

Re: master volume problem

Postby sorrowsbitch on Mon Jan 21, 2008 9:45 am

thanks guys. I am using a desktop so I did not hibernate and my speakers are meant to be external. I think we have the the same issue with mcss. Like I said, it is not a big deal, I can adjust sound via PCM. I think I can live with it.
sorrowsbitch
Level 1
Level 1
 
Posts: 13
Joined: Thu Jan 17, 2008 8:06 pm

Re: master volume problem

Postby zachalekos on Fri May 02, 2008 5:31 pm

Kynan wrote:I experienced this problem also and it seemed to fix itself after fiddling with some settings. from what i can remember i made sure of a few things.
1. when right clicking on the sound icon in the far right bottom corner and going to preferences it is set to the correct device and set to master. (for me alsa mixer)
2. double clicking on the icon going to file device check its set to the same device (for me alsa mixer)
3. daryna menu > search for sound > check playback is set to automatic and default mixer tracks is the same device as 1. and 2. (for me alsa mixer)
4. now i remember that the settings did not take effect immediately and i gave up and just kept using my computer it actually took 20minutes and i was just using it not fiddiling any further when it suddenly started working but i'd suggest a reset or log out/in.


This worked for me
User avatar
zachalekos
Level 1
Level 1
 
Posts: 24
Joined: Fri Oct 05, 2007 4:29 am
Location: London

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: mangia, nomko and 19 guests