[Solved] oobase wizzard broken?

Questions about applications and software
Forum rules
Before you post please read this

[Solved] oobase wizzard broken?

Postby MartinRF on Wed Feb 27, 2008 5:17 pm

Last weekend I started to look into OpenOffice's database tool, oobase. I struggled
a bit before I found some nice tutorials and how-tos. Creating a table by using the
wizzard was OK. Adding some data to the table worked fine. Time to create a
report. Wizzard fires up -- not!

If I invoke oobase from command line in a terminal I can observe the following
when I try the report wizzard:

"com.sun.star.container.ElementExistException:
at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
at $Proxy18.insertByName(Unknown Source)
at com.sun.star.wizards.ui.UnoDialog.insertControlModel(UnoDialog.java)
at com.sun.star.wizards.ui.UnoDialog.insertEditField(UnoDialog.java)"
etc, etc, etc

This is OpenOffice 2.2.0 on a fully updated LinuxMint 3.0

If I try the same on my SUN at work it works just fine (using OO version 2.0.something).
I brought the database project back home and what I created at work works just
fine at home. I even tried that wizzard on a W2K box at work and it seemed to
fire up just fine.

So what's up? Is version 2.2.0 broken? Or is it the Linux version that's broken. Or is
it the Mint version or is it only on my system it doesn't work????

Any help is appreciated,

/Martin
Last edited by MartinRF on Sun Mar 02, 2008 6:45 am, edited 1 time in total.
User avatar
MartinRF
Level 1
Level 1
 
Posts: 42
Joined: Wed Jun 20, 2007 12:16 pm
Location: Sweden

Linux Mint is funded by ads and donations.
 

Re: oobase wizzard broken?

Postby Husse on Fri Feb 29, 2008 7:34 am

Try the OO support - forums faq...
Unfortunately does not ring a bell...
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: oobase wizzard broken?

Postby MartinRF on Sat Mar 01, 2008 12:54 pm

I got a quick reply on OOs forum for oobase:

"Very often, Linux distros use a different build as the official one. You should try the official (Sun) version, see here: install the official version of OOo : [Ubuntu] Installing OOo on Debian and Co."

The "see here" points at http://user.services.openoffice.org/en/ ... ?f=16&t=68

Is this true for Mint as well?
Anyone tried this?

/Martin
User avatar
MartinRF
Level 1
Level 1
 
Posts: 42
Joined: Wed Jun 20, 2007 12:16 pm
Location: Sweden

Re: oobase wizzard broken?

Postby Husse on Sat Mar 01, 2008 4:45 pm

We have the Ubuntu version - it's way to "heavy" to make our own
Link seems good
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: [Solved] oobase wizzard broken?

Postby MartinRF on Sun Mar 02, 2008 6:48 am

I just did what those instructions told me to do and it worked like a charm.
The result is much better than the Ubuntu-OOo that came with Mint!

/Martin
User avatar
MartinRF
Level 1
Level 1
 
Posts: 42
Joined: Wed Jun 20, 2007 12:16 pm
Location: Sweden

Re: [Solved] oobase wizzard broken?

Postby Husse on Sun Mar 02, 2008 10:00 am

Same version?
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: [Solved] oobase wizzard broken?

Postby MartinRF on Sun Mar 02, 2008 12:42 pm

No, 2.3.1 this time which may explain the snappiness but it does not explain the better integration into xfce's menu. I guess someone was in a hurry when preparing the Ubuntu package.

/Martin
User avatar
MartinRF
Level 1
Level 1
 
Posts: 42
Joined: Wed Jun 20, 2007 12:16 pm
Location: Sweden

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 23 guests