[Solved] Mint 13 Mate 32 bit, Sound Skips

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

[Solved] Mint 13 Mate 32 bit, Sound Skips

Postby barryp on Thu May 24, 2012 12:59 pm

Hi folks,

Enjoying Mint 13, Mate 32. It seems to run ok on this aging Tosh laptop. Thanks to Clem & all the team!

I'm getting irregular little clicks & skips in music playback with Audacious & Banshee. Not noticing any obvious clues like cpu or memory issues.

My sound set up on this laptop is

Code: Select all
inxi -A
Audio:     Card: Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller driver: snd_intel8x0
           Sound: Advanced Linux Sound Architecture ver: 1.0.24


If I look in Sound Preferences, Output all I see is: "Built-in Audio Analog Stereo" as my only option.

In play a lot of music through this particular laptop, so I'm keen for a solution. Any suggestions?

Thanks
Barry
Last edited by barryp on Sat May 26, 2012 4:25 am, edited 1 time in total.
User avatar
barryp
Level 2
Level 2
 
Posts: 55
Joined: Wed Sep 24, 2008 5:14 am

Linux Mint is funded by ads and donations.
 

Re: Mint 13 Mate 32 bit, Sound Skips

Postby barryp on Fri May 25, 2012 6:04 pm

Skipping, aka stuttering & glitching!

Killing pulseaudio didn't work. in fact then I had no sound at all.

I tried:

Code: Select all
sudo dpkg-reconfigure alsa-base
sudo dpkg-reconfigure alsa-utils
sudo dpkg-reconfigure pulseaudio


To no avail.

Desparate, I was prepared to look anywhere. Even ...ahem... a Fedora site, But I saw a line of code i recognized, about editing /etc/pulse/default.pa

Elsewhere in the Mint forum I had seen advice to:
Code: Select all
Change: load-module module-hal-detect
 to:
load-module module-hal-detect tsched=0


But don't have that line. However in this case it was followed by:
Code: Select all
   Change: load-module module-udev-detect
   to:
    load-module module-udev-detect tsched=0


Which I do have!

This change was followed by changes to /etc/pulse/daemon.conf:
Code: Select all
Skip down to about line 34 where it reads:
; realtime-scheduling = no

Change this to:
realtime-scheduling = yes

Skip down to about line 76 where it reads
; default-fragments = 4
; default-fragment-size-msec = 25

Change this to:
default-fragments = 8
default-fragment-size-msec = 5


Some of these settings did not need to be changed, they were already set to the recommended values.

It works! No More skipping, glitching or stuttering! :D

I hope that this may be helpful to someone.
User avatar
barryp
Level 2
Level 2
 
Posts: 55
Joined: Wed Sep 24, 2008 5:14 am

Re: [Solved] Mint 13 Mate 32 bit, Sound Skips

Postby craig100 on Wed Jul 25, 2012 7:41 am

I tried these changes and found that the skipping occurred with the same frequency but probably because of the reduced buffer time it skipped back a shorter amount so sounded even more weird. Not a fix for me I'm afraid on Linux Mint 13 Cinnamon.
craig100
Level 2
Level 2
 
Posts: 50
Joined: Mon Nov 07, 2011 1:37 pm
Location: Slough, UK


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: austin.texas, Google Adsense [Bot] and 9 guests