Can not play avi, mkv or any video files in Mint 13

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Can not play avi, mkv or any video files in Mint 13

Postby pacman257 on Sun Sep 02, 2012 7:56 pm

I just upgraded to Mint 13 Mate from Mint 11 Gnome with a clean install and when I try to play an avi file, I get sound but no video. Online videos play just fine and it doesn't matter what player I use. My primary choice is VLC. I have all the extra codecs installed but still no luck. Any help would be appreciated.

Update: I booted up with a live cd version of Moon OS ver. 4 last night on a whim and had no problems watching avi files.
Vini, Vidi Velcro.
I came, I saw, I stuck around.
pacman257
Level 1
Level 1
 
Posts: 11
Joined: Fri Oct 08, 2010 11:22 pm

Linux Mint is funded by ads and donations.
 

Re: Can not play avi, mkv or any video files in Mint 13

Postby pacman257 on Wed Sep 05, 2012 11:01 am

Yesterday I tried using a live cd of Mint 12 and Mint 11. I could play videos on 11 but nothing on 12 or 13. My solution was obvious. I uninstalled 13 and went back to 11. Life is good again. I guess the Mate desktop just doesn't work properly on this system.
Vini, Vidi Velcro.
I came, I saw, I stuck around.
pacman257
Level 1
Level 1
 
Posts: 11
Joined: Fri Oct 08, 2010 11:22 pm

Re: Can not play avi, mkv or any video files in Mint 13

Postby squeezy on Wed Sep 05, 2012 11:51 am

Is your version of Mint 13 one that doesn't include the multimedia codecs by default?
squeezy
Level 5
Level 5
 
Posts: 567
Joined: Thu Feb 23, 2012 2:05 pm
Location: The Land of Enchantment

Re: Can not play avi, mkv or any video files in Mint 13

Postby pacman257 on Wed Sep 05, 2012 11:59 am

No, it's the full DVD, I even went so far as to reinstall the extra codes no avail.
Vini, Vidi Velcro.
I came, I saw, I stuck around.
pacman257
Level 1
Level 1
 
Posts: 11
Joined: Fri Oct 08, 2010 11:22 pm

Re: Can not play avi, mkv or any video files in Mint 13

Postby pacman257 on Thu Sep 06, 2012 12:29 pm

On a whim this morning, I downloaded Mint 13 XFCE to see if that would solve the problem. No dice. What happened to all the versions after 11 that would cause this? Could it simply be a hardware compatibility issue?
Vini, Vidi Velcro.
I came, I saw, I stuck around.
pacman257
Level 1
Level 1
 
Posts: 11
Joined: Fri Oct 08, 2010 11:22 pm

Re: Can not play avi, mkv or any video files in Mint 13

Postby pacman257 on Tue Sep 11, 2012 12:39 am

Ok, still playing around with this using different versions and found out that Pinguy 10.10 plays all my videos. Pinguy 12.04 does not. Is it something in an updated version of the kernel?
Vini, Vidi Velcro.
I came, I saw, I stuck around.
pacman257
Level 1
Level 1
 
Posts: 11
Joined: Fri Oct 08, 2010 11:22 pm

Re: Can not play avi, mkv or any video files in Mint 13

Postby mank_in on Tue Sep 11, 2012 1:10 am

Maybe related with Graphic card /audio :

you can post an output of :
Code: Select all
inxi -F
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Can not play avi, mkv or any video files in Mint 13

Postby pacman257 on Tue Sep 11, 2012 1:25 am

System: Host paul-Dimension-2400 Kernel 2.6.38-8-generic i686 (32 bit) Distro Linux Mint 11 Katya
CPU: Single core Intel Pentium 4 (-UP-) cache 512 KB flags (sse sse2) bmips 5049.76 clocked at 2524.883 MHz
Graphics: Card Intel 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device X.Org 1.10.1 Res: 1024x768@0.0hz
GLX Renderer Software Rasterizer GLX Version 2.1 Mesa 7.10.2 Direct Rendering Yes
Audio: Card Intel 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller driver Intel ICH at ports ee00 edc0 BusID: 00:1f.5
Sound: Advanced Linux Sound Architecture Version 1.0.23
Network:
Disks: HDD Total Size: 1154.0GB (45.5% used) 1: /dev/sda WDC_WD1600JB 33.8GB
2: /dev/sdb WDC_WD1200JB 120.0GB 3: USB /dev/sdc WD10EACS 1000.2GB
Partition: ID:/ size: 30G used: 8.8G (31%) fs: ext4 ID:swap-1 size: 1.33GB used: 0.15GB (12%) fs: swap
Info: Processes 146 Uptime 3 days Memory 630.8/1245.4MB Runlevel 2 Client Shell inxi 1.4.23
Vini, Vidi Velcro.
I came, I saw, I stuck around.
pacman257
Level 1
Level 1
 
Posts: 11
Joined: Fri Oct 08, 2010 11:22 pm

Re: Can not play avi, mkv or any video files in Mint 13

Postby mank_in on Sat Sep 15, 2012 7:19 am

I don't know what is wrong.
I tested i845G with LM12 and didn't have problem play any video files.
In LM 12 GLX renderer for intel 845 is Mesa DRI
Maybe you can try don't use Hardware acceleration in media player.
VLC >tool>preferences>video , turn off accelerated video output (overlay)
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Can not play avi, mkv or any video files in Mint 13

Postby pacman257 on Mon Jun 03, 2013 8:45 pm

Still no solution to this. If I disable the video acceleration in VLC it closes as soon as I try and play a file. I can still watch videos online through the browser though.
This one little problem is all that is keeping me from upgrading and I would really like to upgrade so I can get some updates to the os.
Vini, Vidi Velcro.
I came, I saw, I stuck around.
pacman257
Level 1
Level 1
 
Posts: 11
Joined: Fri Oct 08, 2010 11:22 pm

Re: Can not play avi, mkv or any video files in Mint 13

Postby pacman257 on Wed Jun 05, 2013 9:32 am

941 views and only one suggestion?
Vini, Vidi Velcro.
I came, I saw, I stuck around.
pacman257
Level 1
Level 1
 
Posts: 11
Joined: Fri Oct 08, 2010 11:22 pm

Re: Can not play avi, mkv or any video files in Mint 13

Postby miumiu2134 on Wed Jun 05, 2013 9:36 am

I'm having the same problems with you guys... sometimes it just don't work....
how to create your own video with video clips captured by iphone? any mp4 editor recommend?
miumiu2134
Level 1
Level 1
 
Posts: 1
Joined: Thu May 23, 2013 5:23 am

Re: Can not play avi, mkv or any video files in Mint 13

Postby one_timer on Fri Aug 30, 2013 3:27 pm

Still no solutions? I'm having this issue on Mint 15 KDE on a system76 laptop.

Posting some MPlayer output to further the understanding of the problem:

MPlayer2 UNKNOWN (C) 2000-2012 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing ./star trek tos/seson 2/Star trek TOS 2x01.x264.DD5.1.avi.
Detected file format: AVI format (libavformat)
[avi @ 0x7f57efad48c0]max_analyze_duration reached
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (mp3), -aid 0
VIDEO: [H264] 1200x900 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
Load subtitles in ./star trek tos/seson 2/
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[vdpau] Error when calling vdp_device_create_x11: 1
[ass] auto-open
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Asking decoder to use 8 threads if supported.
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Requested audio codec family [mpg123] (afm=mpg123) not available.
Enable it at compilation.
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, floatle, 96.0 kbit/3.40% (ratio: 12000->352800)
Selected audio codec: [ffmp3float] afm: ffmpeg (FFmpeg MPEG layer-3 audio)
==========================================================================
AO: [pulse] 44100Hz 2ch floatle (4 bytes per sample)
Starting playback...
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 1200x900 => 1200x900 Planar YV12
Colorspace details not fully supported by selected vo.
A: 23.1 V: 23.1 A-V: 0.000 ct: 0.000 0/ 0 0% 1% 0.3% 0 0


MPlayer interrupted by signal 2 in module: sleep_timer
A: 23.2 V: 23.2 A-V: 0.000 ct: 0.000 0/ 0 0% 1% 0.3% 0 0

Exiting... (Quit)


I'm going to attempt to solve the issue, but I plan on installing arch anyway. I've barely looked at the output myself, but I will update if I find a solution.
one_timer
Level 1
Level 1
 
Posts: 2
Joined: Fri Aug 30, 2013 3:11 pm

Re: Can not play avi, mkv or any video files in Mint 13

Postby one_timer on Fri Aug 30, 2013 5:23 pm

Ok, so I found out my compiler is broken as well as well as a few essential components on this distro, and I do not have the time to troubleshoot all these issues. I'd rather build my system from the ground up.

After doing a little work I suspect that Mint is calling the wrong libraries by architecture not supported by my system. All of my drivers are correct but X is calling a bunch of weird and unecessary components. If you want to go further, look at X and not your drivers.
one_timer
Level 1
Level 1
 
Posts: 2
Joined: Fri Aug 30, 2013 3:11 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: dpetka2001 and 2 guests