Failing to stream Youtube videos with media players

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Failing to stream Youtube videos with media players

Postby Cerule on Fri Sep 14, 2012 8:42 am

I've low fps when playing Youtube flash videos fullscreen (drops from 30 to about 10) for some reason and would like to solve this by streaming videos through some media player. None of them seem to work. When I try to open URL with VLC or Mplayer it adds it to play list but just stops immediately. Strangely enough it worked first without problems but now it doesn't. I don't think I made any changes to settings. No problems when playing videos from hard drive.

I have Mint 13 KDE and Ati Radeon 4550 HD with propriety drivers. Tried Minitube and it worked but didn't manage to make browsers to open links with it. I'm using ext-youtube firefox add-on for that but didn't work with Minitube.

If I try open link with VLC in terminal it says:
[0xe2cd08] [http] lua interface: Lua HTTP interface
[0x7fe96800c038] lua demux error: Couldn't extract youtube video URL, please check for updates to this script

Mplayer says:
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Update: I manage to find combination that works for me and it's fFirefox Open With 5.2.1 add-on and Minitube 1.6. Would be still interesting to hear if you know what's the problem with VLC or Mplayer.
User avatar
Cerule
Level 1
Level 1
 
Posts: 24
Joined: Sat Sep 01, 2012 1:44 pm

Linux Mint is funded by ads and donations.
 

Re: Failing to stream Youtube videos with media players

Postby jamvaru on Tue Sep 18, 2012 8:04 pm

I got tired of it quitting on me all the time

i uninstalled everything swf and installed just 'lightspark' which also includes the basic gnash program

it works fine at small sizes, but is choppy at full screen or larger sizes (ctrl+/-)

I decided to just download a video if i really want to watch it in fullscreen; i usually put youtube off to the side anyways

no longer using adobe flash software at all, feels good

playing a youtube video no problem right now, going smoothly

any way to get rt.com/on-air to work?

[just ran flashupdate without the adobe files installed, just mintflash... it is working well]
Last edited by jamvaru on Tue Sep 18, 2012 10:37 pm, edited 1 time in total.
jamvaru
Level 3
Level 3
 
Posts: 196
Joined: Thu Dec 15, 2011 11:53 pm


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 6 guests