Video Tearing - Mint Maya XFCE

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Video Tearing - Mint Maya XFCE

Postby takis123 on Mon Sep 24, 2012 1:53 pm

Hello,

I've installed mint 13 xfce at my netbook :D It's vga is Intel Corporation Mobile 945GSE Express Integrated Graphics Controller. Everything runs fine except a tearing problem when watching youtube videos or videos with VLC. Is there something that I can do in order to stop tearing ?
takis123
Level 1
Level 1
 
Posts: 43
Joined: Wed Feb 29, 2012 5:36 pm

Linux Mint is funded by ads and donations.
 

Re: Video Tearing - Mint Maya XFCE

Postby Mozenrath on Tue Sep 25, 2012 12:26 am

My netbook happens to have the same graphics as yours, and I too get a bit of tearing when using GNOME 3 with Mutter/Metacity.

But honestly, I've never been able to get "tear-free" Linux. Ever. Even on my desktop, I still get tearing. It's ridiculous that most compositors don't let you just manually enter a refresh rate.
Mozenrath
Level 4
Level 4
 
Posts: 212
Joined: Thu Jun 17, 2010 12:41 am

Re: Video Tearing - Mint Maya XFCE

Postby mank_in on Tue Sep 25, 2012 2:09 am

You can try ( you can remove it later when the change is no effect):
Code: Select all
sudo gedit /etc/environment


add line :
Code: Select all
CLUTTER_PAINT=disable-clipped-redraws:disable-culling


save and reboot.
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Video Tearing - Mint Maya XFCE

Postby takis123 on Tue Sep 25, 2012 7:38 am

Mozenrath wrote:But honestly, I've never been able to get "tear-free" Linux. Ever. Even on my desktop, I still get tearing. It's ridiculous that most compositors don't let you just manually enter a refresh rate.



My netbook never had tearing problems with Mint 9. But I wanted something lighter and newer, so that's why I've installed mint maya xfce. It is better but tearing is the problem :(

mank_in wrote:You can try ( you can remove it later when the change is no effect):
Code: Select all
sudo gedit /etc/environment


add line :
Code: Select all
CLUTTER_PAINT=disable-clipped-redraws:disable-culling


save and reboot.



I'll try it, thank you
takis123
Level 1
Level 1
 
Posts: 43
Joined: Wed Feb 29, 2012 5:36 pm

Re: Video Tearing - Mint Maya XFCE

Postby takis123 on Tue Sep 25, 2012 7:56 am

I tried that solution but tearing doesn't stop :(
takis123
Level 1
Level 1
 
Posts: 43
Joined: Wed Feb 29, 2012 5:36 pm


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: Google Adsense [Bot] and 8 guests