Banshee 2.6.1 Not found in Repositories

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Banshee 2.6.1 Not found in Repositories

Postby ebranste on Fri Aug 30, 2013 1:49 am

I must be missing something simple but no matter what, I can't find Banshee 2.6.1 through repositories. I've confirmed the problem on both the system I upgraded to Mint 15 Olivia 64-bit and and a VM of a fresh install of the same.

I've added the ppa and updated the repositories, verified the entries are enabled in software sources and the authentication key is there. Still no matter what, I can't find the 2.6.1 package through apt-get or Synaptics.

I was able to work around this by finding the deb package from ubuntuupdates.org and installed it but I would like to know what I'm doing wrong that I can't get it from the normal repositories. I've verified through packages.ubuntu.com that it is there. I've also enable Backported packages, unstable packages, and source code repositories to see if that was the problem and the only version I see is 2.6.0.

Please, suggestions would be appreciated.

My repo files.....

Sources.list
# deb http://archive.getdeb.net/ubuntu raring-getdeb apps games

Official-Package-Repositories.list
deb http://packages.linuxmint.com olivia main upstream import backport romeo

deb http://archive.ubuntu.com/ubuntu raring main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu raring-updates main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ raring-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ raring partner
ebranste
Level 1
Level 1
 
Posts: 2
Joined: Fri Aug 30, 2013 12:15 am

Linux Mint is funded by ads and donations.
 

Re: Banshee 2.6.1 Not found in Repositories

Postby xenopeek on Fri Aug 30, 2013 2:34 am

The command `apt-cache policy banshee` shows you why this is.
Code: Select all
banshee:
  Installed: 2.6.0-2linuxmint1
  Candidate: 2.6.0-2linuxmint1
  Version table:
     2.6.1-1ubuntu1.2 0
        500 http://archive.ubuntu.com/ubuntu/ raring-updates/universe amd64 Packages
     2.6.1-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
 *** 2.6.0-2linuxmint1 0
        700 http://packages.linuxmint.com/ olivia/upstream amd64 Packages
        100 /var/lib/dpkg/status

As you can see, Banshee is included in the Linux Mint repository also and that has a higher priority than the Ubuntu repository. To install 2.6.1 you need to indicate you want it from the Ubuntu repository. As to why it is also in the Linux Mint repository I'm not 100% sure, but I believe adjustments are made to share part of the revenue for any online purchases in Banshee with the Linux Mint project. Switching to Banshee from the Ubuntu repository will cancel that.

To install Banshee from the Ubuntu repository:
Code: Select all
sudo apt-get install banshee/raring-updates
Forum Rules | IRC Channel Rules
Image
Arch Linux / 64-bit / Gnome Shell
User avatar
xenopeek
Level 21
Level 21
 
Posts: 13700
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Banshee 2.6.1 Not found in Repositories

Postby ebranste on Sat Aug 31, 2013 4:09 am

Worked! Thanks for being so informative as well. With that tidbit of info I was able to find out how to force install a version through Synaptics and change the priority too. Your help is appreciated.
ebranste
Level 1
Level 1
 
Posts: 2
Joined: Fri Aug 30, 2013 12:15 am


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 7 guests