Google Chrome - Crackling sound fix

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Google Chrome - Crackling sound fix

Postby Krystah on Sat Sep 14, 2013 3:35 pm

Evening Mints! Just thought I'd share what I came across as my only working fix (so far) for fixing my
issue with snappy, crackling sound in Google Chrome on Mint 15. If this has been posted before, my apologies.

I was quite clueless but nonetheless frustrated when I came across this issue, so I tried a variety of things:
(The relevance of the steps in my troubleshooting might vary, please bear with me)

- Jumping from Cinnamon to MATE - Nope.
- Updating from google-chrome-stable to google-chrome-dev to google-chrome-unstable - Nada.
- Manually updating to the latest flash plugin - Nothing.

It turned out it was an issue with pulseaudio, and this was the tweak that fixed my issue:

Open /etc/pulse/default.pa with sudo / as root and change the line
Code: Select all
load-module module-udev-detect use_ucm=0
to
Code: Select all
load-module module-udev-detect use_ucm=1
followed by a
Code: Select all
$ killall pulseaudio
in the terminal.

Hope this helps anyone. Happy weekend!
/Krystah
Krystah
Level 1
Level 1
 
Posts: 1
Joined: Sat Sep 14, 2013 3:07 pm

Linux Mint is funded by ads and donations.
 

Re: Google Chrome - Crackling sound fix

Postby attackroomba on Sat Dec 14, 2013 5:51 pm

Thanks for posing this. It really helped in figuring out a solution to a long standing problem that I've had. I wasn't able to use your exact solution due to my pulseaudio being version 1.1, and not 4.0 when the use_ucm option was introduced. However, I was able to do a little digging further and found a different solution for crackling.

I noticed this crackling after I was listening to music for a short while in a stand alone application, and then was browsing around on the net at the same time and ended up at a youtube flash video. I noticed that when both sources were playing (and even after playback of one had stopped), there was a noticable click/pop/crackle in the audio. It was highly irritating and continued until pulseaudio was restarted.

I found this thread which was quite helpful: https://bbs.archlinux.org/viewtopic.php ... 0#p1333820

The solution was to try a different resample-method other than the one that was assigned by default.

The resample methods available are visible using the pulseaudio command:

pulseaudio --dump-resample-methods
Code: Select all
src-sinc-best-quality
src-sinc-medium-quality
src-sinc-fastest
src-zero-order-hold
src-linear
trivial
speex-float-0
speex-float-1
speex-float-2
speex-float-3
speex-float-4
speex-float-5
speex-float-6
speex-float-7
speex-float-8
speex-float-9
speex-float-10
speex-fixed-0
speex-fixed-1
speex-fixed-2
speex-fixed-3
speex-fixed-4
speex-fixed-5
speex-fixed-6
speex-fixed-7
speex-fixed-8
speex-fixed-9
speex-fixed-10
ffmpeg
auto
copy
peaks


And can be changed in the daemon config. So far, I've settled on ffmpeg as my resample-method.

/etc/pulse/daemon.conf
Code: Select all
resample-method = ffmpeg


I tried several others and as described by some other users, they end up using a huge amount of CPU, but made the symptoms significanly more pronounced, so I knew I was on the right track. The default in my config/version is speex-float-1. The ffmpeg does well, however, and I've changed the setting an no longer hear the crackling. If I use ffmpeg for a while and noticed any crackling, I'm going to give the copy resample-method a try and see how that works out. It seems like it might be what I'm looking for since I probably don't need to resample anything anyway.
attackroomba
Level 1
Level 1
 
Posts: 3
Joined: Thu May 16, 2013 9:42 am


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 2 guests