Audio vibration in Linux Mint [SOLVED]

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Audio vibration in Linux Mint [SOLVED]

Postby andinux on Tue Dec 24, 2013 12:06 pm

Hello! My name is Andrés and I'm new in this forum. I'm not new in Linux, as I installed Linux Mint 11 when it started working.
The fact is that I've always had audio problems in Linux Mint. I've got Linux Mint 15 KDE and it happens the same as in Linux Mint 11. I cannot listen to music properly because there's a kind of vibration in the left speaker. It's really annoying and I can't enjoy my music. It doesn't happen when I connect my speakers in the computer when running Windows 7 or even in my Android mobile phone. What can it be?

Thank you very much for your help. :wink:

Greetings. :mrgreen:
Last edited by andinux on Sat Jan 11, 2014 9:05 am, edited 1 time in total.
andinux
Level 1
Level 1
 
Posts: 14
Joined: Tue Dec 24, 2013 11:28 am

Linux Mint is funded by ads and donations.
 

Re: Audio vibration in Linux Mint

Postby dagon on Tue Dec 24, 2013 4:09 pm

Hello!

What kind of speakers do you have? (USB, channels, brand...?)
Can you post back the output from this command?
Code: Select all
inxi -A


This Launchpad bug has some tips. Does it sound anything like your problem?
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/772738
Image
User avatar
dagon
Level 7
Level 7
 
Posts: 1690
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden

Re: Audio vibration in Linux Mint

Postby andinux on Wed Dec 25, 2013 12:05 pm

Hello! First of all, thank you very much for helping me.
As it regards to the bug explained in this page, if you want me to be honest, I don't understand it properly. I don't know if it's written in a correct English or maybe it's too technical but I understand only a few words.
Regarding my speakers and headphones, they both have got a 3'5 mm jack connector, neither usb connection, nor anything else. The brand of the speakers: Hercules. The brand of my headphones: Sennheiser HD 439.
In Windows and in my Android device, they both sound spectacular, but not in Linux (Maybe it's the audio card or a motherboard incompatibility).
The vibration is like if the plastic membrane of the left speaker was vibrating all the time. Imagine the sound of the plastic bundle of sweets (caramel / bonbon) when crumpling it. This is the sound.

Hope it helps identificate the bug. I wouldn't like to use linux mint for everything but for listening to music.

Thank you very much for your help. :wink:
andinux
Level 1
Level 1
 
Posts: 14
Joined: Tue Dec 24, 2013 11:28 am

Re: Audio vibration in Linux Mint

Postby andinux on Thu Dec 26, 2013 11:45 am

Sorry, I didn't remember to type inxi -A on the terminal.

This is what it reads:

inxi -A
Audio: Card: Intel NM10/ICH7 Family High Definition Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture ver: k3.8.0-26-generic

Thank you very much again.
andinux
Level 1
Level 1
 
Posts: 14
Joined: Tue Dec 24, 2013 11:28 am

Re: Audio vibration in Linux Mint

Postby dagon on Sun Dec 29, 2013 4:41 am

Sorry for the delay. Try this fix, it could work for your problem

Open
Code: Select all
/etc/pulse/default.pa

in a text editor and change the line that goes
load-module module-udev-detect

to
Code: Select all
load-module module-udev-detect tsched=0


Save the file and log out/in or stop pulseaudio with
Code: Select all
pulseaudio -k


Fix taken from here (among other places)
http://marian.schedenig.name/2012/11/08/fixing-pulseaudio-issues-on-ubuntu-12-10/

presumably nothing at all will catch fire from this. :wink:
Image
User avatar
dagon
Level 7
Level 7
 
Posts: 1690
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden

Re: Audio vibration in Linux Mint

Postby andinux on Fri Jan 03, 2014 3:45 pm

Hi, there. Thank you very much for your help and sorry for the delay. I've tried what you asked me to do, but it doesn't work. I wanted to change what you said, but the line load-module module-udev-detect didn't appear. It appeared load-module module-udev-detect use_ucm=0 instead. The fact is that I entered the page you passed me, and there is one guy that has got the same line as me, and as he says, in order to solve the problem, you have to change use_ucm=0 to tsched=0. I did it, but no results.
I tried to close pulseaudio by typing "pulseaudio-k" on the terminal, but it reads that "the order wasn't found".
Anyway, I've tried playing music and the vibration is still there.

I think I'll have to listen to music or watch videos on my phone or in Windows.

Thank you very much, indeed. :wink:


EDIT:

I've found this page, in which some people complain about pulseaudio. (viewtopic.php?f=48&t=115181) But there's one guy that says that the problem is the hardware. He /she bought an audio card and the audio works perfectly now. So, I think there's not a solution til I buy another audio card.

Thank you very much again. It's been a pleasure. :wink:
andinux
Level 1
Level 1
 
Posts: 14
Joined: Tue Dec 24, 2013 11:28 am

Re: Audio vibration in Linux Mint (SOLVED)

Postby andinux on Fri Jan 03, 2014 4:21 pm

I solved it!!!! 8) 8) 8) wooooowww! I'm very excited about that! :mrgreen:
The problem is not my hardware but Linux default sound configuration. I entered "pulseaudio" and I entered "configuration". I don't know how it's written in English as I've got my Linux in Valencian (Catalan), but I changed the configuration from "Dúplex estèreo analògic" to another different, doesn't matter which one you choose, except "Sortida estèreo analògic" (I suppose it's "Analogic Stereo output"), "Inactive" or "Entrada estèreo analògic (Analogic Stereo input)". If I choose the other options, it works properly. :mrgreen:

I write the solution just in case it happens to other people.

Greetings and thank you very much for everything! :P
andinux
Level 1
Level 1
 
Posts: 14
Joined: Tue Dec 24, 2013 11:28 am

Re: Audio vibration in Linux Mint

Postby dagon on Fri Jan 03, 2014 4:32 pm

Cool! 8)

ps. To mark the thread as solved you need to edit the subject line in the first post.
Image
User avatar
dagon
Level 7
Level 7
 
Posts: 1690
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden

Re: Audio vibration in Linux Mint [SOLVED]

Postby andinux on Sat Jan 11, 2014 9:09 am

dagon wrote:Cool! 8)

ps. To mark the thread as solved you need to edit the subject line in the first post.


Ok, dagon, I've edited the thread.

Thank you very much. :wink: :D
andinux
Level 1
Level 1
 
Posts: 14
Joined: Tue Dec 24, 2013 11:28 am

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 4 guests