PulseAudio

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

PulseAudio

Postby billybag on Thu Jul 31, 2008 4:31 pm

I have been racking my brains out trying to get my sound back. I had a problem with it when i first installed linux mint 5 and was able to fix it with this wonderful thread: http://ubuntuforums.org/showthread.php?t=789578 However something happened recently (i have no idea what) that has muddled it up again and this time that thread isnt helping!

Any ideas how to get my pulseaudio/sound to work currectly again?

This is what i get so far as an output for:
Code: Select all
$ pulseaudio -k; sleep 4; pulseaudio -vv
I: main.c: We're in the group 'pulse-rt', allowing real-time and high-priority scheduling.
I: core-util.c: Successfully gained nice level -11.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
I: main.c: This is PulseAudio 0.9.10
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_284b_sound_card_0_alsa_playback_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=0 sink_name=alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0'
D: alsa-util.c: Trying front:0...
I: module-alsa-sink.c: Successfully opened device front:0.
I: module-alsa-sink.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Using mixer control "Master".
I: sink.c: Created sink 0 "alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0" with sample spec "s16le 2ch 44100Hz"
I: source.c: Created source 0 "alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0.monitor" with sample spec "s16le 2ch 44100Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4352 bytes.
I: alsa-util.c: ALSA device lacks independant volume controls for each channel, falling back to software volume control.
D: module-alsa-sink.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device_id=0 sink_name=alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0").
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=0 source_name=alsa_input.pci_8086_284b_sound_card_0_alsa_capture_0'
D: alsa-util.c: Trying front:0...
I: module-alsa-source.c: Successfully opened device front:0.
I: module-alsa-source.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Using mixer control "Capture".
I: source.c: Created source 1 "alsa_input.pci_8086_284b_sound_card_0_alsa_capture_0" with sample spec "s16le 2ch 44100Hz"
I: module-alsa-source.c: Using 4 fragments of size 4352 bytes.
I: alsa-util.c: All 2 channels can be mapped to mixer channels. Using hardware volume control.
D: module-alsa-source.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+28
I: module.c: Loaded "module-alsa-source" (index: #1; argument: "device_id=0 source_name=alsa_input.pci_8086_284b_sound_card_0_alsa_capture_0").
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_284b_sound_card_0_alsa_hw_specific_2
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_284b_sound_card_0_alsa_control__1
I: module-hal-detect.c: Loaded 2 modules.
I: module.c: Loaded "module-hal-detect" (index: #2; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-esound-protocol-unix.so': success
I: module.c: Loaded "module-esound-protocol-unix" (index: #3; argument: "").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #4; argument: "").
I: module.c: Loaded "module-volume-restore" (index: #5; argument: "").
D: module-default-device-restore.c: Restored default sink 'alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0'.
I: module-default-device-restore.c: Saved default source 'combined.monitor' not existant, not restoring default source setting.
I: module.c: Loaded "module-default-device-restore" (index: #6; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #7; argument: "").
D: module-suspend-on-idle.c: Sink alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0 becomes idle.
D: module-suspend-on-idle.c: Source alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0.monitor becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.pci_8086_284b_sound_card_0_alsa_capture_0 becomes idle.
I: module.c: Loaded "module-suspend-on-idle" (index: #8; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-gconf.so': success
D: module-gconf.c: Loading module 'module-combine' with args '' due to GConf configuration.
I: sink.c: Created sink 1 "combined" with sample spec "s16le 2ch 44100Hz"
I: source.c: Created source 2 "combined.monitor" with sample spec "s16le 2ch 44100Hz"
D: memblockq.c: memblockq requested: maxlength=174080, tlength=174080, base=4, prebuf=1, minreq=0
D: memblockq.c: memblockq sanitized: maxlength=174080, tlength=174080, base=4, prebuf=4, minreq=4
D: module-suspend-on-idle.c: Sink alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0 becomes busy.
I: resampler.c: Using resampler 'trivial'
I: resampler.c: Using s16le as working format.
I: sink-input.c: Created input 0 "Simultaneous output on ALSA PCM on front:0 (STAC92xx Analog) via DMA" on alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0 with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
I: module-combine.c: Master sink is now 'alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0'
D: module-combine.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+27
D: module-suspend-on-idle.c: Source combined.monitor becomes idle.
D: module-suspend-on-idle.c: Sink combined becomes idle.
I: module.c: Loaded "module-combine" (index: #9; argument: "").
I: module.c: Loaded "module-gconf" (index: #10; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-x11-publish.so': success
D: module-x11-publish.c: using already loaded auth cookie.
I: module.c: Loaded "module-x11-publish" (index: #11; argument: "").
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus, path=/org/freedesktop/DBus, member=NameAcquired
I: module-suspend-on-idle.c: Source alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0.monitor idle for too long, suspending ...
I: module-suspend-on-idle.c: Source alsa_input.pci_8086_284b_sound_card_0_alsa_capture_0 idle for too long, suspending ...
I: module-alsa-source.c: Device suspended...
I: module-suspend-on-idle.c: Source combined.monitor idle for too long, suspending ...
I: module-suspend-on-idle.c: Sink combined idle for too long, suspending ...
D: module-suspend-on-idle.c: Sink alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0 becomes idle.
D: module-suspend-on-idle.c: Sink alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0 becomes idle.
I: sink-input.c: Freeing output 0 "Simultaneous output on ALSA PCM on front:0 (STAC92xx Analog) via DMA"
I: module-combine.c: No master selected, lacking suitable outputs.
I: module-combine.c: Device suspended...
I: module-suspend-on-idle.c: Sink alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0 idle for too long, suspending ...
I: module-alsa-sink.c: Device suspended...


any help or suggestions at all would be awesome... i have tried everything i can think of
billybag
Level 1
Level 1
 
Posts: 24
Joined: Sun Apr 06, 2008 7:54 am

Linux Mint is funded by ads and donations.
 

Re: PulseAudio

Postby billybag on Fri Aug 01, 2008 8:02 am

i think it has something to do with my update to Linux 2.6.24-19-386

i just want my sound back!!! the last thing i want to do is reinstall linux.... that is such a microsoft cop-out
billybag
Level 1
Level 1
 
Posts: 24
Joined: Sun Apr 06, 2008 7:54 am

Re: PulseAudio

Postby rivenought on Fri Aug 01, 2008 8:49 am

You may wish to roll back to the original kernel for Mint. I know a friend of mine did the Level 4 and 5 updates just for experimentation, thereby getting a new kernel. His sound no longer worked. He rolled back, and all returned to normal for him. You might want to consider trying that first. Good luck.
rivenought
Level 5
Level 5
 
Posts: 780
Joined: Wed Apr 09, 2008 10:34 am

Re: PulseAudio

Postby billybag on Fri Aug 01, 2008 10:10 am

DAMMIT. So i ended up reinstalling and that fixed it of course... but a few updates later AND THIS TIME I DID NOT UPDATE TO A NEW KERNEL. DID NOT DIS-UPGRADE ANYTHING.... gone. back to no sound. i am soooooo irked

nevermind. The level is just really low for some reason. i can barely here it and it is at max volume. lame
billybag
Level 1
Level 1
 
Posts: 24
Joined: Sun Apr 06, 2008 7:54 am

Re: PulseAudio

Postby rivenought on Fri Aug 01, 2008 10:30 am

If you have sound, although it is very low, you may need to adjust the volume sliders in the Pulse Audio controls. I fiddled with my settings in Sound and set my devices for Pulse Audio. There is the Pulse Audio Volume Control listed under the Sound and Video menu (but I think you have to enable it via Main Menu) that might need to be set properly. Also, in your panel Volume Control, you may wish to verify you have levels set as you prefer. This really appears to be a slider adjustment someplace. Once you get Pulse Audio figured out, you can share with the rest of us! :D Good luck!
rivenought
Level 5
Level 5
 
Posts: 780
Joined: Wed Apr 09, 2008 10:34 am

Re: PulseAudio

Postby billybag on Fri Aug 01, 2008 10:33 am

Yea i realized i had to fiddle with the default Volume Control. Still not as high as it used to be in past Ubuntus or in windows which is weird. PulseAudio has been the bane of my existence for the last 2 months. I respect what it is for and everything, i just wish their was an easier way. it would be nice if the next version of mint implemented an easier method oif Installing, Fixing, and Recovering sound.
billybag
Level 1
Level 1
 
Posts: 24
Joined: Sun Apr 06, 2008 7:54 am

Re: PulseAudio

Postby rivenought on Fri Aug 01, 2008 11:59 am

Well, as long as you have decent sound and can crank the volume up just a tad more, you are still way ahead of the folks who have absolutely no sound at all. The positives certainly outweigh the negatives by a very wide margin.

I cannot complain at all about my sound in Mint. Everything simply works.

Recently, I have noticed that with the same volume level settings, my secondary machine (with different hardware, but the same software) has slightly higher sound output. I use the same set of speakers with both machines (I swap the plug). Now, on that same secondary machine, when I run openSUSE KDE 4.1, I have to turn the volume down since the Phonon sound in KDE is radically different than GNOME. So, not only are there Pulse Audio/Phonon differences, but the audio cards make a difference, as well. All have very good sound, just varying audio levels. I can certainly live with that. Keep fiddling. :D
rivenought
Level 5
Level 5
 
Posts: 780
Joined: Wed Apr 09, 2008 10:34 am

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 6 guests