Headphone/Earbud Problem: Sound in one ear only (Mint 14+16)

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Headphone/Earbud Problem: Sound in one ear only (Mint 14+16)

Postby botanybear on Mon Jan 06, 2014 12:35 am

Tried several sets of headphones and it is always the same: they work perfectly well with my smartphone, but the Left ear has no volume when I use Mint (just upgraded from 14 to 16 today in hopes that the problem would be solved, but alas...). Occasionally, I would get sound in Virtualbox running Windows 7, so I'm really hoping it's no hardware issue. Searched the forums but couldn't find help with the issue of half-working headphones.

The machine is a Lenovo X1 (3825 I believe, not Carbon).

inxi -A:
Code: Select all
[color=#008000]Audio:     Card: Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture ver: k3.11.0-12-generic[/color]


lspci | grep Audio:
Code: Select all
[color=#008000]00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)[/color]


lspci:
Code: Select all
[color=#008000]00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b4)
00:1c.6 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 7 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM67 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000 [Condor Peak]
0d:00.0 System peripheral: Ricoh Co Ltd MMC/SD Host Controller (rev 07)
0f:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)[/color]


aplay -l:
Code: Select all
[color=#008000]**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CX20590 Analog [CX20590 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0[/color]


aplay -L:
Code: Select all
[color=#008000]default
    Playback/recording through the PulseAudio sound server
sysdefault:CARD=PCH
    HDA Intel PCH, CX20590 Analog
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, CX20590 Analog
    Front speakers
surround40:CARD=PCH,DEV=0
    HDA Intel PCH, CX20590 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
    HDA Intel PCH, CX20590 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
    HDA Intel PCH, CX20590 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
    HDA Intel PCH, CX20590 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
    HDA Intel PCH, CX20590 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
hdmi:CARD=PCH,DEV=0
    HDA Intel PCH, HDMI 0
    HDMI Audio Output
hdmi:CARD=PCH,DEV=1
    HDA Intel PCH, HDMI 1
    HDMI Audio Output
hdmi:CARD=PCH,DEV=2
    HDA Intel PCH, HDMI 2
    HDMI Audio Output
dmix:CARD=PCH,DEV=0
    HDA Intel PCH, CX20590 Analog
    Direct sample mixing device
dmix:CARD=PCH,DEV=3
    HDA Intel PCH, HDMI 0
    Direct sample mixing device
dmix:CARD=PCH,DEV=7
    HDA Intel PCH, HDMI 1
    Direct sample mixing device
dmix:CARD=PCH,DEV=8
    HDA Intel PCH, HDMI 2
    Direct sample mixing device
dsnoop:CARD=PCH,DEV=0
    HDA Intel PCH, CX20590 Analog
    Direct sample snooping device
dsnoop:CARD=PCH,DEV=3
    HDA Intel PCH, HDMI 0
    Direct sample snooping device
dsnoop:CARD=PCH,DEV=7
    HDA Intel PCH, HDMI 1
    Direct sample snooping device
dsnoop:CARD=PCH,DEV=8
    HDA Intel PCH, HDMI 2
    Direct sample snooping device
hw:CARD=PCH,DEV=0
    HDA Intel PCH, CX20590 Analog
    Direct hardware device without any conversions
hw:CARD=PCH,DEV=3
    HDA Intel PCH, HDMI 0
    Direct hardware device without any conversions
hw:CARD=PCH,DEV=7
    HDA Intel PCH, HDMI 1
    Direct hardware device without any conversions
hw:CARD=PCH,DEV=8
    HDA Intel PCH, HDMI 2
    Direct hardware device without any conversions
plughw:CARD=PCH,DEV=0
    HDA Intel PCH, CX20590 Analog
    Hardware device with all software conversions
plughw:CARD=PCH,DEV=3
    HDA Intel PCH, HDMI 0
    Hardware device with all software conversions
plughw:CARD=PCH,DEV=7
    HDA Intel PCH, HDMI 1
    Hardware device with all software conversions
plughw:CARD=PCH,DEV=8
    HDA Intel PCH, HDMI 2
    Hardware device with all software conversions[/color]


...didn't change any settings in alsamixer; output shows:
Card: HDA Intel PCH
│ Chip: Intel CougarPoint HDMI
│ View: F3:[Playback] F4: Capture F5: All
│ Item: Headphone [dB gain: 0.00, 0.00]
│ 00 00 MM
│ 58 100<>100 0<>0 100<>100 100<>100 MM 00 00 00 Enabled 0<>0
│ Master < Headphone > Speaker PCM Mic Boost S/PDIF S/PDIF 1 S/PDIF 2 Beep Auto-Mute Mode Internal Mic B
botanybear
Level 1
Level 1
 
Posts: 2
Joined: Sun Jan 05, 2014 11:54 pm

Linux Mint is funded by ads and donations.
 

Re: Headphone/Earbud Problem: Sound in one ear only (Mint 14

Postby botanybear on Mon Jan 06, 2014 1:01 am

UPDATE: Apparently Mint16 sort of half-solved the problem of the half-working headphones. In other words, each set of headphones works occasionally... most of the time the left ear has no volume.. It can't be hardware if 16 sort-of fixed a problem that happened all the time with 14...

Maybe a usb connection?

lsusb gives:
Code: Select all
[color=#008000]Bus 002 Device 004: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 04f2:b25f Chicony Electronics Co., Ltd
Bus 001 Device 003: ID 147e:2016 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub[/color]


Thank-you for any help. I want to get all of my hardware working *All of the time. (Also have other compatibility issues with the USB 2.0 drive, native camera, fingerprint reader as well as MyPassport external drive, but I will have to search the forums and perhaps make a few threads.) Anyone an X1 owner that has experienced similar problems?
botanybear
Level 1
Level 1
 
Posts: 2
Joined: Sun Jan 05, 2014 11:54 pm

Re: Headphone/Earbud Problem: Sound in one ear only (Mint 14

Postby dagon on Wed Jan 08, 2014 8:34 am

botanybear wrote:It can't be hardware if 16 sort-of fixed a problem that happened all the time with 14...

Hi! It can be very hard to see what is a hardware or a software problem.
Se if my answere here applies to your problem
http://forums.linuxmint.com/viewtopic.php?f=48&t=155500

(Also have other compatibility issues with the USB 2.0 drive, native camera, fingerprint reader as well as MyPassport external drive, but I will have to search the forums and perhaps make a few threads.) Anyone an X1 owner that has experienced similar problems?
Please make a separate post for these issues. People won't notice them if you put them in the end of a topic about something else.
Image
User avatar
dagon
Level 7
Level 7
 
Posts: 1690
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 8 guests