After update Mint 16 sound doesnt work propertly

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

After update Mint 16 sound doesnt work propertly

Postby piperoman on Tue Jan 07, 2014 9:29 am

I have updated today from Linux mint 15 to 16 (Petra), and sound doesn't work. I have ALSA installed, not PULSE.

Code: Select all
aplay -l


aplay: device_list:268: no soundcards found...

The hardward is detected

Code: Select all
lspci -v | grep Audio

00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
01:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)


So it's a drivers problem. I have tried adding:

Code: Select all
options snd-hda-intel model=auto index=-0


To /etc/modprobe.d/alsa-base.conf, after restart it doen't work neither.

And I have tried adding:

Code: Select all
snd_hda_intel


To /etc/modules, problem continues.

Have someone any idea how could I fix this?
piperoman
Level 1
Level 1
 
Posts: 4
Joined: Tue Jan 07, 2014 9:20 am

Linux Mint is funded by ads and donations.
 

Re: After update Mint 16 sound doesnt work propertly

Postby piperoman on Mon Jan 13, 2014 7:32 am

Bump
piperoman
Level 1
Level 1
 
Posts: 4
Joined: Tue Jan 07, 2014 9:20 am

Re: After update Mint 16 sound doesnt work propertly

Postby piperoman on Thu Jan 30, 2014 8:05 am

Still no working. Is possible to set Audrio drivers in version 15?
piperoman
Level 1
Level 1
 
Posts: 4
Joined: Tue Jan 07, 2014 9:20 am

Re: After update Mint 16 sound doesnt work propertly

Postby pezonik on Sun Feb 02, 2014 1:02 pm

I've been having a similar problem. Sound was working fine before, but now only the headphones work, not the speakers. I have a System76 Gazelle Professional (gazp7).

Code: Select all
aplay -l


**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: VT1802 Analog [VT1802 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 2: VT1802 Alt Analog [VT1802 Alt Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0


Code: Select all
lspci -v | grep Audio


00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)


Code: Select all
inxi -A


Audio: Card: Intel 7 Series/C210 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture ver: k3.11.0-12-generic


I also tried adding
Code: Select all
    options snd-hda-intel model=auto index=-0

to /etc/modprobe.d/alsa-base.conf, but it is not working
pezonik
Level 1
Level 1
 
Posts: 6
Joined: Thu Jan 28, 2010 2:46 am

Re: After update Mint 16 sound doesnt work propertly

Postby pezonik on Sun Feb 02, 2014 1:10 pm

It started working with

Code: Select all
sudo alsa force-reload


as found here

http://itsfoss.com/fix-sound-ubuntu-1304-quick-tip/
pezonik
Level 1
Level 1
 
Posts: 6
Joined: Thu Jan 28, 2010 2:46 am

Re: After update Mint 16 sound doesnt work propertly

Postby piperoman on Mon Feb 03, 2014 10:17 am

I had a problem with the group of sound.

Using

Code: Select all
sudo gedit  /etc/group


and adding my user (piperoman) to the line:

Code: Select all
audio:x:29:piperoman


And then,

Code: Select all
aplay -l


started to work:

Code: Select all
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: VT2020 Analog [VT2020 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: VT2020 Digital [VT2020 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 2: VT2020 Alt Analog [VT2020 Alt Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


I added into /etc/modprobe.d/alsa-base.conf too:

Code: Select all
options snd-hda-intel model=auto # https://help.ubuntu.com/community/HdaIntelSoundHowto https://www.kernel.org/doc/Documentation/sound/alsa/HD-Audio-Models.txt


After that, I launched:

Code: Select all
 gnome-alsamixer


Add some volume to my sound card, and then

Code: Select all
 speaker-test


works. Hope this help others. Thanks for the help.

All the best, Piperoman.
piperoman
Level 1
Level 1
 
Posts: 4
Joined: Tue Jan 07, 2014 9:20 am


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 5 guests