No login sound in MATE 1.6? (explained)

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

No login sound in MATE 1.6? (explained)

Postby norm.h on Tue Jan 07, 2014 10:18 am

I am running Mint 13 MATE.
Since updating Mate from 1.4 to 1.6 via the backports I have no login sound.
The only advice I could find was for Mint 12, but I tried it anyway:

viewtopic.php?f=42&t=86813&hilit=Mint+12+tips+%26amp%3B+tricks

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/*.desktop
gksu gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

These commands both displayed blank pages, and I can't get Gnome Login Sound to appear in my Start-up Applications:

Does this latest version of MATE not use a login sound, or am I doing / not doing something correctly?
Last edited by norm.h on Sat Jan 11, 2014 1:06 pm, edited 3 times in total.
norm.h
Level 3
Level 3
 
Posts: 140
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Linux Mint is funded by ads and donations.
 

Re: No login sound in MATE 1.6?

Postby karlchen on Tue Jan 07, 2014 12:12 pm

Hello, norm.h.

Assuming that the Control Center of Mate 1.6 on Mint 13 will look very similar to the Control Center of Cinnamon 2.0 on Mint 13 - an assumption which might prove terribly wrong - I'd say:
Launch the Control Center. Go down to the section "Hardware" and click on the icon "Sound".
Inside the "Sound" go to the tab "Sound Effects".

Cinn2.0_sound_soundeffects.png
Control Center - Sound - Sound Effects

Activate / de-active the sound effects to your liking.

Hm, comparing the "What's New" sections for Mint 16 Cinnamon 2.0 and Mint 16 Mate 1.6, I start being afraid that the sound effects dialogue might be specific to Cinnamon 2.0, because it is not mentioned for Mate 1.6. This in turn would mean that the backports can only bring to Mint 13 what is present on Mint 16 as well and that the needed Sound Effects dialogue might simply be absent from Mate 1.6.
(It is definitely missing on the xfce desktop, Mint 13 and Mint 16.)

HTH,
Karl
Image
Enlightened by Lucid Lynx, enchanted by Maya, impressed by Petra.
User avatar
karlchen
Level 9
Level 9
 
Posts: 2520
Joined: Sat Dec 31, 2011 7:21 am

Re: No login sound in MATE 1.6?

Postby norm.h on Tue Jan 07, 2014 1:14 pm

Hi Karl,
Thank you for your reply.
I've tried configuring my sound preferences several times, without success.
FWIW, it looks nothing like your screenshot, so there is quite a difference between the versions.
Guess I'm looking at a re-install to solve this?
norm.h
Level 3
Level 3
 
Posts: 140
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: No login sound in MATE 1.6?

Postby karlchen on Tue Jan 07, 2014 1:23 pm

Hello, norm.h.

I am not sure that a re-installation will solve the issue. - I have got the impression that this feature "sound effects" has been implemented into Cinnamon 2.0 first and that it has not been implemented in Mate 1.6, yet. Just like xfce does not have it. Definitely not.
So before re-installing I would try a Mint 16 Mate live system and find out whether the desired feature is present there. If it is not then there is no point in re-installing your system from the scratch, no matter whether you re-install Mint 13 LTS with the backported Mate 1.6 or whether you decide to switch to the short lived Mint 16 with Mate 1.6.
And of course, it may be worthwhile waiting a bit whether other (Mate) users chime in and can offer a solution which does not involve re-installing from the scratch.

Cheers,
Karl
Image
Enlightened by Lucid Lynx, enchanted by Maya, impressed by Petra.
User avatar
karlchen
Level 9
Level 9
 
Posts: 2520
Joined: Sat Dec 31, 2011 7:21 am

Re: No login sound in MATE 1.6?

Postby norm.h on Tue Jan 07, 2014 1:30 pm

Thanks again, Karl,
Actually I'm not in any hurry, as it's more of a niggle than a necessity.
I was just wondering if I'm doing something wrong, or missing something.
When I said re-install, I meant my original copy of Mint 13 LTS Mate 1.4 (backports NOT selected)
I'll hang fire for the time being to see if I get any other advice.
norm
norm.h
Level 3
Level 3
 
Posts: 140
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: No login sound in MATE 1.6?

Postby karlchen on Tue Jan 07, 2014 7:37 pm

Hello, norm.h.

Looking for a way of enabling system sounds for particular events on Mint 13 and above (Ubuntu 12.04 and above) with the xfce desktop, I came across 2 identical ways of achieving my goal.
One very structured tutorial is in German. Sorry. Xfce Systemklänge (Just see, it is explicitly based on the next instruction, the Ubuntu forum thread, linked to below.)
The same steps can be found on this thread page 2, in English: Xubuntu System Sounds - How To

I tend to assume that basically the same steps may apply to Mint 13 with the Mate desktop as well. Only difference must be that wherever xfce specific commands are used, you will have to find the corresponding Mate specific configuration dialogue. - No warranty given, it will work, though. But might be worth a try.

Kind regards,
Karl
Image
Enlightened by Lucid Lynx, enchanted by Maya, impressed by Petra.
User avatar
karlchen
Level 9
Level 9
 
Posts: 2520
Joined: Sat Dec 31, 2011 7:21 am

Re: No login sound in MATE 1.6?

Postby norm.h on Wed Jan 08, 2014 7:27 am

Thanks yet again, but I got stuck when I did:
cat /etc/X11/Xsession.d/52libcanberra-gtk-module_add-to-gtk-modules
I got "No such file or directory"
There is also this:
Quote: (in fact, they are no longer part of the libcanberra-gtk-module package - which seems to have migrated to gconf)
But I don't know where to look for it.
I also notice the posts are well over a year old - would this make any difference?
Perhaps the best idea is to wait to see if it gets sorted properly in Mate, and if not, resort to a reinstall as discussed earlier.

Regards
norm

EDIT: fwiw, I've found all the sounds in usr/share/sounds
It's just that I haven't got the GNOME Login sound in my Startup Apps.
Last edited by norm.h on Wed Jan 08, 2014 10:16 am, edited 1 time in total.
norm.h
Level 3
Level 3
 
Posts: 140
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: No login sound in MATE 1.6?

Postby karlchen on Wed Jan 08, 2014 10:07 am

Hello, norm.h

Missing file (s)/etc/X11/Xsession.d/52libcanberra-gtk-module_add-to-gtk-modules:
Toz wrote:In addition to the steps from post #1, creating these two files and rebooting has brought sound effects back for me
I.e. create the 2 files. Rebooting is not required. Logoff and logon will do.

Karl
Image
Enlightened by Lucid Lynx, enchanted by Maya, impressed by Petra.
User avatar
karlchen
Level 9
Level 9
 
Posts: 2520
Joined: Sat Dec 31, 2011 7:21 am

Re: No login sound in MATE 1.6?

Postby norm.h on Wed Jan 08, 2014 10:18 am

Hi,
Crossed posts - see EDIT in my previous post.
Sorry but I'm completely lost :(
norm
norm.h
Level 3
Level 3
 
Posts: 140
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: No login sound in MATE 1.6?

Postby norm.h on Wed Jan 08, 2014 10:27 am

karlchen wrote:Hello, norm.h

Missing file (s)/52libcanberra-gtk-module_add-to-gtk-modules:
T/etc/X11/Xsession.doz wrote:In addition to the steps from post #1, creating these two files and rebooting has brought sound effects back for me
I.e. create the 2 files. Rebooting is not required. Logoff and logon will do.
Karl

But isn't the instruction to create those files in the file that's missing?

Here is how. From a terminal window:
Code:
sudo leafpad /etc/X11/Xsession.d/52libcanberra-gtk-module_add-to-gtk-modules
...enter your password when prompted and copy/paste the following code:


Or should I create them in /etc/X11/Xsession.d
I substitute gedit for leafpad
norm
norm.h
Level 3
Level 3
 
Posts: 140
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: No login sound in MATE 1.6?

Postby norm.h on Wed Jan 08, 2014 11:07 am

Success, I've done it!
Took "guidance" from Step One in the Ubuntu link, and added "play usr/share/sounds/linuxmint-login.wav"
to my Startup applications ..
Many thanks for your interest and help.
norm
norm.h
Level 3
Level 3
 
Posts: 140
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: No login sound in MATE 1.6? SOLVED

Postby karlchen on Wed Jan 08, 2014 7:01 pm

Hello, norm.h.

Right. In fact the (German) instruction and the English Ubuntu forum thread, they are both about achieving two goals:
(1) getting a logon sound
(2) activating system sounds

In order to achive the first goal, getting a logon sound, it is sufficient to create a new startup application item which launches a command like e.g.
Code: Select all
play -q /usr/share/sounds/LinuxMint/stereo/desktop-login.ogg
The only prerequisite which must be fulfilled is that sox/play has been installed. This seems to be the case on Mint 13 by default.

All the more complicated steps are only needed in order to activate system sounds which should be played on prticular system events.

Cheers,
Karl
Image
Enlightened by Lucid Lynx, enchanted by Maya, impressed by Petra.
User avatar
karlchen
Level 9
Level 9
 
Posts: 2520
Joined: Sat Dec 31, 2011 7:21 am

Re: No login sound in MATE 1.6?

Postby norm.h on Thu Jan 09, 2014 6:49 am

Hi,
OK, so I've achieved the first goal, but although the sound files are there, they're not playing for particular events so I still have some work to do.
My posts above explain (I hope) the problems I have when trying to follow the Ubuntu procedure with regard to missing files etc.
I don't seem to have any sort of "canberra" file or directory.
Perhaps this is not part of Mate 1.6 anyway?
norm
EDIT:
I've done a search and found the canberra files, but none is preceded with 52.
How can I tell which one to add the codes to?
norm.h
Level 3
Level 3
 
Posts: 140
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: No login sound in MATE 1.6?

Postby norm.h on Thu Jan 09, 2014 7:38 am

Post deleted by norm.h
It was rubbish!

EDIT:
gconf (as mentioned in the Ubuntu thread) just has lots of "schemas", so I've followed the Ubuntu instructions and put the codes into:
/usr/share/doc/libcanberra-gtk-module
and /usr/share/doc/libcanberra-gtk3-module .
Hope this works - I'll not mark it SOLVED till I'm sure.
norm

EDIT 2:
Didn't work, so I've "undone" what I did.
Seems as though I'm not the only one - viewtopic.php?f=90&t=150598&p=786109&hilit=+sound+events+#p786109
norm.h
Level 3
Level 3
 
Posts: 140
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: No login sound in MATE 1.6?

Postby norm.h on Thu Jan 09, 2014 12:34 pm

OK, I found this here:
http://www.techsupportalert.com/content ... dition.htm

Change or Disable Login Sound (for Mint 13 to 15)
Each time when you login to Linux Mint, it may play a login sound. If you don't like to listen to it each time you login, you can easily disable it, or change it to your favorite sound.
1. Go to Menu > Administration > Login Window.
2. Under the "Accessibility" tab, change to a sound you like from the drop-down menu for "Login successful", click "Play" to try the sound if needed.
3. If you want to disable the log-in sound, untick "Login successful"
Log out and log back in to check the new setting for login sound. Similarly you can try out sounds for "Login screen ready" and "Login failed".


My: Menu > Administration > Login Window doesn't show an “Accessibility” tab, but since the page was updated on January 5th, we seem to be back to the difference being between Mate 1.4 & 1.6, as sounds were OK before I did the backported update.

There doesn't seem to be a way to “roll back” to Mate 1.4, so my options seem to be either a reinstall, or live with it.
Ah well, such is life!
norm.h
Level 3
Level 3
 
Posts: 140
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: No login sound in MATE 1.6?

Postby norm.h on Sat Jan 11, 2014 1:06 pm

Explanation HERE
norm.h
Level 3
Level 3
 
Posts: 140
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: Earl_Hickey and 15 guests