No Sound heard Mint 16

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

No Sound heard Mint 16

Postby lancekates on Wed Jan 08, 2014 2:37 pm

I've seen a couple other threads with a sound issue with Mint, but mine is a bit different and I didn't want to "threadjack"

I'm not 100% new to Linux, but new enough to be dangerous to myself and those around me.

I installed Linux mint 16 on my desktop and everything seemed ok but there was no sound. I followed steps found on other threads here and eventually caught on to updating my video driver (My audio comes through my sapphire radeon hd 7770 hdmi card) So I installed the AMD Catalyst and it fixed audio (yay!) but destroyed video (boo). In Mint it caused Cinnamon to crash upon boot. I got frustrated and swapped to Ubuntu 12.10 and had the same audio issue (and when I updated the amd catalyst drivers, it caused the video to defaul to 800x600 and I couldn't change it.)

So, this morning I wiped it all and went back to mint 16 (I prefer it anyway) and am still without audio. I went through some steps editing the default.pa file to include "set-card" line to poin to my output as an hdmi stereo card. Now, in pulse audio, I see the bar moving when I play videos, indicating that there IS sound, but I still hear nothing, whether I use the hdmi cable or the audio cable from the built in sound card (which was not necessary before my move to linx).

Here's what I see:
In Pulse Audio:

Playback has just "System Soudns" set to 100%
Recording has "No application is currently recording audio" (which is fine with me)
Output Devices has "Cape Verde/Pitcaim HDMI Audio [Radeon HD 77700/7800 Series\ Digital Stereo HDMI" and the port says HDMI Displayport 4.
Inpud Devices is blank like recording
Configuration says "Cape Verde HDMI Audio [Radeon HD 770/7800 Series] Profile Digital Stereo (HDMI) Output (it is a dropdown box with 3 of that same option and the fourth says "off"
belos that is "Built-in Audio" profile Off.

Now, when I click on the speaker icon and select "Sound Setings" I see the normal sound settings window. This shows:
Output: Play sound through "Analog Output Built in Audio" (this is the only option here)
On the right I see "Settings for HDMI / DisplayPort 4" with the left/right bar and the test button (which does nothing)

Volumes are all up at least 50% if not 100%.
lspci says:
Code: Select all
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation H61 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde XT [Radeon HD 7770 GHz Edition]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)


so, perhaps even more frustrating than just not having sound.... it LOOKS like there is sound but I hear nothing.

I even went so far as to hook up my monitor to my blue ray player and played a movie (I needed the break) and the sound is fine.

Help?
lancekates
Level 1
Level 1
 
Posts: 1
Joined: Wed Jan 08, 2014 2:19 pm

Linux Mint is funded by ads and donations.
 

Re: No Sound heard Mint 16

Postby davidlatapie on Sun Feb 02, 2014 9:36 pm

Hi,

That should help you. Here is the copy of the mail I sent to Compulab (who build the MintBox 2 I bought 2 weeks ago). It sums up quite well my situation and a little bird told me yours too! Even if you don't have a Mintbox. You probably have an Intel chipset for the sound and a connected HDMI port and this seems to be the core of the issue (that and using Linux with ALSA+PulseAudio).

Reproductible bug: very muffled sound

Step to reproduce (from a live CD/USB, for instance) :
  1. Be sure to have working speakers connected to the S/PDIF output (jack connectors, not USB connectors).
  2. Boot from a Linux Mint 16 live CD/USB drive.
  3. Once on the desktop, press the Windows key to get to the main menu
  4. Type "Sound" then press "enter".
  5. On the opening Sound window, go straight to the "Sound effect" tab. This is important; don't do anything else in-between.
  6. Press the right-pointing triangle right of the login.oga sound to play the sound. You should hear it (=> not a hardware problem).
    So far, so good. Now the bug which had been plaguing me for two weeks, since the very day I received the Mintbox.
  7. Still on the same "Sound" window, go back to the "output" tab. Notice the "play sound through" has nothing selected. Again, don't do a thing here; just go back to the "Sound effect" tab.
  8. TADAM! Try playing a sound. ANY sound. You can't.

Attempted workarounds:
  1. Works (seems so):
    • Install Manjaro Linux and muse in sound parameters too. Same issue arises but can be fixed with
      Code: Select all
      sudo nano /etc/modprobe.d/alsa-base.conf
      then
      Code: Select all
      options snd-hda-intel model=generic
      (link). Note it won't fix Linux Mint's problem. It's only that, if you switch to Manjaro, you won't experience this issue anymore (yeah, I know it sounds almost like a Manjaro commercial ^^)
  2. Works (sort of):
    • Reinstall the OS (and don't reproduce step 7 this time)
    • Create another account (and don't reproduce step 7 on this account). I won't fix the problem on your account, it is just that, at least, you'll be able to hear sound from another account - that's why I call it fix "sort of". Source
  3. Fails:
    • Several other parameters in /etc/modprobe.d/alsa-base.conf
      Code: Select all
      options snd-hda-intel model=hp
      options snd-hda-intel model=hp-dv5, enable_msi=1
      options snd-hda-intel index=0
      options snd-hda-intel index=1
      options snd-hda-intel position_fix=1
      options snd-hda-intel position_fix=2
      options snd-hda-intel model=pulseaudio position_fix=0
      options snd-hda-intel model=3stack
      options snd-hda-intel model=generic
      options snd-hda-intel model=auto
      alias snd-card-0 snd-hda-intel
      alias sound-slot-0 snd-hda-intel
      alias sound-slot-0 snd-card-0
      alias sound-service-0-0 snd-mixer-oss
      alias sound-service-0-1 snd-seq-oss
      alias sound-service-0-3 snd-pcm-oss
      alias sound-service-0-8 snd-seq-oss
      alias sound-service-0-12 snd-pcm-oss
    • Install Debian-testing and muse in sound parameters too. Same issue arises but contrary to Manjaro Linux, it cannot be fixed => not a Linux Mint-specific issue, but a Debian-wide one (Debian, Ubuntu...).

Possible hint: my monitor is connected on the HDMI port (it is a VGA-only monitor with no speaker) and my sound is connected via the S/PDIF out, with a regular 3,5" jack. It is possible that, once the device is selected, Linux Mint and Debian (well, really ALSA or PulseAudio) continue sending the sound but... send it to the video display!

Other hint: this page in French seems to implies that it may be a "simple" matter of finding the right parameter for XXXX
Code: Select all
options snd-hda-intel model=XXXX


Below is a list of what I found. Hope it will help.

lspci tells me that the audio chipset for my Mintbox is:
Code: Select all
Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)


cat /proc/asound/pcm tells me this:
Code: Select all
00-00: ALC888 Analog : ALC888 Analog : playback 1 : capture 1
00-01: ALC888 Digital : ALC888 Digital : playback 1 : capture 1
00-03: HDMI 0 : HDMI 0 : playback 1
00-07: HDMI 1 : HDMI 1 : playback 1
01-00: USB Audio : USB Audio : capture 1


grep "Codec:" /proc/asound/card*/codec* has that for me:
Code: Select all
/proc/asound/card0/codec#0:Codec: Realtek ALC888
/proc/asound/card0/codec#3:Codec: Intel PantherPoint HDMI


alsamixer, finally:
Code: Select all
Soundcard: pulseaudio
Chipset: pulseaudio


The BIOS is on default setting. Furthermore, I tried by tweaking the BIOS settings, it did not change a thing. Anyway, it definitely is not a BIOS issue, since the sound works well on a Linux Mint live CD.

I hope it will help. Both you and potential ALSA/PulseAudio developpers
davidlatapie
Level 1
Level 1
 
Posts: 2
Joined: Sun Feb 02, 2014 9:06 pm

Re: No Sound heard Mint 16

Postby Mintboxfan on Wed Apr 16, 2014 12:56 pm

Having tried out mint 16 cimarron on my Windows PC I concluded that this is the ideal operating system to replace XP. As my old Windows PC is very old now and had to be replaced anyhow, I acquired a Mintbox 2, replaced the hard disk with an SSD and installed Linux Mint from an USB stick. Everything works beautifully with exception of sound. There is no sound in the in the analog jack and also no sound in a TV connected with via HDMI. The tray shows intern audio stereo (IEC 958). I can change this with pavocontrol, but without effect. Sound control offers only digital stereo, and the alsa mixxer shows only digital audio cards, no pulse audio only hda Intel PCH. To get sound I finally attached an USB Speaker which works and is shown in the tray, soundcontrol window and alsamixer.

I would appreciate any comment, tips, help or atleast to hear from someone who has a mintbox 2 with cimarron with working analog sound from the jack, since I would like to get analog sound in my earphones.

Thankyou for an answer

Mintboxfan
Mintboxfan
Level 1
Level 1
 
Posts: 1
Joined: Wed Apr 16, 2014 12:29 pm

Re: No Sound heard Mint 16

Postby davidlatapie on Wed Apr 16, 2014 4:53 pm

I found only one "solution":
backup your data, reinstall, NEVER ever go the sound settings panel - hardly a satisfying one, I know.
I was able to a patch with Manjaro Linux, but none for Linux Mint (by the way, Manjaro Linux is faster than Linux Mint and I believe this is not only because of XFCE)
davidlatapie
Level 1
Level 1
 
Posts: 2
Joined: Sun Feb 02, 2014 9:06 pm

Re: No Sound heard Mint 16

Postby Horck on Thu Apr 17, 2014 3:21 pm

Hi sorry if I waist your time, I had this issue and I searched this thread for "options snd-hda-intel probe_mask=1 model=auto" and didnt get a hit.

What I did was add

options snd-hda-intel probe_mask=1 model=auto


To the end of the file "/etc/modprobe.d/alsa-base.conf"

After I did that I rebooted and now I have to enter this command at prompt every time i boot up again: sudo alsa force-reload
Horck
Level 1
Level 1
 
Posts: 24
Joined: Thu Apr 17, 2014 3:10 pm

Re: No Sound heard Mint 16

Postby Horck on Thu Apr 17, 2014 3:42 pm

sry if this is a double post but try:

Code: Select all
pico /etc/modprobe.d/alsa-base.conf


scroll down to the end and enter this line:

Code: Select all
options snd-hda-intel probe_mask=1 model=auto



Then I rebooted and now I have to type
Code: Select all
alsa force-reload
every time for the sound to work.
Horck
Level 1
Level 1
 
Posts: 24
Joined: Thu Apr 17, 2014 3:10 pm


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 6 guests