Sound ok but keys don't control volume any more [solved]

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Sound ok but keys don't control volume any more [solved]

Postby fiddlesticks on Sun Jan 12, 2014 3:11 am

It seems this new problem is due to my in-place upgrade to Petra, which otherwise seemed to go very smoothly. With Olivia (Mate) everything worked fine.
I still have sound, and I can still control the volume with the Mate volume control applet, but now my keyboard's volume up/down keys don't work any more. The brightness up/down keys still work, but the volume keys just bring up a display showing zero volume which won't go up (this display always shows zero volume regardless of the volume setting in the applet). So I'm thinking that the voume keys are trying to control something else and getting confused about what is controlling the volume.

I'm a bit stuck, how do I diagnose this? Could this be something to do with pulseaudio? Like, my system isn't using pulseaudio but my keyboard keys are trying to get/set the pulseaudio volume or something like that? I've no idea how these things are configured.
Last edited by fiddlesticks on Tue Jan 14, 2014 6:52 am, edited 1 time in total.
fiddlesticks
Level 1
Level 1
 
Posts: 13
Joined: Wed Jul 31, 2013 3:01 pm

Linux Mint is funded by ads and donations.
 

Re: Sound ok but keys don't control volume any more

Postby JoeBingo on Sun Jan 12, 2014 3:32 am

Take a look at Control Center > Keyboard Shortcuts. Are you able to change those controls?
JoeBingo
Level 3
Level 3
 
Posts: 123
Joined: Fri Jun 24, 2011 4:18 pm

Re: Sound ok but keys don't control volume any more

Postby fiddlesticks on Sun Jan 12, 2014 1:08 pm

Nice idea, and worth a try.
I can change the "volume up" command to Alt+U, and it's recognised (when I press Alt+U, the volume control overlay appears), but as before it doesn't actually increase the volume, it stays at minimum. And I can change it back to my regular keyboard shortcuts and exactly the same thing still happens.
fiddlesticks
Level 1
Level 1
 
Posts: 13
Joined: Wed Jul 31, 2013 3:01 pm

Re: Sound ok but keys don't control volume any more

Postby JoeBingo on Sun Jan 12, 2014 3:33 pm

Also in Control Panel, click on Keyboard in the Hardware section. Check the Layouts tab in the Keyboard Preferences. Maybe click on Reset To Defaults and/or take a look at/change the Keyboard Model specified. The Keyboard Model on both my desktop and laptop computers is set to Generic 105-Key (INTL) PC by OS installation default configuration and volume controls work fine but the Keyboard Model could be changed to a vendor specific model.
JoeBingo
Level 3
Level 3
 
Posts: 123
Joined: Fri Jun 24, 2011 4:18 pm

Re: Sound ok but keys don't control volume any more

Postby fiddlesticks on Tue Jan 14, 2014 6:52 am

Problem solved, I just don't know how :)
I tried changing a few settings, but it still didn't work. I tried from the live image (everything worked fine), I tried with a new user (everything worked fine) and then tried as myself again (and everything now works fine). I have no idea if it's because I changed anything, or just because I rebooted (although it had already been rebooted since the Petra upgrade).
In any case, thanks for your suggestions!
fiddlesticks
Level 1
Level 1
 
Posts: 13
Joined: Wed Jul 31, 2013 3:01 pm


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 2 guests